Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Page 2 of 6 FirstFirst 1234 ... LastLast
Results 11 to 20 of 52
  1. #11
    Member +
    Join Date
    Jul 2015
    Location
    Belgium
    Posts
    38
    Rep Power
    0

    Default

    Thanks for your answers. I perfomed as Butters suggested. I cleared the nonvol but after the problem still remains. It meens whae i connect the device to the computer, open Garminexpress i seen there are several updates including maps. So to not spend to much time to update everyting i try just to update the software version from 4.10 to 5.90. After update, disconnect the device from the computer ande connect it back after 5 seconds, garminexpress shows the same update available again. The devise has not been updated. What more can i do? As just a test a added by means of the computer a map with a random textfile. After diconnect the device from teh computer an reconnect the device, i see this last added map including the text file has vanniched? exactly what happens to the maps. I still wonder what's wrong with the device.
    Kind regards,
    Francis.

  2.    Advertissements


  3. #12
    Master asprin624's Avatar
    Join Date
    Aug 2009
    Location
    Belgium
    Age
    72
    Posts
    795
    Rep Power
    340

    Default

    @fchody,

    Like I asked before:

    Show me a screen shot of your DriveSmart 50 in Garmin Express
    Then show a screen shot of your DriveSmart 50 when you click on it.
    The show a screen shot of the updates that are there.

    Click on view updates:

    There is something you are doing wrong and with out a clear picture of what you are doing it is had to know what mistakes you are making.

    Because we can keep going around in circles with this.

    These are examples of Garmin Express

    Spoiler: First step
    qIkBdhn


    Spoiler: second step view details
    K925sgV


    Show what is there to update
    Installed maps or firmware updates do not just disappear after they have been installed
    Last edited by asprin624; 28th March 2020 at 05:14 PM.

  4. #13
    Master Butters's Avatar
    Join Date
    Jul 2017
    Location
    CA
    Posts
    899
    Rep Power
    140

    Default

    Quote Originally Posted by fchody View Post
    ............... i try just to update the software version from 4.10 to 5.90. After update, disconnect the device from the computer ande connect it back after 5 seconds, garminexpress shows the same update available again. The devise has not been updated.
    Did you let it reboot so that it can LOAD the new firmware? It seems not if your quote "connect it back after 5 seconds" is literally what you did. When GE 'updates' the firmware it simply writes a new GCD file to the device's .System folder, the components of that GCD are then flashed (loaded) by the device itself to the various regions as part of the next boot cycle. Additionally, during boot an updated GarminDevice.xml file is written by the device into its Garmin folder, overwriting the existing file. If that XML file isn't updated then GE on reading it will sense that the older fw is still loaded and offer the latest GCD file again. Your understanding of this process is key to fixing this device. Your earlier posts seem to indicate that you have allowed the device to reboot however, so if you still can't get the device to update from a GCD file there are other methods, i.e. using an RGN file in preboot mode or flashing individual BINs via media card. It might even be necessary to re-format the device correctly. Do you know the history? Did you or your BinL reformat it at some stage and if so, how? If the device is not updating fw and rewriting the XML on boot cycle then it may indicate physical flash damage or it may only be that there is minor corruption in one of the firmware regions, probably rgn14 where fw_all.bin is flashed. The former is fatal, the later is easily fixed by flashing a healthy BIN file.

    Give as much info as you can so we can diagnose this problem. The smallest detail may be be important, even if it seems irrelevant to you.

  5. #14
    Member +
    Join Date
    Jul 2015
    Location
    Belgium
    Posts
    38
    Rep Power
    0

    Default

    Hallo, first off all thanks for helping me. Please notice English is not may native language but i do my best. I will try to give you as much info as possible by inserting some screenshot i made during connecting and attempting to update my device. This first image shows my DrSm is connected to GE(
    Spoiler: pic1
    [Only registered and activated users can see links. ])
    . After GE shows available updates (
    Spoiler: pic2
    [Only registered and activated users can see links. ])
    . The next image shows the content of the DrSm(
    Spoiler: pic3
    [Only registered and activated users can see links. ]
    and than the deploued Garmin map this all before update(
    Spoiler: pic4
    [Only registered and activated users can see links. ]
    . The next image shows the available device software which is the 5.90(
    Spoiler: pic5
    [Only registered and activated users can see links. ]
    ). To save time i will first only try to update this device software fro 4.10 to the latest 5.90 as you can see in this picture:
    Spoiler: pic6
    [Only registered and activated users can see links. ]
    . So after the update completed, i disconnected the device from the computer and start it again. After the device started up i went to look in the settings of the device. Also there i saw nothing has changed. The software version is still at 4.10. I reconnected the device to the computer and started GE again. In GE i could see the same updates are still available as befor and GE shows also the software version 4.10 as before (
    Spoiler: pic7
    [Only registered and activated users can see links. ]
    ). Also in the deployed Garmin folder shows the sam as before. When i update the maps, also i can see there has no maps been added to the Garmin folder even GE says everything has been updated. I hope you can follow because the language of GE is Dutch. I hope also i provided enough information for you to help me. If not i'll do my best to provide more needed info.
    Kind regards and thanks a lot for spending time to help.
    Francis.
    Last edited by Boki_Srb; 29th March 2020 at 02:19 PM. Reason: spoilers!

  6. #15
    Master asprin624's Avatar
    Join Date
    Aug 2009
    Location
    Belgium
    Age
    72
    Posts
    795
    Rep Power
    340

    Default

    I thank you for the info you posted.

    First thing I see no access to .system folder.
    Spoiler: .system folder
    RrAnSVy

    Next on the SmartDrive the map is installed in the folder .system.
    Spoiler: Map will be found there.
    lNvjUfl

    The file name is gmapprom.img

    The second place the map is installed is here:
    Spoiler: In the folder Map

    N7V2aXx


    When you are installing full coverage of Europe 2020.30

    It is for most of the newer Garmin Units the same locations.

    I find if I use a file browser XYplorer it let you see that folder with out having to do anything.
    But it can be seen in the Explorer too as long as you put the SmartDrive 50 in MASS Storage mode

    IF you do things correctly you get this

    Spoiler: Map or firmware all updated

    sba6yRJ


    Yours will show a different firmware update.


    Plus you show 13 updates.

    Do the updates one at a time remove the SmartDrive 50 from PC each time and turn on the unit wait till it does it's updated.

    It could take a couple of minutes to do so.
    With the firmware it could take longer.
    Then reconnect and do the next update.
    Repeating the steps each time for every update.

    Till all the updates have been completed.

    Do not rush any of it.

    How to see everything with the Windows Explorer
    Spoiler: THe How Too to view .system folder.

    BNYbs1E
    Qyn8TjC
    Last edited by asprin624; 30th March 2020 at 10:25 AM.

  7. #16
    Member +
    Join Date
    Jul 2015
    Location
    Belgium
    Posts
    38
    Rep Power
    0

    Default

    Hallo,

    First of all, i modified in the Hidden files and folders into "Show hidden files and folders and drives. In the DriveSmart tree i dont see the map .System
    Spoiler: large image
    [Only registered and activated users can see links. ]

    This file is not present on my DriveSmart. My brother in-Law confirmed me he has never tried to perform an undate as he dont have the knowledge to perform this. Ver strange is the device worked properly untill i connected it to GE. I think the sofware should be re´nstalled but i dont wher or how i could do so? As i can see in the pictures you provided in your reply compared to my icluded picture in this reply, several maps are missing in my device.

    Francis.


    Use spoilers for large pictures. Respect all other rules as well. Read carefully:
    [Only registered and activated users can see links. ]
    and
    [Only registered and activated users can see links. ]
    Last edited by Boki_Srb; 30th March 2020 at 04:14 PM. Reason: SPOILER!

  8. #17
    Important User Problem Updating DriveSmart50 using GarminExpress FireFox58's Avatar
    Join Date
    May 2009
    Location
    Florence - Italy
    Posts
    196
    Rep Power
    366

    Default

    @[Only registered and activated users can see links. ]
    As stated above by Aspirin624 Garmin Drive series are MTP Devices, you must enable "Mass Storage Mode" on Device to view \.System folder
    To enable the "Mass Storage Mode", like the previous series, proceed as follows:

    1. From the Map screen, touch the speed icon to access the Travel Panel.
    2. Press and hold the Direction / Speed indicator for about 10 seconds until a hidden Diagnostics menu appears
    3. Scroll to "MTP Settings", set to "Mass Storage" and Save settings.
      The Menu should appear like follow
      MTP SETTING
      MTP Auto Detect
      Mass Storage
      Mass Storage Single Session
    4. Now your Nuvý is exactly like those of the old series (including .System folder)


  9. #18
    Master Butters's Avatar
    Join Date
    Jul 2017
    Location
    CA
    Posts
    899
    Rep Power
    140

    Default

    Quote Originally Posted by fchody View Post
    First of all, i modified in the Hidden files and folders into "Show hidden files and folders and drives. In the DriveSmart tree i dont see the map .System
    That picture of the DS's tree indicates that you may have Mass Storage set on your DS and it's connected in MSM to the computer however in addition to enabling the radio button next to "Show hidden files, folders and drives", you may also need to uncheck "Hide protected operating system files" in Control Panel>File Explorer Options>View. Set it like this:
    Spoiler: Image
    [Only registered and activated users can see links. ]

    MTP connection looks like this before expanding:
    Spoiler: Images
    [Only registered and activated users can see links. ]

    Or this, depending on Display view:

    [Only registered and activated users can see links. ]

  10. #19
    Master asprin624's Avatar
    Join Date
    Aug 2009
    Location
    Belgium
    Age
    72
    Posts
    795
    Rep Power
    340

    Default

    Everyone has tried to help you out here.

    If you do not do what is told to do you will still have problems.
    Update all what is showing in Garmin Express no if, and or buts about it.

    As for what your brother inlaw did or didn't do is not relevant here.
    This is about you paying attention to what needs to be done.

    As you can see from you screen shot you are missing folders.
    Plus .system folder is there you just need to do the steps to see it.

    I have showed you how to view it along with Butters and FireFox58 who are all experts with Garmin products.

    No more can be said in the matter that has not already been shown to you.
    But if you are not going to do any of this then we have just wasted are time on you.
    So please do what is told of you to do.
    Last edited by asprin624; 31st March 2020 at 09:36 AM.

  11. #20
    Member +
    Join Date
    Jul 2015
    Location
    Belgium
    Posts
    38
    Rep Power
    0

    Default

    Dear I performed as you suggested and now i see the complete content of my DS's tree. This picture show the tree before update:
    Spoiler: first large pic
    [Only registered and activated users can see links. ].

    In this next picture you can see the .system folder deployed before update:
    Spoiler: sedcond large pic
    [Only registered and activated users can see links. ].

    in this picture uou can see the gmapprom.img file. This file is up to 4GB large before update. Now again i made a complete update as suggested by GE. Next picture show the available updates in GE:
    Spoiler: large pic again
    [Only registered and activated users can see links. ].

    Now i do a complete update of the 13 avilable updates and exactly what GE ask me to do:
    Spoiler: third large pic
    [Only registered and activated users can see links. ].

    GE ask me to disconnect and reconnect after 5s the device.
    Spoiler: pic 4
    [Only registered and activated users can see links. ]

    In the next picture GE continue to update the map:
    Spoiler: pic5
    [Only registered and activated users can see links. ].

    Next picture shows GE update completed.
    Spoiler: pic6
    [Only registered and activated users can see links. ]
    .
    Before disconnet the device from the PC i made a screehot of the .system folder. In this picture you can see the gmapprom.img in the .system folder has changed his size. It went from up to 4 GB into approximatly 2.6GB. Now i disconnected
    and reconnected it the device from the PC as the updates are completed. Now GE shows again the same updates as before.
    Spoiler: pic7
    [Only registered and activated users can see links. ].

    The screenshot of the deployed .system folder afteer update shows the gmpapprom took his original size again up to 4GB. See picture:
    Spoiler: pic8
    [Only registered and activated users can see links. ]

    So nothing has changed. The device even dont show the map exepted only the basemap. I do not understand what i have could been done wrong.
    Anyway thanks for your patient,

    Francis
    Last edited by Boki_Srb; 31st March 2020 at 12:20 PM. Reason: spoilers!

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •