Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Results 1 to 8 of 8
  1. #1
    Master janch's Avatar
    Join Date
    Jun 2010
    Location
    Hell
    Posts
    1,490
    Rep Power
    325

    Default iGO on Navigon Canada 310

    Hi guys

    I'm struggling with iGO installation on Navigon Canada 310. Default navi runs from SD and I upgraded maps to 2018.Q1. So no problem with Navigon. But now I wanted to play around and I have added also Primo. I found one unlock menu where I can choose between Navigon an Primo (+all necessary progs). Unlock menu is launched on boot from SD as UpdateMe.exe with UpdateMe.nfSM file where are all paths to different programs, hoewer my interest is Primo only. I set the paths and primo starts and works perfectly but with one well known problem - no satellites are visible. Correct port is 7, baud 57600 as i checked from Navigon settings and also got the same result with iGO8 automatic detection. It's interesting that iGO8 and Primo don't complain about gps hw detection, but the satellites bar is always empty as it cannot see any. I know that this problem is well known with navigon devices and it can be solved with port splitter..I tried with it also, but I'm not really sure how to use it. I cannot set input values to 7/57600 (I can choose baud 57600, but I cannot chose port 7)

    [Only registered and activated users can see links. ]

    any suggestions are more than welcome..
    Last edited by janch; 18th July 2018 at 11:13 PM.

  2.    Advertissements


  3. #2
    Master janch's Avatar
    Join Date
    Jun 2010
    Location
    Hell
    Posts
    1,490
    Rep Power
    325

    weel

    Ok, I figure it out..it's all about this port splitter and it's correct values (device specific). For this Navigon I had to set input to NMRX 2020 driver and baud 57600, added output to port 5 and than Start. Finally I set GPS and port values in Primo to 5 / 57600 and bingo!

    Only problem is that Port splitter won't remember settings after device reset/restart. That could be really annoying..

    Below is my simple unlock (SD) version if somebody ever needs it. It includes iGO primo 2.0 as this is the only stable version for this device. I have tested many, but all crashed after the language selection (even Primo 1.1 and 1.2). I also edit the script so the PortSplitter is automatically launched along with iGO Primo. But after device reset or restart, you need to manually launch port splitter - go to Explorer icon (or Total Commander) than go to folder \Storage Card\PortSplitter\ and launch Port.exe. Configure settings as described above, confirm and exit, launch Primo. Until you just power off/on device, settings will be preserved.

    Yandex:
    Spoiler:
    Code:
    Please Login or Register to see the links

    Zippyshare:
    Spoiler:
    Code:
    Please Login or Register to see the links

  4. #3
    Junior Member stevoxxxx's Avatar
    Join Date
    Mar 2017
    Location
    Slovakia
    Posts
    7
    Rep Power
    0

    Default

    I'm trying to Navigon 70 + .Miopocket 4 designed for the Navigon 2100 there works in the root directory.

  5. #4
    Junior Member
    Join Date
    Jun 2019
    Location
    home
    Posts
    1
    Rep Power
    0

    Thumbs up Re-upload

    Quote Originally Posted by janch View Post
    Ok, I figure it out..it's all about this port splitter and it's correct values (device specific). For this Navigon I had to set input to NMRX 2020 driver and baud 57600, added output to port 5 and than Start. Finally I set GPS and port values in Primo to 5 / 57600 and bingo!...
    Hi,

    Thank you for sharing and for the trial and error. Could you reupload the file please. On Yandex is gone and Zippyshre is geographically blocked for me.

    I trying to bring this up to date with maps to gift it, and would rather stick with the original soft so the new owners don't have to jump through hoops to use it.
    I haven't read the forum on this unit on how to update the original maps (if that's even possible) but I will.
    In your opinion will this be a decent GPS unit with updated maps for a people that are not computer literate (I cannot test it on the road as I don't drive)

    Thanks again!
    Last edited by Boki_Srb; 23rd July 2020 at 10:06 PM. Reason: quote shortened, approved

  6. #5
    iGO Enthusiast iGO on Navigon Canada 310
    iGO on Navigon Canada 310iGO on Navigon Canada 310iGO on Navigon Canada 310iGO on Navigon Canada 310iGO on Navigon Canada 310iGO on Navigon Canada 310
    Boki_Srb's Avatar
    Join Date
    Jun 2014
    Location
    Ni
    Age
    48
    Posts
    4,302
    Rep Power
    2683

    Default

    Quote Originally Posted by gcourie View Post
    ...Zippyshre is geographically blocked for me.
    Use Opera with VPN service activated

    Anyway, both uploads are dead...
    Before asking a question, know it's already discussed here and at 99.9% is not unique. Use search.
    NO ONE IS A SEER, READ (click on): [Only registered and activated users can see links. ] <- Click!
    [Only registered and activated users can see links. ] <- Click!

    Spoiler: obs
    Many questions become very arduous, a lot of time chewed deja vu...Since we have lost all the year of work and effort, many people have no will to answer the same questions again. Me neither. Use a search, please.

  7. #6
    Junior Member stevoxxxx's Avatar
    Join Date
    Mar 2017
    Location
    Slovakia
    Posts
    7
    Rep Power
    0

    Default

    If the Canada 310 is similar to the Navigon 2100, here's this should be working iGO8 on the SD card:

    Spoiler: Download
    [Only registered and activated users can see links. ]


    Link renewed
    Last edited by stevoxxxx; 6th September 2020 at 08:44 AM.

  8. #7
    Member
    Join Date
    Jan 2014
    Location
    Subotica, Serbia
    Age
    44
    Posts
    14
    Rep Power
    0

    Default

    For PortSplitter.exe you need to have settings.dat file when you start setup, and after that it works every time... Im on vaccation now, but I will upload script with iGO8... all you have to do is to be pattient for two weeks iGO on Navigon Canada 310

  9. #8
    Member
    Join Date
    Sep 2020
    Location
    Mostly Germany.
    Posts
    16
    Rep Power
    0

    Default

    Hi! I used Boki_Srb's link from here to get the WinCE Menu:

    [Only registered and activated users can see links. ]

    And stevoxxxx's iGO8 package works flawlessly on my Navigon 40 Plus! Well, except for TMC. But GPS is possible!

    To (shamelessly) quote myself:

    PortSplitter (or more correctly "Port.exe") needs to be started once to set the GPS-device up properly. So best to have PortSplitter as a startable app in the start menu to access it easily. Port 7 and 4800 baud seems to be correct for the 40 Plus. (And the settings are stored once you exit PortSplitter properly.)
    Last edited by ThePatcher; 20th September 2020 at 07:34 AM.

 

 

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •