Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Page 1 of 2 12 LastLast
Results 1 to 10 of 20
  1. #1
    Member
    Join Date
    Feb 2011
    Location
    UK
    Age
    43
    Posts
    14
    Rep Power
    0

    Default Unlock Mio 7700LM to run iGo Primo - is that possible.

    Any help or advice would be most appreciated.

    Thanks fopr reading.

  2.    Advertissements


  3. #2
    Super Member
    Join Date
    Dec 2010
    Location
    USA
    Posts
    154
    Rep Power
    43

    Default

    Did you look here: [Only registered and activated users can see links. ]
    ALWAYS back up your device first before doing ANY editing!

  4. #3
    Member
    Join Date
    Feb 2011
    Location
    UK
    Age
    43
    Posts
    14
    Rep Power
    0

    Default

    Hi chas521, thanks for replying. You helped me once before for which many thanks. I will give that a go later - thanks again.

    Edit:

    Hi again chas521. Can I clarify a couple of points from the post you pointed me to.
    My Mio 7700LM seems to have an internal memory only - it has what looks like an SD slot, but no SD card in it. Do I understand correctly that I connect the device to my PC then;
    1) Delete everything on the drive that shows up in windows
    2) expand the contents of the RAR file you uploaded, then copy it to the internal drive
    3) Detah the device from the PC and restart it

    The 7700LM does not have a mio button (unlike the other mio 687 I have, which has 2 buttons on the face of the device) - so I will not be able to press the mio button on startup.
    In your rar file structure I don't see all the same folders as I have on my mio 687 (that you helped me unlock before) - I am presuming I will still be able to run the Primo software I am used to in some way.

    I just want to try and make sure I don't screw something up because I don't understand properly. Thanks very much for the help, it is much appreciated.

    Hi again chas521.

    Deleted contents of internal drive - replaced with contents of your RAR file. When restared it gets to a single screen showing 'Mio' All About You - but does not seem to progress further. As I mentioned there is an SD slot but there is nothing in it at the moment. I could put one in there but what should it contain ? Also, I dont have a 'mio' button (as far as I know) - not sure what to do about that.

    Anyway, thanks for looking I appreciate it.
    Last edited by ramses505; 4th December 2020 at 06:02 PM. Reason: change CD to SD

  5. #4
    Super Member
    Join Date
    Dec 2010
    Location
    USA
    Posts
    154
    Rep Power
    43

    Default

    First of all, I hope that you first backed up all the contents of your internal drive first before you edited!! After you applied the unlock, did you press the power button to start it up then pressed the Mio icon? That's how you get to the unlock.
    ALWAYS back up your device first before doing ANY editing!

  6. #5
    Member
    Join Date
    Feb 2011
    Location
    UK
    Age
    43
    Posts
    14
    Rep Power
    0

    Default

    Hi again chas521 - thanks very much for replying.

    I did do a backup, but I used MioMore rather than a straight copy and paste (which is my own stupidity). As I cannot connect to MioMore at the moment I don't have a way of doing a restore - but that is another matter and nothing to do with you trying to help me for which I am very grateful.

    I folleowed the post you pointed me to - copying the files to the internal memory of the device which sadly only boots to an orange mio screen but no further. I had trouble following the other parts of the post namely;

    1) Copy the program to your SD card. Add contents [maps and such]. - what program ?

    To use the unlock, press the Miomap button when the device starts and it will switch to the unlock. - I only have an On/Off button, nothing else on the SatNav.

    There is an SD drive bay - I do have a card I cold use but I have no idea what needs to be on it as the instructions don't say as far as I can divine.

    Thanks very much for helping me I really appreciate it. Any further instruction most welcome.

    Thank You.
    Last edited by ramses505; 4th December 2020 at 06:10 PM.

  7. #6
    Master janch's Avatar
    Join Date
    Jun 2010
    Location
    Hell
    Posts
    1,745
    Rep Power
    554

    Default

    Unfortunately unlock menu which you are trying to use cannot work on your Mio, because it's not properly coded for this Mio type! And that's the reason you are stuck on the welcome screen. Mio 7700 gets commands in boot sequence from \My Flash Disk\Program Files\Navman\appstartupsec.ini file which is clearly missing in the unlock. Can you still connect device with the PC so you can see it's flash disk? If so, than It's not a big problem. If not, than the only way to un-brick it is from SD script.

    Also please check MioMore app, there should be backed up files from your device if you really did a backup. You can manually search it, most probably is stored somewhere in My Documents folder..Or check Miomore settings where you can usually set path for a backup folder..If you find it, please send me a file device.xml which is located in the Flash disk root. From that file I can create SD version of the unlock which will solve the problem.

    later edit:

    I think I got the file so this SD unlock should do the trick:

    Spoiler:
    Code:
    Please Login or Register to see the links


    unrar, and copy folders Magnetic_S5000, Progs and slide to empty fat32 formatted SD card. Restart device with the SD card. It should boot into a new ulock menu. Report back.
    Last edited by janch; 4th December 2020 at 11:28 PM.

  8. #7
    Member
    Join Date
    Feb 2011
    Location
    UK
    Age
    43
    Posts
    14
    Rep Power
    0

    Default

    Hi janch - thank you very much for taking the time to read my posts and trying to help me, I appreciate it :-)

    I have downloaded the file and will try to use it tomorrow - I will report back.

    I know where the backup I made is stored (I made a new folder for it before taking the backup), however, it does not look to me like a straight copy and paste type of backup - the folders don't look to be in all the same places as they were when they were on the 7700LM internal memory.

    Anyway, I am not really wanting to go back to the supplied software if I can help it. I like the way Primo works and would like to run it on this 7700LM.

    I tried another unlock that had a folder called Magnetic_S5000 - it had to be renamed 'Default' top work. I will try your fileset in the way you have indicated and only chage the name if required.

    UPDATE !

    I have now tried the files you sent me. I did have to rename the 'Magnetic_S5000' to 'Default, but it now boots to a selection menu (pics attached) - pressing the 'iGo Primo' button leads to the erro shown in the pic - you will have expected that as you have not given me a folder containing the program yet, I assume :-)

    I will wait to hear back from you.

    Thanks again, I really appreciate your time and help.
    Spoiler: images
    [Only registered and activated users can see links. ]

    [Only registered and activated users can see links. ]
    Last edited by Boki_Srb; 5th December 2020 at 09:05 AM. Reason: spoiler...

  9. #8
    Master janch's Avatar
    Join Date
    Jun 2010
    Location
    Hell
    Posts
    1,745
    Rep Power
    554

    Default

    Yeah, great job! Hoewer I'm surprised that it had to be renamed to "Default". But no problem, now you are ready to proceed to the next step, you assumed well - installing and configuring Primo.
    Here u go:

    Spoiler:
    Code:
    Please Login or Register to see the links

    unrar and copy folder Primo to SD root. You can than run it from Primo icon in the unlock menu. Primo 2.4 [9.6.13.405512] which I sent you is already configured for Mio (gps/baud) and it's multi-language so it should work "out of the box"
    Only thing left is to add maps. You can find those from the iGO maps section...
    Last edited by janch; 5th December 2020 at 12:46 AM.

  10. #9
    Member
    Join Date
    Feb 2011
    Location
    UK
    Age
    43
    Posts
    14
    Rep Power
    0

    Default

    Hello again janch - thank you so much for the new fileset. I installed them and now get the error;

    'Application Primo.exe has encountered a serious error and must shut down' (pic attached - Ihope !)

    I do have a map set that I use with the Mio Spirit 685 (or 687 ?, can't remember which), that I have not put with the files you sent yet.

    Many thanks again for taking the time to help me.
    Spoiler: pic
    [Only registered and activated users can see links. ]

  11. #10
    Master janch's Avatar
    Join Date
    Jun 2010
    Location
    Hell
    Posts
    1,745
    Rep Power
    554

    Default

    Did you copy also .fjw files which are in MAP folder? If so, than this may cause the problem as these files are compatible only with Nextgen. Delete all fjw files from MAP folder and than try again. You can also try Another Primo version (2.0). Link below

    Spoiler:
    Code:
    Please Login or Register to see the links

 

 

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •