Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 21
  1. #1
    Member
    Join Date
    Aug 2018
    Location
    England
    Posts
    10
    Rep Power
    0

    Default Kenwood DNX4230DAB missing SD card

    Hello everyone.
    I am hoping someone can give me some guidance here, I recently bought a Mitsubishi L200 with a Kenwood DNX4230DAB factory fitted.
    It does not have any map card installed in the SD card slot, and when I press the nav icon on the touchscreen says 'no maps found'.
    I am assuming that this device does not have any internal memory for maps, and relies on the SD card being present.
    I have updated the firmware in teh unit to the latest version, and the navigator software to the latest version, could anyone give me a clue as to the folder satructure of the SD card so I can try to re-create it, I have downloaded some unlocked maps but not sure exactly where to put the gmapsupp.img file, I tried the root folder, then a sub folder called garmin but still I get no maps, do I require any additional files or folders on the card.

    Any and all help much appreciated.

  2.    Advertissements


  3. #2
    Master Butters's Avatar
    Join Date
    Jul 2017
    Location
    CA
    Posts
    905
    Rep Power
    141

    Default

    Provided the 4230DAB's Garmin firmware is:
    (i) not 'protected' against using unlocked maps (probably it's unprotected) and;
    (ii) your downloaded map *.img is indeed properly unlocked (it will need to have been treated by gimgunlock - if required just google for it, version 0.04);
    then the following will work:
    • Make a folder named Garmin in a CLEAN SD card previously freshly formatted in FAT32 only.
    • Place the unlocked map img file named only GMAPSUPP.IMG into the Garmin folder.
    • If you want to add safety camera warnings or other POIs as *gpi files then make a folder POI and add the GPI files (POI folder can either be in the card root or in the Garmin folder for most Garmin devices).
    • If it supports JunctionView, make a folder named JCV in the Garmin folder and place the appropriate *.jcv file for the map and your device in there. Google to check what additional files the 4230DAB supports).

    To check your map is unlocked, open the IMG file in GMAPTool and look under 'Details' tab. If you see an "L" on any line under the heading 'prio' then it's not fully unlocked. You should see only "30" not "30 L S" for a City Navigator map.
    Code:
    Please Login or Register to see the links

  4. #3
    Member
    Join Date
    Aug 2018
    Location
    England
    Posts
    10
    Rep Power
    0

    Default

    Thanks Butters for the reply, I have followed those instructions, and seem to have made some progress, I have a map gmapsupp.img, that shows an unlocked map.
    I have written them to a blank fat32 SD card, in the Garmin folder.
    When I put the card in and hit the 'nav' icon, the head unit switches to nav, displays 'loading maps' and then goes to 'ready to navigate', no map is shown, no are there any on screen icons or text!.
    I can hit the left had lower screen, no text or icon is shown, but it pops up a menu where I can enter an address to navigate to.
    Entering an address via the postcode works, it finds the street address, but when I view route, there is no map shown.
    I am wondering if there is something else missing from the card, as I have no map displayed, and no icons on the nav screen.

    Looking in the 4230DAB manual, I should see icons on the nav screen, but I see none at all, but I can see the onscreen keyboard, I can see the trip menu when I tap the distance numbers on the screen, but no icons or menu.

    Just in case, I repeated the firmware update to the latest version, but that made no difference, it said update successful and to reboot which I did, but it's still the same.

    Ok, further update (maybe).
    I have found out how to put the head unit into test mode, it passes all tests, which is good.
    But, in navigation, it says 'Base map' 0000 Missing and 'Detail map' 0000 Missing, but the navigation software is showing as version 0350 KNWD 2013 SW Only WinCE and the Junction View is showing as 0200 Junction View.

    So it looks like the unit isn't seeing the maps on the SD card, If I take out the SD card, I get 'no map data available' on the screen, re-insering the SD card, I get 'loading maps' then no map data available.

    I am unsure if the maps are displayed from the SD card, or copied from the SD card to the internal memory, then displayed from there,
    Last edited by Boki_Srb; 20th May 2020 at 12:23 PM. Reason: Merged two posts, approved

  5. #4
    Master Butters's Avatar
    Join Date
    Jul 2017
    Location
    CA
    Posts
    905
    Rep Power
    141

    Default

    A minor corruption in the map IMG file is the most likely problem. Where did you get it from, can you supply a link for download? I can then check it further

  6. #5
    Member
    Join Date
    Aug 2018
    Location
    England
    Posts
    10
    Rep Power
    0

    Default

    Sure, I apologise if not ok to post links, but they came from here

    h***s://www.*********.com/new-maps/city-navigator-europe-ntu-2020-fid-8360-t21582.html

    I am beginning to think that the date is something to do with it, i.e. 2013 in the WinCE nav software I metioned in the last post, when I try and do the official update from the garmin webpage, using Garmin express, i.e. put a newly formatted blank FAT32 SD card in the head unit, click on update maps, it saves the file GarminDevice.xml in the garmin folder.
    Putting this into the card reader on the PC (several PC's in fact), when I run GarminExpress, it shows updates available, but when trying to download them, it says update failed in a big red bar across the top of the box like this.

    Spoiler: image
    [Only registered and activated users can see links. ]


    I am also wondering if the icons that I am unable to see are in the missing basemap file? and that is why I don't see any icon.

    Further to the last, in Express, if I attempt to purchase the updated map, it says the latest map is

    Spoiler: large image again
    [Only registered and activated users can see links. ]


    The one I was using was an NTU map, from 2020.
    I need to try it with the version that Express shows if I can find a working link, I may end up buying it but at this atge I am unwilling to in case the head unit has an issue.
    Last edited by Boki_Srb; 20th May 2020 at 12:23 PM. Reason: removed unnecessary quote, merged two posts, spoilers, approved...

  7. #6
    Master Butters's Avatar
    Join Date
    Jul 2017
    Location
    CA
    Posts
    905
    Rep Power
    141

    Default

    As the device doesn't have a Lifetime Maps subscription (LM), GE won't download the maps of course until you pay for them.

    Your 'update' post (now merged) wasn't seen by me when i made my previous reply because it was held for moderation being as you're a new member i guess. It was approved and merged with your earlier post by a mod over an hour later. Best not to make consequent posts, just use the edit function if you need to add more info.

    It seems unlikely that the WinCE software has any bearing on the Garmin navigation software which is proprietary. Your device uses NT (not NTU) City Navigator it seems from the second pic in your post so maybe your problem would be solved by downloading the NT EU version from the same source as the NTU:
    Code:
    Please Login or Register to see the links
    You'll need a basemap but not for POIs. The basemap is mainly used for high-level panning when zoomed out. You can get a basemap from here: [Only registered and activated users can see links. ]. It must be named gmapbmap.img only.

    PS: Direct links to other concurrent forums aren't allowed and our server automatically disguised your link.

  8. #7
    Member
    Join Date
    Aug 2018
    Location
    England
    Posts
    10
    Rep Power
    0

    Default

    Cheers Butters, all noted, not very experienced with forums etc, i'm too old I reckon!
    Anyways, downloaded the NT maps, and the basemap file put them on the card and .... no difference whatsoever.
    I can do an address search, which finds the address and street name, when I click routes, or view map, nothing is shown, nor are any icons on the status bar, or the screen.
    When I tried to do the update officially using GE from a friends PC and my SD card, it said the system update to be downloaded was was city navigator europe 2013.20, I tried to download it, but got the same 'error installing update'.

    after doing all this, in the system setup for the head unit, it is still saying base map missing and detail map missing, so I am stumped.
    Last edited by Boki_Srb; 21st May 2020 at 07:37 AM. Reason: approved

  9. #8
    Master Butters's Avatar
    Join Date
    Jul 2017
    Location
    CA
    Posts
    905
    Rep Power
    141

    Default

    So you did purchase the update for 50 quid then i assume. The fact that you get the 'error installing update' when trying to update the SD card with GE indicates to me that either (i) There may be a problem with the card rather than the device; or (ii) The GarminDevice.xml on the card has some problem causing GE to throw that error. If it's the latter then perhaps the XML is reflecting some problem with the device itself.

    If you've indeed forked over the money you should be able to get some assistance from Garmin UK. I think the map runs directly from the card in your device, i.e. the head unit isn't updated with a new map from the card. So if it runs directly from the card and GE hasn't updated the card i would think that it's not unexpected that the system setup reports the maps are 'missing'.

    The immediate action for any device not performing normally is to do a hard (or factory) reset. As it seems the card itself isn't being fully recognized then use another card, essential if you'd previously properly reformated the present card. Try doing both reset and update using another card with a fresh XML from the head unit before re-connecting to GE.

  10. #9
    Member
    Join Date
    Aug 2018
    Location
    England
    Posts
    10
    Rep Power
    0

    Default

    No as yet I haven't purchased the update, I get the option (I assume) to download the current map version

    Spoiler: LARGE IMAGE
    [Only registered and activated users can see links. ]


    But it always 'fails to install update' tried multiple PC's and laptops, several SD cards a 4GB, an 8GB and two 32Gb all fat32.
    Tried Windows 10 x64, Windows 7 x32 and x64 all professional versions not home.

    Only thing I haven't tried is to do the update from a MAC as I don't know anyone that has one.

    When using GE to do the update, do you know if anything else would be downloaded and written to the SC card, that is missing when I do it manually?

    I've been following this thread

    [Only registered and activated users can see links. ]

    Although not exactly the same head unit, I think the process is very similar but mine uses and SD card.

    I've followed it several times, each with the same effect, that is when I get to this point

    ---------------------------------------------------------------------------------------------

    Once all this is done, eject the USB drive from your computer and go connect the USB stick to the USB cable on you Kenwood unit.
    Place the unit in Standby mode
    Open Navigation
    Go to Settings
    Press Update Map
    Press OK to continue
    When it's done uploading (~10-15 minutes), remove the USB stick, power down the unit and restart it. Go back into navigation, settings, map, about. It should show the new 2014.30 map.

    ------------------------------------------------------------------------------------------------------------------------------------------------------------------------

    On my unit, when I press 'update map', all that happens is that the message about updating pops up, then it asks for an sd card to write the garmindevice.xml file to again, it is as if it is ignoring the sdcard contents.
    Last edited by Boki_Srb; 21st May 2020 at 11:50 AM. Reason: SPOILER!, merged two posts

  11. #10
    Master Butters's Avatar
    Join Date
    Jul 2017
    Location
    CA
    Posts
    905
    Rep Power
    141

    Default

    Yes the terminology is confusing, but if you don't pay for the latest map it doesn't really 'update' as such. The Version 2013.20 EU map being offered above is either the one loaded on the unit from new in the factory, or the last one that's since been legally purchased. It is indeed the 'current' map entitlement in that it's the one which the unit is currently allowed to re-download free.

    So did you try my other suggestions? (Reset the head unit and use a different card with a freshly generated XML).

 

 

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •