Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 38
  1. #11
    Member
    Join Date
    Oct 2014
    Location
    uk
    Posts
    22
    Rep Power
    6

    Default

    hi
    i started with a fresh installation. using the tts voice from post 1327. the tts voice works for everything. except when i test tts by wiman. the voice does not respond. in SETTINGS/WARNINGS/ALERT POINTS the voice says only the type of speedcam no speed limit or distance even if those option are turned on. when driving by a speedcan i just see a red visual alert, no voice or sound. i attach a copy of my sys. txt. if please someone can look at it.
    please if a uk user can share the complete working application including a uk tts voice will be very appreciated. i know it is a lot to ask.
    thanks

    Spoiler: sys
    Code:
    Please Login or Register to see the links



    Learn how to use spoilers
    Last edited by Boki_Srb; 2nd January 2019 at 01:41 PM.

  2.    Advertissements


  3. #12
    Senior Member
    Join Date
    Aug 2014
    Location
    United Kingdom
    Posts
    103
    Rep Power
    8

    Default

    [Only registered and activated users can see links. ]

    Your "sys.txt" file is very bloated. Probably a third of the content can be deleted as it is handled elswhere[ux folder/-speedcam file]

    The above link is to my working program. This is installed on an incar GPS device, and the whole proram is installed on the internal memory.

    The loading screen is my own and features a Vauxhall Insignia. It is in landscape only. You can delete or change as you like.

    For TTS you will need a TTS engine installed with a voice downloaded, i use the Google engine.

    Once the file is downloaded you will need to open it with the password HOWTO.

    The download is in a folder called "TRAVEL DOCUMENT"
    Last edited by 1franka; 2nd January 2019 at 04:10 PM.

  4. #13
    Member
    Join Date
    Oct 2014
    Location
    uk
    Posts
    22
    Rep Power
    6

    Default

    hi
    i can now have tts voice saying "after 1000 yard speedcam ahead" but no speed limit announced. in alert point i enabled: say camera speed limit,say camera speed unit, say distance to camera. however whem i do i speedcam test in setting or when im driving,the tts voice says the name of the camera then says just ahead but no speed limit. do i have to had something in the sys txt.
    thanks

    Spoiler: sys.txt
    [android]
    fullscreen=1
    ignore_keyguard=1
    navigation_audio_stream = 3
    ;STREAM_VOICE_CALL - Value: 0
    ;STREAM_SYSTEM - Value: 1
    ;STREAM_RING - Value: 2
    ;STREAM_MUSIC - Value: 3
    ;STREAM_ALARM - Value: 4
    ;STREAM_NOTIFICATION - Value: 5
    ;STREAM_BLUETOOTH - Value: 6
    ;STREAM_DTMF - Value: 8

    ;[android.opengl]
    ;sub_sample_size=4

    [autorad]
    disabled=1
    detect=10

    [camera.roundabout]
    enabled=0

    [debug]
    skip_eula=1
    screenshotsavecameraini=0
    ;log_1="/storage/emulated/0/igo_log.txt::5"

    [device]
    device_nng_path_secondary_disable=1
    device_nng_path_primary=""

    ;[folders]
    ;has_secondary_root=1
    ;content="/storage/6A19-C9F9/addons/content"

    [gps]
    background_navigation=1
    accuracy_workaround=0
    location_log=0

    [gps.igo_connector]
    horizontal_accuracy_treshold=10000

    [hnr]
    ignored_missing_country_ids=*

    [interface]
    network_enabled=1
    save_checksum=0
    ;show_speaker_only_mode=1

    [map]
    3d_max_tmc_icon_draw_count=5
    poi_3d_speedcam_icon_overlap=0

    [naviextras]
    boot_service_address="http://zippy.naviextras.com/services/index/rest"

    [poi]
    picturepoi_folder="/storage/6A19-C9F9/DCIM/Camera"
    use_mixed_poi_icon=0
    use_multi_poi_icon=0
    multi_poi_overlay=0

    ;[power]
    ;battery_warning_limit=0
    ;powermgm_state=0
    ;treat_charging_as_ac_line=1

    [rawdisplay]
    driver="gles_2_0_android"
    screen_xy="auto"
    ;base_dpi=240
    ;dpi=120
    ;dpi=160
    ;dpi=240
    ;dpi=320
    ;dpi=480
    ;dpi=640
    ;base_dpi =200

    [route]
    enable_uturn_on_short_segments=1

    [sound]
    ding_muted=1 ;/*skambutis*/
    alert_muted=0 ;/*įspėjimai*/
    effect_muted=0
    sound_effect_unmute_delay=100000000000
    android_muting_device=0
    media_config=config/devices/media_android.xml
    guidance_distance_offset=50
    announce_restricted_roads=1 ;/*apribojimų įgarsinimas*/

    [sound.announcer]
    gps_signal_lost=1
    gps_disconnected=1

    [tmc-http]
    enabled=1
    ;profile_name="nng-igo-tmc-jci"
    ;profile_name="nng-igo-tmc-iphone"
    ;profile_name=nng-igo-tmc-beckerfull
    profile_name=nng-igo-tmc-igoworld

    [attractions]
    user_picture_path="/storage/6A19-C9F9/DCIM"

    [voice]
    bridge_prio=2
    ;big_junction_prio=1
    only_first_traffic_light_announced=1

    [voice]
    big_junction_prio=1
    bridge_prio=2
    tunnel_prio=3
    ;poi_prio=4
    ;natural_guidance_prio=5

    [vr]
    disabled=0

    [warning]
    is_spoken=1
    speedcam_enabled=1
    speedcam_warning=1
    speedcam_max_lookahead=2000
    speedcam_maxdistance_from_road=10
    warn_distances="1000,500,200"
    say_camera_distance=1




    ;--------------
    ;---by pongo---
    ;--------------
    Last edited by Cserrobi; 4th January 2019 at 06:17 AM. Reason: Use a spoiler

  5. #14
    iGO Moderator Problems with TTS and speedcams
    Problems with TTS and speedcamsProblems with TTS and speedcamsProblems with TTS and speedcamsProblems with TTS and speedcamsProblems with TTS and speedcams
    Boki_Srb's Avatar
    Join Date
    Jun 2014
    Location
    Niš
    Age
    47
    Posts
    3,163
    Rep Power
    2231

    Default

    Of course.
    Don't just ask questions. Try to explore a forum and read and learn.
    [Only registered and activated users can see links. ]
    Before asking a question, know it's already discussed here and at 99.9% is not unique. Use search.
    NO ONE IS A SEER, READ (click on): [Only registered and activated users can see links. ] <- Click!
    [Only registered and activated users can see links. ] <- Click!

    Spoiler: obs
    Many questions become very arduous, a lot of time chewed deja vu...Since we have lost all the year of work and effort, many people have no will to answer the same questions again. Me neither. Use a search, please.

  6. #15
    Member
    Join Date
    Oct 2014
    Location
    uk
    Posts
    22
    Rep Power
    6

    Default

    sorry i been looking all over the forum. i been asking for help to other members, and i want to say thanks for trying to help. i been trying every uk and us tts voice. i been modify the sys. txt. i been trying different skin and tts engine and voice but i cant get igo pal with pongo skin(which i think is the best skin) to say the simple phrase: after 1000 yards speedcam limit 30mph. or what ever speedcam is there with speed units. although this option are enabled in the skin setting/warning/alert point,because when i press the tts test button for the 3 option in the attached photo,the tts voice actually says the speed unit and limit. however when i test them in the speedcam test. the voice just say. speedcam ahead without saying the speed limit or speed unit for that camera.
    so i now understand that igo pal and which ever skin or english tts voice i use will not say. the speedcam speed limit.
    Spoiler: SPOLIER!
    [Only registered and activated users can see links. ]



    Learn to use a spoiler once, and use a correct spelling and punctuation marks.
    Last edited by Boki_Srb; 4th January 2019 at 02:54 PM.

  7. #16
    iGO Moderator Problems with TTS and speedcams
    Problems with TTS and speedcamsProblems with TTS and speedcamsProblems with TTS and speedcamsProblems with TTS and speedcamsProblems with TTS and speedcams
    Boki_Srb's Avatar
    Join Date
    Jun 2014
    Location
    Niš
    Age
    47
    Posts
    3,163
    Rep Power
    2231

    Default

    Basic knowledge:
    For highly customized skin (like Pongo) in combination with TTS, you also need adapted/modded lang and voice files. Not generic.
    Last edited by Boki_Srb; 4th January 2019 at 03:19 PM.
    Before asking a question, know it's already discussed here and at 99.9% is not unique. Use search.
    NO ONE IS A SEER, READ (click on): [Only registered and activated users can see links. ] <- Click!
    [Only registered and activated users can see links. ] <- Click!

    Spoiler: obs
    Many questions become very arduous, a lot of time chewed deja vu...Since we have lost all the year of work and effort, many people have no will to answer the same questions again. Me neither. Use a search, please.

  8. #17
    Senior Member
    Join Date
    Aug 2014
    Location
    United Kingdom
    Posts
    103
    Rep Power
    8

    Default

    When you press "test speedcams"[with TTs voice selected], it will only say speedcamera ahead, or XXXXahead depending what icon you press.

    It will say the speed and distance[when navigating] provided you have turned them on in settings.

    The phrase that it says is in the dictionary file of the selected voice, which can be found in "content/voice"

    Any spoken speech can be changed to the phrase of your choice by editting this dictionary file.

  9. #18
    Member
    Join Date
    Oct 2014
    Location
    uk
    Posts
    22
    Rep Power
    6

    Default

    thanks for the file and your help. i selected the tts you send and now works ok in the s3 phone with google tts engine. but it wont work on my wife s5 phone same installation same voice and tts engine. im sure i will sort it out.
    thank again for your help.

  10. #19
    Master BIRBANTE's Avatar
    Join Date
    Jan 2016
    Location
    Tuscany - ITALY
    Posts
    173
    Rep Power
    71

    Default

    Quote Originally Posted by mariop1 View Post
    ..... with google tts engine.
    This thing you repeated it several times already so I think you're convinced of this. As far as I know, no version of iGO uses Google's TTS voices.

    You can use the "normal" voices, or by a suitable engine, you can use TTS voices, but these must be installed on the phone and set as system voices, whether they are the old Loquendo, or the new Nuance Expressive2.

    Any voice is installed on the phone and set as a system voice, there are programs that use their own voices, TomTom uses his own, as well as Maps uses his own, and iGO uses what I told you, but not the ones from Google .....

    I use iGO Israel, and I have the further possibility of using tts_nua_ve1, which is the Nuance version as internal voices.

  11. #20
    Senior Member
    Join Date
    Aug 2014
    Location
    United Kingdom
    Posts
    103
    Rep Power
    8

    Default

    I have been using different versions of Igo for a long time.
    I have always uesd the Google TTS engine and voices with a vocaliser voice file.
    The version i sent to "mariop1" is the one i am currently using and it works faultlessly.

 

 
Page 2 of 4 FirstFirst 1234 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •