Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Page 22 of 44 FirstFirst ... 12202122232432 ... LastLast
Results 211 to 220 of 434
  1. #211
    Navigation software expert

    lolypop000's Avatar
    Join Date
    May 2010
    Location
    EU
    Posts
    2,925
    Rep Power
    849

    Default

    Try version 2.35.
    I have it on LG G4 and work like charm.
    If you wish, you can [Only registered and activated users can see links. ]

  2.    Advertissements


  3. #212
    Junior Member
    Join Date
    Jul 2014
    Location
    Saudi Arabia
    Posts
    9
    Rep Power
    0

    Default

    Quote Originally Posted by lolypop000 View Post
    Try version 2.35.
    I have it on LG G4 and work like charm.
    Thank you for your tip

    install and run test for "StreetPilot_2.35pi22_sdcard0_signed.apk" with different result as follow

    1-starting the application (v2.35) will end by "Unfortunately Streetpilot has stopped" but it would run normal after 15 or so of trial
    2-After successful run and navigation it will crash in less than 20 minutes but it will fail to run again (have to try it for another 15 times or more)
    3-with these result I believe Streetpilot v2.35 is not usable and stable for my device

    I do no know what to try next

  4. #213
    Member
    Join Date
    Aug 2009
    Location
    Australia
    Posts
    27
    Rep Power
    31

    Default

    Any rotation and the phone immediately reboots, same as in post #130.

    ZTE T84, Snapdragon 410 processor & Adreno 306 GPU, Lollipop 5.0.2.

    Same with 2.36 & 2.37, also 2.35 apk's from other threads.

  5. #214
    Junior Member
    Join Date
    Sep 2015
    Location
    58N25E
    Posts
    1
    Rep Power
    0

    Default

    Confirmed, Streetpilot 2.37 (res 960 by 540 and higher with usb charging fix) working on Oneplus Two (A2003).

  6. #215
    Junior Member
    Join Date
    Jul 2014
    Location
    Saudi Arabia
    Posts
    9
    Rep Power
    0

    Default

    Update:

    The troubleshooting of Streetpilot v2.37 conteniued and I got running but it is workaround not knowing what is the actual problem

    1-when I run streetpilot the error dialog box will appear with "OK" option only

    [Only registered and activated users can see links. ]



    2-Ignoring the error and from the top bar I will pull down the drop down menue


    [Only registered and activated users can see links. ]



    3-Clicking the Streetpilot which is runing on the background will bring it back to live

    [Only registered and activated users can see links. ]



    4-This time I accept the error message by clicking "OK"

    5-From here Streetpilot run without problem

    [Only registered and activated users can see links. ]


    6-This workaround works with v2.33 , v2.35 and v2.37


    Iam not sure how to fix the main issue but streetpilot is somehow usable on my G.S6 edge+

  7. #216
    Moderator

    flagmax's Avatar
    Join Date
    Jun 2014
    Location
    Ca
    Posts
    609
    Rep Power
    331

    Default

    Brarisou;

    It sounds like the main libgarminos.so id crashing.

    You can try "adb logcat" on PC or get Logcat Extreme apk. In the log try to find something like this.

    Code:
    Please Login or Register to see the links

  8. #217
    Junior Member
    Join Date
    Jul 2014
    Location
    Saudi Arabia
    Posts
    9
    Rep Power
    0

    Default

    flagmax

    I have generated these reports and I hope it is what you have asked me in your reply


    report from LOGCATTOOL v4.1

    Code:
    Please Login or Register to see the links


    another from Android Studio and eclipse


    Code:
    Please Login or Register to see the links


    thank you for your help

  9. #218
    Moderator

    flagmax's Avatar
    Join Date
    Jun 2014
    Location
    Ca
    Posts
    609
    Rep Power
    331

    Default

    Brarisou, good job with logs.

    So it crashed here at address 00eae67c inside libgarminos.so.

    Code:
    Please Login or Register to see the links
    The IDA pro disassembly. It is trying to access memory address in R3 that is not available.
    Code:
    Please Login or Register to see the links
    Code:
    Please Login or Register to see the links
    I will try to debug the area on my working phone during the weekend and let you know if I find something. Perhaps you can also get IDA pro 6.5 and maybe we could also debug your device.

    It looks like you are using Streetpilot 2.35?

  10. #219
    Junior Member
    Join Date
    Jul 2014
    Location
    Saudi Arabia
    Posts
    9
    Rep Power
    0

    Default

    flagmax


    when it comes to assembling and disassembling my knowledge is almost equal to none but capable to follow instructions if given.

    currently I am using v2.37 apk (Streetpilot 2.37 (res 960 by 540 and higher with usb charging fix) from the first page of this post ,but I also installed v2.33 and v2.35
    which they were showing the same error, moving from one version to another I used the standard uninstall procedure.

    [Only registered and activated users can see links. ]

    thank you for your help

  11. #220
    Important User

    osiris4isis's Avatar
    Join Date
    Apr 2012
    Location
    Farside of the Sun
    Posts
    2,645
    Rep Power
    636

    Default

    Quote Originally Posted by lolypop000 View Post
    Do you have on root of internal or external SD folder Garmin or you add in folder Android/data/....
    If you have in folder Android/.... then try turn off/on your device and see if then all work.

    I have one time problem when i uninstall SP over phone and if i look over phone no SP folder visible but when i connect device to Pc i see that folder is still there.
    So i manualy delete all folder of SP and turn device off/on, add folder Garmin on device and install apk, turn device off/on and then run SP and all work.

    On some device folder Map or only .img is set ass read only after you copy from Pc to device, don't know why.
    I've uninstalled, power off/on, reinstalled and check crc32 of .img and .vpm and their access control to be correct. Same problem. Odd that you would get "Loading maps" message and map is not loaded.

 

 
Page 22 of 44 FirstFirst ... 12202122232432 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.