Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Likes Likes:  0
Results 1 to 6 of 6
  1. #1
    Junior Member
    Join Date
    Apr 2012
    Age
    62
    Posts
    8
    Rep Power
    0

    Default Zumo 345LM reduced connectivity issues with Basecamp

    Hi,

    I am new to this forum and impressed by the posts and topics I read here, so I think this community maybe can help me with this zumo 345LM problem:

    I recently purchased this device second hand.
    Maps were recently updated by former owner to Western Europe NTU2022.10 and also a Foursquare map is available on the device.
    Also user info was deleted via the menu I guess because I had to setup localization etc.

    Navigation is no issue at all, but after connecting to W10 PC (in Mass storage Mode) and starting up Basecamp the problem starts:

    First of all a pop-up appears in BC with the error message: (translated from Dutch)
    "There is a communication problem with the Garmin device GARMIN. Communication with the device may take place with reduced functionality."

    When I click OK Basecamp shows my device as : GARMIN ( H: )
    Normally you should see the device-id here, this id is available in Garmindevice.xml
    also in the device a link to UserData and the map CN Europe NTU 2022.10 Foursquare is shown
    I don't see the CN Europe NTU 2022.10 here, but both maps are shown on the device when I go to my Maps there.

    Also it's not possible to see the Active Logs directly in BC which are on the device ( I have to get them from GPX directory via File explorer) (Current logs GPX file)

    Transferring options are also not changeable.

    I did make a copy of the Device to an SD card and when inserting the SD card in computer slot, I see same behaviour.
    So it looks like a configuration issue in the files / directories.
    Deleting GarminDevice.xml and GPX maps on H: drive did not help either.

    Also Garmin express is able to reļnstall the maps on the device, but making a copy yo the computer gives an error message during activating of the maps. Also the device transfer options are not visible because the device is not shown in the pull down menu
    In the device-info menu this option is also greyed out

    I had no issues on the same computer with a Zumo 340LM and I also tried another laptop also with no success.

    I made a dump from this device with the JaVaWa device tool.
    Which can be found here:

    [Only registered and activated users can see links. ]

    Any help is appreciated.
    Last edited by damted; 12th August 2021 at 09:31 PM.

  2.    Advertissements


  3. #2
    Important User Zumo 345LM reduced connectivity issues with Basecamp
    Zumo 345LM reduced connectivity issues with BasecampZumo 345LM reduced connectivity issues with Basecamp
    Butters's Avatar
    Join Date
    Jul 2017
    Location
    CA
    Posts
    1,304
    Rep Power
    651

    Default

    Looking at the dump it can be seen the zumo has previously been updated on a Mac. Do a complete backup of the file system and importantly a backup the [Only registered and activated users can see links. ]. Then [Only registered and activated users can see links. ] and check if the problem still exists. Only if unchanged, do this: Reformat using ONLY [Only registered and activated users can see links. ] on a Windows PC. While still connected to the PC create an empty Garmin folder in the root of the device, then safely disconnect from PC and let the zumo boot. Re-connect to PC, open Garmin Express to update map entitlement and most missing files.

  4. #3
    Junior Member
    Join Date
    Apr 2012
    Age
    62
    Posts
    8
    Rep Power
    0

    Default

    I started the RGN_Tool and opened the file \.System\GUPDATE.GCD on my zumo
    Spoiler: pic
    [Only registered and activated users can see links. ]

    Now I can see HWID for Zumo 345 is 2435
    I saved the boot.bin on the SD card in the right folder and renamed it to Ldr.bin

    What is the right reg ## for my zumo 41 or anything else like 154.bin
    So what do I have to write in the update.txt file:
    Code:
    Please Login or Register to see the links
    Maybe I need to try different numbers for internal SD card nummer and reg number and see if a backup is created on the sd card.

    My steps:
    I could make a backup now (after few attempts)
    I had to use:
    rrgn,154,2:/154.bin
    reboot
    as update.txt
    After backup I cleared nonvol memory and did a restart.
    Same problem is still there
    So I reformatted the internal disk and restarted the zumo.
    Cards are gone now. So I started GE and now the update is on the way.
    In next post I will write the outcome
    Fingers crossed
    Last edited by damted; 15th August 2021 at 12:53 PM.

  5. #4
    Junior Member
    Join Date
    Apr 2012
    Age
    62
    Posts
    8
    Rep Power
    0

    Default

    With GE I was able to download and install the cards again.
    From the backup I could restore some directories like POI / Themes

    Connecting now to BC and also to MapSource give no error message at all and the device is poperly displayed as zumo 345 and device id
    Also the card is shown as CN 2022.10 and not the Foursquare map.
    Even transfer options to the device can be adjusted.


    It looks like some files messed up the communication and now everything works fine.
    Spoiler: screenshot
    [Only registered and activated users can see links. ]


    Edit:
    Today I discovered the real cause of the problem:
    I was comparing both the device and a backup on an SD card.
    I tried some things on both and I messed up again the zumo communication by copying some .unl and .gma files from the backup .\System\Map\ directory to the zumo device.
    Removing the .unl and .gma files which do not belong to the Foursquare map and a clearnonvol action, did the job much faster than before.

    So in .System\Map\ the only files there are:
    D4935220A.gma
    D4935220A.img
    D4935220A.unl

    So a combination of Foursquare Maps and City Navigator can really mess up the system.
    Last edited by damted; 15th August 2021 at 01:23 PM.

  6. #5
    Important User Zumo 345LM reduced connectivity issues with Basecamp
    Zumo 345LM reduced connectivity issues with BasecampZumo 345LM reduced connectivity issues with Basecamp
    Butters's Avatar
    Join Date
    Jul 2017
    Location
    CA
    Posts
    1,304
    Rep Power
    651

    Default

    Quote Originally Posted by damted View Post
    ..........
    What is the right reg ## for my zumo 41 or anything else like 154.bin .........
    Devices with MTP function use 2:/ as the path to the card. Using 1:/ will write the BIN file to the small hidden RWFS partition on the internal memory.

    I had to use:
    rrgn,151,2:/151.bin
    reboot
    as updater.txt ............
    I guess that "151" is only a typo and you meant "154". If the NV memory of zumo 345 is indeed region 151 please advise.

    It's likely that you are missing the basemap now as GE doesn't replace it. Rather than use the one from your file system backup load a fresh copy from [Only registered and activated users can see links. ]

  7. #6
    Junior Member
    Join Date
    Apr 2012
    Age
    62
    Posts
    8
    Rep Power
    0

    Default

    Yes
    Sorry that was a typo I meant 154 in update.txt
    I will check the fresh copy of Basemap from the link you provided.
    Last edited by Boki_Srb; 15th August 2021 at 05:18 PM. Reason: approved

 

 

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •