Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Results 1 to 8 of 8
  1. #1
    Junior Member
    Join Date
    Jan 2018
    Location
    South Africa
    Posts
    6
    Rep Power
    0

    Default Missing Speed indicator / Junction View /Next Turn Indicator

    Hi There,

    Perhaps someone can assist me :

    My BMW Navigator V ( Garmin) has stopped showing the speed limit indicator for each road , the next turn indicator ( Top left corner) the junction view is also not functioning at all while navigating.

    These functions are working in Simulator mode , but not while navigating.

    I have reloaded the maps , updated the firmware and also did a master reset.

    Regards,

    Piet

  2.    Advertissements


  3. #2
    Pro-Member Butters's Avatar
    Join Date
    Jul 2017
    Location
    CA
    Posts
    474
    Rep Power
    18

    Default

    Try clearing its non-volatile memory, more comprehensive than hard reset: [Only registered and activated users can see links. ]

  4. #3
    Junior Member
    Join Date
    Jan 2018
    Location
    South Africa
    Posts
    6
    Rep Power
    0

    Default

    Hi Butters,

    Thank you for the response, unfortunately it did not solve the problem...

    The speed limit indicator, junction view, and next turn indicator does work when in Simulator mode, but once iam navigating all those functions are gone.


    Could it not be a corrupt system file? if so how could I go by fixing it?

    I have tried Using Garmin Express, but when restoring a backup, it only restores my favorites etc. I have also used base camp to reinstall firmware, but no change.

  5. #4
    Pro-Member Butters's Avatar
    Join Date
    Jul 2017
    Location
    CA
    Posts
    474
    Rep Power
    18

    Default

    More likely some corruption in a region rather than a system file. The SL and LA [lane assist] indicators are read from map data. The JV images are read from the JCV file. Both the map IMG and JCV files are of course stored in the file system which is also a region itself [it's probably rgn83 in your device] however if both those files were faulty they wouldn't work in simulation either.

    Try dumping rgn140 and open it in "mod2xxx" to see what is enabled there. I think your Navigator V is similar in firmware to 2xxx and 34/35xx devices so should have that region populated. [Only registered and activated users can see links. ]

  6. #5
    Junior Member
    Join Date
    Jan 2018
    Location
    South Africa
    Posts
    6
    Rep Power
    0

    Default

    Hi Butters,

    I went through the entire process, and the functions were already activated once I opened up rgn 140.bin , I Then proceeded in deactivating them and reactivating them, hoping that might sort the problem ,but still no success.

    Is there anything else I can still try?

    I have noticed the Junction view does work when clicking on the top bar and flicking through all the steps (to get to the destination) but they still don't pop up during navigation.

    The next turn indicator does pop up now and again, but only when clicking on a location and navigating to it manually, searching an address then navigating still doesn't bring up anything else besides current speed and direction of travel.

  7. #6
    Pro-Member Butters's Avatar
    Join Date
    Jul 2017
    Location
    CA
    Posts
    474
    Rep Power
    18

    Default

    You could erase its non-volatile memory which is almost certainly the region that's got some minor corruption. It's not something to do lightly and you absolutely should NOT try it without making a safe backup beforehand. Make the backup of it with "rrgn" command then erase with "ergn". As the region's data will be encrypted there is no easy way for you to check the viability of the backup so maybe make it a couple of times before erasing. If you try the erasure please understand that it's done on the firm basis that it's entirely at your own risk. I do regard it as a method of last resort personally but cannot think of anything else you can try that might be helpful. If it makes no difference then you can write back with "xrgn" command. Read this thread to understand how rgn commands work: [Only registered and activated users can see links. ].

    Your device probably has NV in rgn154 rather than 41 however some devices may have copies in both but usually if one is populated the other in empty. [Only registered and activated users can see links. ]

  8. #7
    Junior Member
    Join Date
    Jan 2018
    Location
    South Africa
    Posts
    6
    Rep Power
    0

    Default

    Butters,

    It Worked :0

    THANK YOU , THANK YOU.

  9. #8
    Junior Member
    Join Date
    Jan 2018
    Location
    South Africa
    Posts
    6
    Rep Power
    0

    Default

    false alarm.

    Still not working but:

    if I run :

    ergn,154,1:/154.bin

    All functions work, once until reboot.

    The log returned is unsucessful because the log actually needs to be ergn,154

    When running ergn,154 it makes no difference,functions still not working

    Also removed rgn41, which gives me just a white screen, so did restore rgn 41 and back to where I started.

    Its funny that a command promt (ergn,154,1:/154.bin) which returns a unsuccessful message sorts the problem until device reboot.

    I thought i might leave the file on the SD card( and Make SD card read only, but once running the promt it wants to write id.bin back, which its unable to do in read only SD card, leaving me back to square 1.

 

 

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.