Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: Garmin 60csx

  1. #11
    Member +
    Join Date
    Oct 2014
    Location
    Santa Catarina
    Posts
    35
    Rep Power
    4

    Default System Software Missing

    Hi Guys,
    Somebody can help me to fix a GPSMAP 60CSX with a System Software Missing Message?
    I did not find it here.
    Thanks
    Last edited by xclaudio; 3rd September 2017 at 01:09 AM.

  2.    Advertissements


  3. #12
    Pro-Member Butters's Avatar
    Join Date
    Jul 2017
    Location
    CA
    Posts
    274
    Rep Power
    5

    Default

    Devices displaying 'system software missing' normally default to preboot mode. You can try to flash firmware as an RGN file using Updater.exe which may fix it. The message often means that the main unit software (firmware) has become corrupt or the device has been flashed with an incompatible firmware.
    Last edited by Butters; 3rd September 2017 at 01:19 AM.

  4. #13
    Junior Member
    Join Date
    Apr 2017
    Location
    Finnland, Kuhmo
    Posts
    1
    Rep Power
    0

    Default

    Quote Originally Posted by xclaudio View Post
    Hi Guys,
    Somebody can help me to fix a GPSMAP 60CSX with a System Software Missing Message?
    I did not find it here.
    Thanks
    Brilliant Corners
    Fixing a dead Garmin GPSMap 60CSx:
    Fixing a dead Garmin GPSMap 60CSx
    One of my favorite gifts that I received this last Christmas has been my Garmin GPSMap 60CSx GPS receiver (GPSr). Now that the weather has been getting better, I’ve been itching to use it to start tracking my bike rides (which I can later plot on a map). So, to get ready, I started up Parallels, connected the GPSr, and updated the firmware (mainly to get the update to correct the new daylight savings time).
    Everything seemed to go just fine when running the WebUpdater application, until a small note on the last message box during the update process. There was something there about a problem with the update, but the message box had a “Finish” button, so I blew it off as something I probably didn’t need to worry about. But I did need to worry. Once I disconnected the unit, it wouldn’t start up. At all. I got a flash of some kind of info screen, but it immediately went blank again. Nothing. Dead. I tried to run the firmware updating software again, only for it to not even find the GPSr, even though it was plugged in. Great.
    I hopped online to see if I could find any information about this problem. In the excellent Groundspeak geocaching forums I read some similar reports, but all the tips the suggested to get the GPSr working again didn’t work for me. Many said they ended up having to send in theirs in to Garmin to get fixed. I didn’t want to do that.
    A few folks in the forum suggested to others that they call Garmin’s customer support, and that they were nice and quite helpful. So I did, and after some back and forth and checking with other support staff, the friendly chap at Garmin support helped me fix my GPSr without having to send it in. Yay!

    So, ANYWAY, here’s the point of this post: here’s one way to revive your dead Garmin GPSMap 60CSx:
    Download the latest firmware file from this handy site. The filename will look like this: GPSMAP60CSx_330.exe (where the 330 is the firmware version number).
    Double click the .exe (which is a self-extracting archive) and it will ask you where you want to extract the files (the default is c:\garmin). If you have your other Garmin applications (like MapSource) already installed in c:\garmin, then choose another location to extract the files.
    Now, here’s where it gets tricky. Since the unit wasn’t recognized by the firmware updater on its own, customer support gave me the crazy keypad combination to trick the updater to see your USB GPSr: hold down the power button (on the top of the unit) and push the directional button in the up (“^”) position.
    While holding those buttons down, double click on the Updater.exe file in the directory where the firmware updates were extracted to.
    If this worked for you, then your GPSr should now show up for the firmware update program. While still holding down the two buttons, make sure your GPS device is selected, and then click the “OK” button to start the firmware update.
    During the entire firmware update process you need to hold those buttons down. The update can take several minutes, and your fingers will start to HURT, but you need to hold them down.
    Once the update has completed, you can relax your fingers and you should now be able to start up your GPSr.
    Jump for joy!

    This post is probably too long for such a simple fix, but if all this rambling helps someone out there, then it was worth it. I’m glad I have my updated 60CSx and that I didn’t have to send it back to Garmin.
    Apr 04, 2007 04:21PM (customer service, garmin, gps, gpsr)
    Comments

    Pierre Lepeer said on 17 May 2007:

    Great! You saved my life. It worked great on a 60CS! Many thanxs! :-)
    Kevin Draz said on 26 May 2007:

    Thanks for the fix, but it doesn’t work for me. Same/similar setup: Garmin 60CSx, Parallels latest version with WinXP VM, MacBook Pro Core 2 Duo running 10.4.9.

    I did a firmware update using the web updater. The update ran through to completion, I saw the “Loader” screen, &c. on the GPS, then I got a successful completion message on the updater program under Windows, but the GPS went blank, and won’t power on.

    I’ve tried removing batteries and replacing with new (the “old” ones were almost-new), reboots, you name it.

    I really was hopeful your trick would work for me, but alas, the GPS won’t show up under USB.

    Sigh. I supposed this means I have to pay to have it fixed. According to the Garmin web site, they won’t warranty failed firmware updates.

    What really frustrates me, is I’m a software engineer for a large printer company, and I design and implement the firmware update system for the printers among other jobs. One key requirement is that the flash update must always fail into a user-recoverable mode for the system. We use several methods – such as copying all the flash image data into RAM and CRC’ing it before we write a single byte into flash memory. That way, even if communication is lost during data transfer, the device just reboots and no harm done. Once flash write starts, all the I/O ports and protocols are disabled, along with all control buttons, so really only removing power during the write phaser could cause an incorrect flash image. But even that wouldn’t toast the box.

    We also break the flash into several regions. There’s a tiny, tiny boot loader that never gets overwritten, and it looks in two different places for the main boot loader, using an NVRAM bit to determine which is “preferred”, but it will CRC it before loading it and fail to the other location.

    The flash update program only overwrites the “old” bootloader, so there’s always one which has enough smarts to run USB and a flash loader.

    I guess Garmin hasn’t figured this all out yet. Maybe they should hire me to consult. :-/
    ...
    Thank you sir! Worked on my GPSMAP70 when I thoughts all was lost! Made my day, thanks for posting!

 

 
Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.