Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Page 1 of 3 123 LastLast
Results 1 to 10 of 21
  1. #1
    VIP Master
    isg's Avatar
    Join Date
    Jun 2009
    Location
    Europe
    Posts
    170
    Rep Power
    81

    Default 3597 LMT problems connecting to PC

    Just to share my experience:
    My unit is 3597 LMT FW 4.00 + SD Card SanDisc 8 GB HC
    Problem - very often when I'm connecting the unit the PC /Win7 Pro/ can not see the unit.
    I have installed Garmin USB drivers etc.
    Also a lot of Garmin programs are installed on PC.
    Unit is on MTP.
    What I have done to solve the problem:
    1. Restarted PC several times
    2. Restarted 3597 unit several times
    3. Make restarts from above together
    4. Reinstall USB drivers
    All above - no luck at all.
    Unit was still invisible to PC.

    What I did and helped me is that I just removed SD card from the unit and have a success.
    Unit immediately connected to PC and after that I just put SD in the unit.
    I'm writing this if someone has such a problem to try and this option.
    Apparently I have some problem with SD card or there is something wrong with software or GarminDevice.xml on SD card - can not determine for the moment. I'm considering that I might have a problem because on all the units I have had before the Eject order was:
    1. Eject SD
    2. Eject the unit
    Unit shut down after p. 2 Eject
    Here on 3597 the Eject order is opposite - First Eject unit and then SD Card

    The above works for me - may be it will work for you to.


    @Moderators:
    If the problem have been discussed already /I'm not good at all with the forum search/, or it is not in proper section - feel free to move it/delete it.

  2.    Advertissements


  3. #2
    GPSPower Helper

    dasilvarsa's Avatar
    Join Date
    Feb 2011
    Location
    Global
    Posts
    1,160
    Rep Power
    351

    Default

    It's also advisable to remove Garmindevice.xml from SD Card (there should only be one Garmindevice.xml)
    Why do you use MTP mode ?
    All the "Cowboys and Girls" use Mass Storage Mode.
    MTP Mode will never give you Access to all the files and folders.
    The difference between stupidity and genius is that genius has its limits.
    Albert Einstein.

  4. #3
    VIP Master
    isg's Avatar
    Join Date
    Jun 2009
    Location
    Europe
    Posts
    170
    Rep Power
    81

    Default

    Sorry dasilvarsa - it is my mistake. I'm running unit in Mass storage mode. But I'm curious did GE will recognize the SD card for map updates without Garmindevice.xml? On the card which came with unit there was Garmindevice.xml. I'll check tomorrow as I'm writing now from mobile.

    Sent from my GT-I9300 using Tapatalk

  5. #4
    GPSPower Helper

    dasilvarsa's Avatar
    Join Date
    Feb 2011
    Location
    Global
    Posts
    1,160
    Rep Power
    351

    Default

    Maybe this Nuvi 3597 writes garmindevice.xml to both Nuvi and SD Card (I've never played with 3597)
    Other Nuvis don't write Garmindevice.xml to SD Card.
    We use it to fool garmin servers and software.
    Maybe you can check date stamps of this file on Nuvi and SD Card and also check if the 2 files are identical.

    Maybe that's why if you remove SD Card it connects perfectly everytime. Try to rename garmindevice.xml in the SD Card to garmindevice.wasxml to see if it connect everytime to computer with the SD Card inserted (That's how it should work).
    You could always rename it back or maybe the Nuvi will write a new one ?
    Last edited by dasilvarsa; 13th January 2014 at 21:29.
    The difference between stupidity and genius is that genius has its limits.
    Albert Einstein.

  6. #5
    VIP Master
    isg's Avatar
    Join Date
    Jun 2009
    Location
    Europe
    Posts
    170
    Rep Power
    81

    Default

    3597 also did not write Garmindevice.xml on SD. I copyed the file from original SD card. I'll try what you suggested and will report.

    Sent from my GT-I9300 using Tapatalk

  7. #6
    VIP Master
    isg's Avatar
    Join Date
    Jun 2009
    Location
    Europe
    Posts
    170
    Rep Power
    81

    Default

    While I'm testing unit behavior with dasilvarsa proposals, I recoled that I'm doing and other trick to connect to PC.
    When I'm desperate and do not want to use Clear NonVol or to play again with PC drivers I'm doing the following:
    I'm entering in preboot mode and do nothing. Unit itself is not connected to PC.
    System disappears and after that unit reboot. Usually it works, but not always.
    You may try it too.

  8. #7
    Garmin/GPS Systems GMod.

    Neil's Avatar
    Join Date
    Aug 2011
    Location
    Oz.
    Posts
    7,388
    Rep Power
    1434

    Default

    NA & AU [also ZA i guess] versions of 3597 don't come with a microSD inserted in the unit as the EU version does. It seems from the above info that the card fitted in the EU has been 'locked' by having a GarminDevice.xml written to the card prior to packing. The NA & AU versions do not write an xml file when a card is inserted. I have an NA 3597LMTD purchased new direct from the States. I've run it with AU maps etc on an 'after-market' Lexar 4GiB since i've received it but no xml has been written to the card by the unit. Similarly with an AU 3597 to which i've had access.

    These units differ to other modern nuvis in that the internal path to the card is not 1:/ it's 2:/ as it was with early 3x0/6x0 nuvis. In 3597, 1:/ is to the unit's RWFS which contains another .System folder with sub-folders Diag, GPS and SQLite folders. It is possible to write to the RWFS using commands, e.g. an NV backup using conventional path of 1:/ will write to it.

    When my 3597 is connected to PC with a card inserted, in Win8 they appear normally under 'Safely Remove Hardware and Eject Media' as this:
    su67

    and must be ejected from there together. Only under 'Computer' may they be ejected as separate devices. I expect that in your case isg, the unit and card will show as separate devices even in 'Safely Remove etc'.

    Have you compared the .xml files which where originally on the sd and unit? I'm curious to know how much the two differ ....

    Quote Originally Posted by isg View Post
    3597 also did not write Garmindevice.xml on SD. I copyed the file from original SD card. I'll try what you suggested and will report. .....
    I think that if you remove the .xml from the card that your unit will function normally in MSM with the card onboard. Do you get the same aberrant PC behaviour when you use the OEM card in the unit? Also could you please check if there is any difference in the card xml after the unit's been rebooted? That may show if the unit's rewriting it on the card.
    'Thanking Posts' are banned. To thank someone, and/or to see hidden links and content, use the [Only registered and activated users can see links. ] button below left of the helpful post then refresh your browser [F5 key]. 'Thanking Posts' are banned.
    Please don't spam. Posts serving no purpose other than to thank or to ask about hidden links are trashed or deleted, it's GPSPower's policy. Please don't spam.
    [Only registered and activated users can see links. ] should make their first post as a new Intro Thread in [Only registered and activated users can see links. ].

  9. #8
    VIP Master
    isg's Avatar
    Join Date
    Jun 2009
    Location
    Europe
    Posts
    170
    Rep Power
    81

    Default

    Sorry for delay, but my Nuvi "hit the road" yesterday, because of one of my friends emergency.
    I'll continue with test in the weekend.
    Yesterday I have made NonVol clear several times because on first and second attempt the trips were not erased or were partially erased and unit also said "Can't unlock maps" which is not possible, because I have LM.
    After third attempt of clearing NV PC start to detect the unit without any problem and unit started to behave normally. Have no time to check additionally, but GE also started to detect unit and to start with unit connection to the PC.
    So, at this stage, I can say that there are always at least two reasons for not detecting unit from PC - PC software problems and unit FW/SW problems.
    In my impression up to the moment 3597 FW/SW is more vulnerable that 3590 for example.
    I did not mention it up to now, but before clearing NV, when I connect unit to PC I have saw 3 USB generic devices:
    Garmin - unit
    SD card
    and some very strange logical device - H:\ - which disc volume is 128 MB. It is shown only when unit is connected to the PC....
    I have no such a card/disc. No external device connected at all. But it is accessible and I have RW permissions. Even GE made a backup on it.
    I'm not an PC expert, but I have enough experience with PC to know how to find some logical discs, directories etc. Checked all computer - nothing.
    Any idea what could be that mysterious drive H:\ ?
    Last edited by isg; 16th January 2014 at 09:28.

  10. #9
    Navigation software expert

    Giomen's Avatar
    Join Date
    Apr 2009
    Location
    Suomi-Russia
    Age
    49
    Posts
    2,578
    Rep Power
    589

    Default

    Please read post above there Neil gave a comprehensive answer about RWFS drive.
    Love your wife? Buy yourself a GPS for answering to her favorite question: "Dear, where are you?".

  11. #10
    Garmin/GPS Systems GMod.

    Neil's Avatar
    Join Date
    Aug 2011
    Location
    Oz.
    Posts
    7,388
    Rep Power
    1434

    Default

    @isg
    You can choose to show or hide RWFS in Mass Storage Mode. Go to Diagnostics Page>RWFS Settings. However when "Show in Mass Storage" is checked, it will show up as another 'Device with Removable Storage' the same as your 3597 and microSD do, as it is not seen as a conventional Logical Drive which would be in with your Hard Disk Drives. RWFS will also show as "Disk [number] Removable" in Windows Disk Management between the 3597 and microSD.

    In the screenshot below GARMIN (H:) is a Logical Drive split off from my Win 8 partition to allow writing to it by patched MS & MI [because i have my system drives write protected]. GARMIN (L:) is the RWFS which always appears immediately following the unit if 'Show' is selected and the microSD, if inserted in the unit, showing behind it [sequence is 0:/, 1:/, 2:/ which is reflected by the ascending sequence of the Disk Nos and Drive letters assigned by Windows]:

    w7hh
    'Thanking Posts' are banned. To thank someone, and/or to see hidden links and content, use the [Only registered and activated users can see links. ] button below left of the helpful post then refresh your browser [F5 key]. 'Thanking Posts' are banned.
    Please don't spam. Posts serving no purpose other than to thank or to ask about hidden links are trashed or deleted, it's GPSPower's policy. Please don't spam.
    [Only registered and activated users can see links. ] should make their first post as a new Intro Thread in [Only registered and activated users can see links. ].

 

 
Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.