Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1
    Junior Member
    Join Date
    Oct 2017
    Location
    Nebraska
    Posts
    5
    Rep Power
    0

    Default Old Versions of Sygic

    Hello All,

    Read most of the suggestions and most recommend Sygic 14.3.4 or Sygic truck 13.2.7, Would those versions work on Android 7.0 Nougat?

    I am currently using 17.2.11 and wish to downgrade. Is it possible to get those older versions and are they compatible with Android 7.0? Thanks!

  2.    Advertissements


  3. #2
    Member + Old Versions of SygicOld Versions of Sygic
    Join Date
    Dec 2015
    Location
    venice
    Posts
    83
    Rep Power
    2

    Default

    Quote Originally Posted by alchemyst View Post
    Hello All,

    Read most of the suggestions and most recommend Sygic 14.3.4 or Sygic truck 13.2.7, Would those versions work on Android 7.0 Nougat?

    I am currently using 17.2.11 and wish to downgrade. Is it possible to get those older versions and are they compatible with Android 7.0? Thanks!
    All these programs are compatible with Android 7.It is possible to get them.
    A downgrade of Truck version is'nt necessary, the software is ever the same , there are only improvements.

  4. #3
    Member + LouBouha's Avatar
    Join Date
    Mar 2017
    Location
    Tunisia
    Posts
    37
    Rep Power
    6

    Default Sygic V14.3.4

    Hi Alchemyst

    Here is the version you need, I don't know if it is functional or not on Android 7.0 Nougat ,so to try.

    Personally I continue to use it is the must in terms of personal customization ,Its menu is easy.

    Works only with old Maps: V9

    Spoiler: Hide
    This post requires you to click the "LIKE this post" button and hit F5 to read this content.


    Regards
    GPS: TomTom ONE

    Smartphone: THL T11 Android 4.2.2 Resolution 720x1280
    Sygic 14.3.4 IGO Primo 9.6.29.636868 Skins : Doupas V9.0h , Dimka/Frontzosd giphy

  5. #4
    Super Member
    Join Date
    Feb 2015
    Location
    italy
    Posts
    152
    Rep Power
    45

    Default

    Sygic 14.3.4 and Sygic truck 13.2.7, both work with android 7 - Nougat. It's not possible to downgrade from higher to lower version of Sygic, simply overwriting APK, but it's necessary remove a version and installing a new. Try to find the version you prefer on the forum and install it. Usually it's required only a minimum vesion of Android( 4.0.3 tu run Sygic, and not a maximum of it.

  6. #5
    Junior Member
    Join Date
    Oct 2017
    Location
    Nebraska
    Posts
    5
    Rep Power
    0

    Default

    Quote Originally Posted by LouBouha View Post
    Hi Alchemyst

    Here is the version you need, I don't know if it is functional or not on Android 7.0 Nougat ,so to try.

    Personally I continue to use it is the must in terms of personal customization ,Its menu is easy.

    Works only with old Maps: V9

    Spoiler: Hide
    -= Hidden Content =-


    Regards
    Thanks for the file, I tried it and was unable to get it to work, it kept on saying trying to download some files. ='( tried other versions like 16.4.14 and that worked with no problem.

  7. #6
    Member + Old Versions of SygicOld Versions of Sygic
    Join Date
    Dec 2015
    Location
    venice
    Posts
    83
    Rep Power
    2

    Default

    Quote Originally Posted by alchemyst View Post
    Thanks for the file, I tried it and was unable to get it to work, it kept on saying trying to download some files. ='( tried other versions like 16.4.14 and that worked with no problem.
    Try with this:[SPOILER][Only registered and activated users can see links. ][/SPOILER]
    You'll find all, remember to complete Maps folder with wcl(basemap)v9 and maps v9.
    Last edited by spyder; 20th October 2017 at 12:56 PM.

  8. #7
    Member + LouBouha's Avatar
    Join Date
    Mar 2017
    Location
    Tunisia
    Posts
    37
    Rep Power
    6

    Default

    Good cleaning before installation:

    First uninstall your version of Sygic, Delete the Sygic file

    Download the V9 Maps with wcl and content.info

    Here is the link: [Only registered and activated users can see links. ]

    Copy Sygic Folder and Sygic 14.3.4 Full SP .apk File to Sdcard of Internal Memory Phone

    Install: Sygic 14.3.4 Full SP .apk

    Do not open the Apk

    Copy Maps in the Sygic / Maps folder

    Launch your Apk is Good Put the Speedcams

    if the method is not functional

    Here is the Sygic 14.3.3 version that you install according to the procedure described and you install Sygic 14.3.4 on it.

    Spoiler: Link
    [Only registered and activated users can see links. ]


    My version is installed for more than two years I had in my archives.

    Regards
    GPS: TomTom ONE

    Smartphone: THL T11 Android 4.2.2 Resolution 720x1280
    Sygic 14.3.4 IGO Primo 9.6.29.636868 Skins : Doupas V9.0h , Dimka/Frontzosd giphy

  9. #8
    Super Member
    Join Date
    Feb 2015
    Location
    italy
    Posts
    152
    Rep Power
    45

    Default

    @alchemyst

    Don't forget to add onto internal memory a suppletive TTS that for Sygic 14.3.4 is "LoquendoTTS". You can download it by Sygic Map Downloader v1.7 (DB-Version 17.3.2 (17.10. 2017) also included Maps v9, here: [Only registered and activated users can see links. ]
    Cheers
    Last edited by INGRIDMARE; 20th October 2017 at 02:11 PM.

  10. #9
    Junior Member
    Join Date
    Oct 2017
    Location
    Nebraska
    Posts
    5
    Rep Power
    0

    Default

    I have tried everything I learned and read and still unable to get 14.3.4 to work, it keeps trying to download some file. Sygic folder on root of internal memory with V9 maps, wcl folder and LoquendoTTS. I think its working as the app informs me it will move the folder into the right structure and then it tries to download some file.

    Tried TA and NT maps, 2016.12 and 2017.03, still no go.

  11. #10
    Member + LouBouha's Avatar
    Join Date
    Mar 2017
    Location
    Tunisia
    Posts
    37
    Rep Power
    6

    Default

    Look at this topic [Only registered and activated users can see links. ]
    GPS: TomTom ONE

    Smartphone: THL T11 Android 4.2.2 Resolution 720x1280
    Sygic 14.3.4 IGO Primo 9.6.29.636868 Skins : Doupas V9.0h , Dimka/Frontzosd giphy

 

 
Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.