Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Likes Likes:  0
Results 1 to 2 of 2
  1. #1
    Junior Member
    Join Date
    Nov 2014
    Rep Power

    Default Who also has bad experience and non-acceptable or no responces at all from sygic?

    Below I just give the unending bad story I experienced sofar. I am just trying to find people having the same kind of experience so that we may be able to put some pressure on the Sygic guys to bring some sence into them!
    Eventually give directions or thoughts how to do that!

    Oct 10 22:31 (CEST)

    I am using Sygic for Europe & Rusland; have also purchused Australia.
    Now I also own a Samsung Galaxy with Samsung Galaxy with:
    android version 2.3.6 basebandS5830iXXLK1 kernel [email protected]#1 BUILDNUM


    Is it possible to use Sygic for mentioned Galaxy? N.B. Could not find it in the Samsung Store.

    Dear customer,

    you can find my answer to your request below. *If you feel your request is not resolved or if you have any additional questions, please reply to this e-mail and I'll get back to you.

    You'll receive one more e-mail within the next 24 hours with an option to evaluate my personal approach to you.

    Tomas Tomas (Sygic Support)
    Oct 14 12:54 (CEST)


    Thank you for contacting Sygic. My name is Tomas, your support representative, and I will be handling your request from now on. I will do my best to help you with your request.

    Regarding your device you may experience unwanted bugs and crashes due to the version of Android 2.3.6, please contact me back if you experience such issues and we will solve the further. The application is available via Google Play.

    I will consider this case solved for now, however if you still experience the issue or have any other questions, feel free to re-open this request by replying to this e-mail. I will get back to you as soon as possible for proper resolution.

    Thank you for your understanding.

    Best regards,

    Sygic Customer Support


    Oct 15 23:23 (CEST) High Tomas,

    The Sygic for The Benelux is now installed on my Galaxy and seems to work alright.
    Since at current I am busy with other work, this app is at second place now.
    I could not really test it yet, also because regularly is shown that the program is looking for contact with satelites.
    Probably next weekend i will know more and let you know next week my findings.

    Question: I have purchased Australia and Europe for my iPad and like to know wether I have to pay when I like to use them also on the Galaxy.



    Oct 21 21:03 (CEST)

    Hi Thomas,

    Last weekend I made a trip from about 400 km With the BeNeLux edition installed on the Samsung Galaxy Ace and during the same trip also the Europe/Russia running on my iPad, I experienced following.

    Locking in to the satelites went better on my iPad. The Galaxy took more time and had to be outside my house!

    Driving and navigating, after about 15 minutes the Sygic on the screen on Galaxy changed from the normal view to one with thinner lines, after which it went more or less black. I only could still see the direction indices. Navigating however went on for some time with only the voice giving direction.
    Pressing the square botton at the bottom of the Galaxy it came back to live after activating the Sygic App again.
    After approximately another 15 minutes above happened again, etc.

    After a couple of days I went back and typed the adress in. This caused a black screen. I had to completely switch of the Galaxy and on again. After that it went OK. This may have had someting to do with the Galaxy itself.
    Also now eveytime after about 15 minutes something happened again with the screen. Now it did not get black, but simply frose, however navigating went on by only the voice and than after some time the whole thing switched off itself, including the Galaxy!
    By switching the Galaxy on and hitting the Gygic app, this found the given adress again, after which I had to activate navigating again. Every time after about 15 minutes the same thing happened again.

    By comparing the navigtion of the iPad and the Galaxy, I can say that the iPad mostly gave the instruction just a little bit before the Galaxy.
    Sometimes I got the idea that they did not go completely synchronised, but generally they did the same. The screenes showed more or les the same. Only on the way back there were small differencies, probably because I had "avoid highway" at none in the Galaxy and "ask allways" in the iPad. Also in the Galaxy calculate the "cheapest route". In the iPad calculate the "shortest route".

    Above means that I would not trust the Galaxy edition in congested area's where there is a lot of traffic to attent to.

    Now something else. I have been using the Australian edition in Australia and the European in Europa and found some peculiar things that happened in Australia as well as in Europe.
    E.g. sometimes it happened that being in a city and giving directions to go somewhere the program lets you drive around in the city not going into th direction given in.
    In Sydney I have been crossing the harbour bridge several times back and fourth, so that at last I followed simply the road signs!
    Also it once happened that we went into a city that was not part of the given route, but I trusted the program would bring me back on the given in toute. No, I was directed around in the city and the program did not bring me out.
    This also happened sometimes in European cities.
    Further it happens rather often that the program goes mad and keeps on changing directions, so that sometimes it happens that you really have to follows the paper map and road signs!
    Sometimes it happens that the screen shows the direction index completely next the road. In those cases I think that there is no good sync. between map and satelite!

    Hope I helped you with this information and would like to here from you.


    28-10-2013 17:44
    Hi Thomas,

    Was my info helpfull.
    Can you answer my question in an earlier mail, I sent you?


    !!!!!!!!!!!!!!THAN ONE YEAR LATER!!!!!!!!!!!!!

    23-9-2014 20:15

    Remarks regarding the sygic gps app for Australia & New Zealand, as well as Europe & Russia.

    We have again been using the app in Australia during our trip from 7 weeks in the states NSW and Queensland.
    What we found is that your gps maps do not sync with reality. Often the indicater is far beside the road we travel on. Often, very often, lets say every 2 minutes your gps indicates to turn around, make a u-turn take a left and again.
    Also it often is late in telling to turn right or left , because we past that turn off for several meters already.
    The latter was very anoying, esspeccialy when driving in larger cities.
    We really had to follow our own direction, using out brains and maps!

    Also the translucant square showing the number of lanes is sometimes giving problems, esspecially when driving in road congested area’s. Than it is sometimes just covering the part which you need for following the road to follow.

    Next to all this it happened often that once we went wrong, or we went of the route for a visit in a place, the app was not able to bring us on the right track again. Instead it showed several directions with on some roads indicaters in one as well as in the other direction! Even after having deleted the route and putting in the proper direction again we got the old “several directions with on some roads indicaters” again!

    The above is for a large part also valid for the south-west of Germany, were we travelled early august this year!
    Al together, I am not at all happy with these 2 app’s from Sygic!

    Now, today I have loaded an update from the Europe wit Russia app and tried to delete Nederland and than install Nederland again. Well I was unable to get Nederland again installed!!!!

    N.B. The app’s are being used on a iPad 2 with 64GB, wifi and 3G.

    I ‘d like the see your esponce.

    Best regards,

    RESPONCE FROM SYGIC: 29-9-2014 09:01
    Dear ......

    due to the increase of customer inquiries and requirements, we would like to apologize for not responding to your request yet.
    We will answer you as soon as possible.

    If our apology is not acceptable for you, you have still options to check our FAQ at:
    [Only registered and activated users can see links. ]

    Thanks for your patience and understanding.

    MY next MESSAGE:

    I rather wait for your answer to my remarks,



    MY next MESSAGE: Monday, September 29, 2014 9:01 AM

    1 To me to get my remarks answered looks rather long!

    2 In the mean time I have used your latest updat for Europe. I drove in Netherlands and Belgian.
    During this trip I did not find noticable problems.

    3 I found however another problem; regarding working with coordinates. I.e. the app only accepts N and E coordinates, where various coordinates west of the greenwich line are given in W. This means that the W coordinates have to be recalculated into E by hand, by deducting 360 degrees ! ??



    MY next MESSAGE: Oct 30 14:06

    I am using Sygic for Eu+Ru and also for AU+NZ.
    I have taking the trouble to inform you about my finding about the app's.
    I also have done some investigation work approx. one year ago.

    I do not get any answers, What is wrong with you guys?

    Below you find some of the communication.

    Please let me hear from you.

    Regards, *******************************


  2.    Advertissements

  3. #2
    Junior Member
    Join Date
    Dec 2014
    Rep Power


    Same here, have been trying to resolve an inability to activate a product for the past TEN WEEKS. Initial responses from Sygic Support did not address the issue at all and just recent the activation code supplied by the online activation process, even after my support request stated this activation code did not work. Eventually after about six weeks of random communication (at times Sygic took two weeks to respond) they said my problem was beyond what Sygic support could rectify and Sygic directed me to contact [Only registered and activated users can see links. ]. This email has been completely unresponsive for the past four weeks.

    I have started forwarding the sent email to both Fleet support and Sygic support every second day for the past three weeks, this did get one response. The response was so unhelpful it was a joke, it was obvious that they did not even read my request and just sent generic help questions including how to recover a product code, even though I referenced my product code in the request.

    I have also started to include [Only registered and activated users can see links. ] in my emails, this is claimed to be the CEO of Sygic but email is also unresponsive.
    Of note is the fact that I was initially receiving a conformation email on sending a support request, now I receive nothing. So either they have blocked my email address or Sygic support is no longer accepting support requests



Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts