Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Results 1 to 2 of 2
  1. #1
    Junior Member
    Join Date
    Nov 2014
    Location
    California
    Posts
    2
    Rep Power
    0

    Default Help with W205 MB Entry SD Card Nav "Copy Protection is Active"

    Hi

    I have a MY 2019 W205 C-Class. This has the newer "MB Entry" SD Card navigation.

    I bought the SD card with part number A213 906 98 07, like one of [Only registered and activated users can see links. ]. This came with 2018 Maps v5.0. This was working well over the last 4-6 weeks.

    I backed up all the data on the SD card to my hard drive. I then went to mbusa website and [Only registered and activated users can see links. ] the SD Card Navigation Download Manager to update the navigation on the SD card within 60 days. It showed that there was a 2019/2020 v6.0 map update available. The first time when I updated the SD card data using the PC software, it failed half way during the update. I restarted this and then it succeeded the next time.

    However, I decided to clone my SD card (using `dd` on linux) to another card just to have a backup card and didn't realize about the SD Card's CID checks in the Nav unit prior to doing it. I got the "Copy protection is active. Please consult your Mercedes-Benz partner." message when I inserted the cloned SD card.

    Then, I inserted the original SD card with the updated nav software and I still get the same "Copy protection is active." message.

    It appears as if my card's CID has now been blacklisted by my Nav unit, is that something the newer Nav units do? Any suggestions? Is my Nav unit hosed altogether or just that particular SD Card CID?

    I'm planning to restore the original backup from my hard drive back to the card to see what happens and if that helps (in any way). Other alternative is to purchase another SD card and this time not insert any cloned cards in my unit.


    [Only registered and activated users can see links. ]
    Last edited by Tuxdude; 23rd July 2019 at 05:57 AM.

  2.    Advertissements


  3. #2
    Junior Member
    Join Date
    Nov 2014
    Location
    California
    Posts
    2
    Rep Power
    0

    Default

    I restored the original SD card backup and it got the card working again - Yaay!

    I feel it probably has something to do with the SD card and the maps it came with. I think it might not be genuine and somehow that version of maps plays nice with the Copy protection. Once the maps get updated, the copy protection kicks in. Kind of a bummer that I can't update the maps version on the card, but better than having to order another SD card I guess

 

 

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •