Best choice is to use the version that comes with proggy.
Second best choice is to use the latest version.
In few rare cases, a mismatch will occurred between proggy and global_cfg that will cause strange and undetected issues you won't know about until you turn on logging.