Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. #1
    Junior Member
    Join Date
    Apr 2017
    Location
    Slovenia
    Posts
    2
    Rep Power
    0

    Default iGO Primo Android black screen during voice guidance

    iGO Primo 9.2.29.483387

    During the voice guidance the screen goes black.
    When the "voice leader" stop talking the iGO is normally visible.

    If I delete the .ftr files inside the maps iGo works normally.

    Please help.

  2.    Advertissements


  3. #2
    Important User iGO Primo Android black screen during voice guidance
    iGO Primo Android black screen during voice guidanceiGO Primo Android black screen during voice guidanceiGO Primo Android black screen during voice guidance
    osiris4isis's Avatar
    Join Date
    Apr 2012
    Location
    Darkside of the Moon
    Posts
    2,455
    Rep Power
    542

    Default

    Your .ftr files might be corrupted. Check it under Help->About->Content->Truck Restrictions
    Do not PM me with questions. That's what a forum is for.

  4. #3
    Master janch's Avatar
    Join Date
    Jun 2010
    Location
    Hell
    Posts
    434
    Rep Power
    152

    Default

    Nope, this is a "known" issue on some Android tablets running Primo with all recent Here maps (2016-->2017). No known solution so far..However, no such problems on Nextgen, but some truckers still prefers iGO Primo. It's really frustrating to be forced to use Nextgen instead of Primo just because of this tiny bug..

  5. #4
    Important User iGO Primo Android black screen during voice guidance
    iGO Primo Android black screen during voice guidanceiGO Primo Android black screen during voice guidanceiGO Primo Android black screen during voice guidance
    osiris4isis's Avatar
    Join Date
    Apr 2012
    Location
    Darkside of the Moon
    Posts
    2,455
    Rep Power
    542

    Default

    I go with info given by the user
    Quote Originally Posted by RaGlaSi View Post
    iGO Primo 9.2.29.483387

    During the voice guidance the screen goes black.
    When the "voice leader" stop talking the iGO is normally visible.

    If I delete the .ftr files inside the maps iGo works normally.

    Please help.
    and note the careful working

    Quote Originally Posted by osiris4isis View Post
    Your .ftr files might be corrupted. Check it under Help->About->Content->Truck Restrictions
    Do not PM me with questions. That's what a forum is for.

  6. #5
    Master janch's Avatar
    Join Date
    Jun 2010
    Location
    Hell
    Posts
    434
    Rep Power
    152

    Default

    Yes, you had a good point no doubt, but I remembered that this issue was already discussed with no other solution than to delete .ftr file(s). But doing so, truck navigation functions are compromised.

    [Only registered and activated users can see links. ]
    [Only registered and activated users can see links. ]

    It's really hard to understand how can .ftr files affect voice commands and screen flickering as these files are just additional map attributes which has nothing to do with the graphic or with the voice commands. And on the other side Nextgen handles them without a problem.

  7. #6
    Important User iGO Primo Android black screen during voice guidance
    iGO Primo Android black screen during voice guidanceiGO Primo Android black screen during voice guidanceiGO Primo Android black screen during voice guidance
    osiris4isis's Avatar
    Join Date
    Apr 2012
    Location
    Darkside of the Moon
    Posts
    2,455
    Rep Power
    542

    Default

    It happened because part of .ftr is corrupted. Case in point, I'm having a streaking graphic (crazy lines drawing from center) for one POI in 2017 HERE USA map. The problem is only for that single POI and it depends on zooming. And this is with NextGen9.18.27.687519-Gift(26Jan2017) So if part of that .poi is corrupted. Data corruption lead to memory corruption (when loaded) and causes impact on other subsystems.
    The reason why NextGen doesn't have issues with it might be because it has different API for loading the data. This is my best guess.
    Do not PM me with questions. That's what a forum is for.

  8. #7
    Master janch's Avatar
    Join Date
    Jun 2010
    Location
    Hell
    Posts
    434
    Rep Power
    152

    Default

    That is well explained but I doubt that all ftr files from any recent HERE maps are corrupted or at least it's a bad definition. As you say I also believe that NNG must have slightly changed something in ftr files which affects Primo having troubles handling them. But it's still confusing that in most Android tablets/phones there is no such problems in relation Primo + ftr.

  9. #8
    Important User iGO Primo Android black screen during voice guidance
    iGO Primo Android black screen during voice guidanceiGO Primo Android black screen during voice guidanceiGO Primo Android black screen during voice guidance
    osiris4isis's Avatar
    Join Date
    Apr 2012
    Location
    Darkside of the Moon
    Posts
    2,455
    Rep Power
    542

    Default

    Ok, if problem exists for all .ftr then it has to be an API problem, not corruption. Does this problem has to do with ONLY .ftr or other content causes problem as well?
    Do not PM me with questions. That's what a forum is for.

  10. #9
    Master janch's Avatar
    Join Date
    Jun 2010
    Location
    Hell
    Posts
    434
    Rep Power
    152

    Default

    ftr only in all cases that I can recall.

  11. #10
    Important User iGO Primo Android black screen during voice guidance
    iGO Primo Android black screen during voice guidance
    Midnight Blues's Avatar
    Join Date
    Aug 2009
    Location
    EU
    Posts
    917
    Rep Power
    736

    Default

    I have same problem with Primo in other situations, like when having listed traffic events and then try to open one of them iGO always crashes or screen goes black.
    Also sometimes when starting iGO, display stuck on loading screen or goes black, but program goes on in background
    Pressing home button and Primo icon againg, display comes back like nothing happened.

    But it is only on some devices with Android 4.x.x
    I never had this problem on Android 5.x or 6.x with exactly same data files

    So my conclusion was that it is problem with graphic driver compatibility, and I tried every possible variant in sys.txt, but with no solution

    And then I stepped forward to NextGen
    NO THANKS POSTS ALLOWED, NO LIKES NEEDED, ALL MIRRORS APPRECIATED
    ztsyz4
    Password for all my uploads: gpspower.net

 

 
Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.