Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Results 1 to 6 of 6
  1. #1
    Junior Member
    Join Date
    Feb 2016
    Location
    Salzburg
    Posts
    6
    Rep Power
    0

    help HELP Medion GoPal P 5460 - TMC on Primo not working

    Hy to everyone,
    can somebody help me, i have medion p 5460 and on primo tmc wont work and i do not have setting for tmc ( icon ).
    Nobody dont know witch tmc chip use this model or what must stay in sys txt, only i have found this thread on German lang:
    [Only registered and activated users can see links. ]

    I have also original data from medion and tmc working, but on primo wont. Tmc chip are integrated and tmc antenne are in power cable.

    thx
    Last edited by Boki_Srb; 20th April 2017 at 06:48 AM.

  2.    Advertissements


  3. #2
    iGO Moderator HELP Medion GoPal P 5460 - TMC on Primo not working
    HELP Medion GoPal P 5460 - TMC on Primo not working
    Boki_Srb's Avatar
    Join Date
    Jun 2014
    Location
    Niš
    Age
    45
    Posts
    1,008
    Rep Power
    454

    Default

    And what is original software on it? And what Primo you use now?
    Read what is original port from it, and write that value in Primo's sys.
    Maybe you need some other version of Primo, in case that current don't support TMC or is not properly cr*cked.
    Maybe you don't have all TMC licenses.
    Maybe...who knows, nobody is seer here....

    Welcome to forum.
    Read my signatures.
    NO ONE IS A SEER, READ: [Only registered and activated users can see links. ]
    [Only registered and activated users can see links. ]

    Many questions become very arduous, a lot of time chewed deja vu...Since we have lost all the year of work and effort, many people have no will to answer the same questions again. Me neither. Use a search, please.

  4. #3
    Junior Member
    Join Date
    Feb 2016
    Location
    Salzburg
    Posts
    6
    Rep Power
    0

    Default

    Original software is Medion gopal 6.1, original tmc port is 1 - baud i dont know i try 38400. I have allrady try that value in Primo sys but wont work. This version of Primo i use on another medion e 4440 and tmc working without problems, and i have downloaded all tmc licenses from internet. Problem with this version is that nobody dont know witch TMC Chip use Medion P 5460.
    I have found on internet some post about this version of Medion P 5460 and say that is not posible use tmc on Primo.
    This is orginal picture of Medion TMC files and ebtmc.dll is the key.
    Spoiler: pic1
    [Only registered and activated users can see links. ]


    Spoiler: pic2
    [Only registered and activated users can see links. ]


    Spoiler: pic3
    [Only registered and activated users can see links. ]


    Last Picture are from folder TMC3


    Read my post again, and answer to all questions related to your problem
    Last edited by Boki_Srb; 20th April 2017 at 10:10 PM.

  5. #4
    Master G-ulash's Avatar
    Join Date
    May 2014
    Location
    Yellow Brick Road
    Posts
    240
    Rep Power
    8

    Default

    Medion devices produced end 2011 and later cannot use TMC using non-GoPal software as there is no proper Primo driver for the TMC chipset (Amaryllo) that supports Primo. Or for Primo that supports the Amaryllo chipset. Whatever is the correct explanation. It won't work. Period.
    AFAIK, many tried, none succeeded.

    Navigon software could work with a certain programming trick, but I can't say all Navigon software could and which build/version. Maybe your German forum has the info when you want to test Navigon?

  6. #5
    Master G-ulash's Avatar
    Join Date
    May 2014
    Location
    Yellow Brick Road
    Posts
    240
    Rep Power
    8

    Default

    A short update:

    By pure coincidence, I discovered a in data.zip/config file for a DELCO device these lines:

    [tmc]
    source="amaryllodyn"
    internal_tmc_name="amaryllodyn"
    port="COM,4"
    update_ltn_on_country_change=1
    tuner_model= "IGO_GPSTMC_TUNER"
    tuneralg_rds_repeat_check=0
    tmc_provider_name_use_old=1
    tmc_provider_name=0
    tuneralg_rds_packet_timeout=4500
    tuneralg_8a_packet_timeout=8500
    tuneralg_3a_packet_timeout=20000
    tuneralg_last_8a_packet_timeout=60000
    amaryllodyn_use_rds_input=0
    auto_band_search_up=1
    default_tmc_freq=892
    check_ltn_support=1
    area_size=500
    use_picode_for_country_code=0
    amaryllodyn_white_filter_state=1

    I think it is worth adding them to sys.txt and try.

  7. #6
    iGO Moderator HELP Medion GoPal P 5460 - TMC on Primo not working
    HELP Medion GoPal P 5460 - TMC on Primo not working
    Boki_Srb's Avatar
    Join Date
    Jun 2014
    Location
    Niš
    Age
    45
    Posts
    1,008
    Rep Power
    454

    Default

    No worth. Sys and licenses are only part of the problem, and are not responsible for the operation of the device.
    TMC chip is OK, but if you don't have a DLL that will work with him, it is absolutely worth nothing. It has nothing to do with Primo, ordinary iGO or NG.
    Not important is chip manufacturer - Amarillo. Medion E4440 is an old model, its TMC is previous generation and fully supported by iGO.
    Actually, the problem is that this new chip, which is built from series 4460 onwards, totally modified, does not give the system infos directly rather than going through the interface of a software, the GoPal has a driver for it.
    These are files responsible for proper work with GoPal:
    AmarylloDynamicsLoader.exe (reads the TMC signal and sends it to navi software)
    ADynamics4709.dll (direct culprit)
    GPSTMC.DLL (these file is presented with every iGO, but not the same edition)
    How Medion did not pay the license iGO-in, they didn't make the driver, so do not waste more time on this.
    Perhaps this explanation is a bit clumsy, but the point is important.
    Last edited by Boki_Srb; 28th April 2017 at 06:52 PM.
    NO ONE IS A SEER, READ: [Only registered and activated users can see links. ]
    [Only registered and activated users can see links. ]

    Many questions become very arduous, a lot of time chewed deja vu...Since we have lost all the year of work and effort, many people have no will to answer the same questions again. Me neither. Use a search, please.

 

 

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.