Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Likes Likes:  0
Results 1 to 10 of 10
  1. #1
    Member
    Join Date
    Nov 2019
    Location
    North of the Netherlands
    Posts
    10
    Rep Power
    0

    Default Citroen C4 RT6 GPS antenna dead?

    Hi, quick question, my emyway Rt6 suddenly stopped seeing sattelites. 2.21 firmware, new maps. (Thanks forum )
    Pressing the setup button reveals no GPS version number, only a few ----- lines.
    I remember it did show something else when the unit was working.

    So, GPS antenna is dead right? Car is going to the shop next year. (2012 Citroen C4)
    It still has some warranty. I bought it "new" a few weeks ago. Mechanic at the shop said "yes antenna is dead". But maybe one of you guys has some other insights

    I already tried the reset methods supplied here, like pressing the eject button and removing and reseating the fuse.

  2.    Advertissements


  3. #2
    Member
    Join Date
    Nov 2019
    Location
    North of the Netherlands
    Posts
    10
    Rep Power
    0

    Default

    It appears that a new antenna doesn't work.

  4. #3
    Pro-Member kitos's Avatar
    Join Date
    Mar 2017
    Location
    spain
    Posts
    256
    Rep Power
    0

    Default

    Update the firmware.
    If my contributions are worth something, please....

    Give like to my post and raise my reputation.

  5. #4
    Member
    Join Date
    Nov 2019
    Location
    North of the Netherlands
    Posts
    10
    Rep Power
    0

    Default

    Yes, I'll try that, I've reloaded the original version firmware, didn't work, I'm slightly concerned that newer firmware will get me the Bluetooth echo bug, but having no sattelites bugs me more

  6. #5
    Member
    Join Date
    Nov 2019
    Location
    North of the Netherlands
    Posts
    10
    Rep Power
    0

    Default

    Quote Originally Posted by kitos View Post
    Update the firmware.
    Well, updating to 2.31 didn't do the trick, thankfully no Bluetooth echo it seems.

  7. #6
    Pro-Member kitos's Avatar
    Join Date
    Mar 2017
    Location
    spain
    Posts
    256
    Rep Power
    0

    Default

    Changue the gps antena.,
    If my contributions are worth something, please....

    Give like to my post and raise my reputation.

  8. #7
    Member
    Join Date
    Nov 2019
    Location
    North of the Netherlands
    Posts
    10
    Rep Power
    0

    Default

    Already changed for a new one

  9. #8
    Pro-Member kitos's Avatar
    Join Date
    Mar 2017
    Location
    spain
    Posts
    256
    Rep Power
    0

    Default

    And works?
    If my contributions are worth something, please....

    Give like to my post and raise my reputation.

  10. #9
    Member
    Join Date
    Nov 2019
    Location
    North of the Netherlands
    Posts
    10
    Rep Power
    0

    Default

    Nope, as I mentioned earlier, new antenna didn't work unfortunately.
    I'll try the reset method mentioned elsewhere, by connecting two points on the system circuit board itself. I have to take the system out of the dashboard though. (Bit of a job)

  11. #10
    Pro-Member kitos's Avatar
    Join Date
    Mar 2017
    Location
    spain
    Posts
    256
    Rep Power
    0

    Default

    Post the tutorial here.
    Last edited by Boki_Srb; 7th March 2020 at 11:44 AM. Reason: removed unnecessary quote
    If my contributions are worth something, please....

    Give like to my post and raise my reputation.

 

 

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •