Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Likes Likes:  0
Results 1 to 9 of 9
  1. #1
    Junior Member
    Join Date
    Aug 2019
    Location
    Ohio
    Posts
    6
    Rep Power
    0

    Default Rosen DS-UN0910 GPS software issue

    Hi everyone. I've been lurking on here for the past couple days and I haven't been able to figure this one out. I have a Rosen DS-UN0910 radio that does not have the original GPS card. I'm trying to get iGo to run on it, but it's not working. First I got "HBS.TXT not found!". So, I created a blank HBS.TXT file and the message became "Unable to find EXE". Then I put this in the HBS.TXT:

    Code:
    Please Login or Register to see the links
    Now, it's finding the exe, but it just keeps saying "Unable Execute File". I've tried many different versions of the iGo software I've found on here, but none of them will run. Reading the Stickied thread "iGO Primo 2.xx official versions", it's looks like Rosen radios were using iGo Primo 2.0.1, but that didn't work either. What's going on?

  2.    Advertissements


  3. #2
    VIP Master Rosen DS-UN0910 GPS software issue
    Rosen DS-UN0910 GPS software issueRosen DS-UN0910 GPS software issue

    Join Date
    Oct 2015
    Location
    Home
    Posts
    147
    Rep Power
    137

    Default

    Give this a try:
    Put in HBS.TXT

    \MMC_Storage\igo\igo.exe

    or maybe rename the igo folder/file and try
    \MMC_Storage\NNG\nngnavi.exe

  4. #3
    Junior Member
    Join Date
    Aug 2019
    Location
    Ohio
    Posts
    6
    Rep Power
    0

    Default

    Ok, tried that and it's still not working. Something I found out though is that the HBS file must be the problem because I even tried "\MMC_Storage\NNG\nng22navi.exe" and it still said "Unable Execute File", not "Unable Find EXE". So the "exe not found" error only happens if the HBS.TXT is blank. I even tried "\FLASH_Storage\NNG\nngnavi.exe" and "\SD_CARD\NNG\nngnavi.exe" and still same error.

  5. #4
    VIP Master Rosen DS-UN0910 GPS software issue
    Rosen DS-UN0910 GPS software issueRosen DS-UN0910 GPS software issue

    Join Date
    Oct 2015
    Location
    Home
    Posts
    147
    Rep Power
    137

    Default

    Did you already try another or smaller sd card (4Gb)

  6. #5
    Junior Member
    Join Date
    Aug 2019
    Location
    Ohio
    Posts
    6
    Rep Power
    0

    Default

    Yeah, the first card was a 512MB. I switched to an 8GB SDHC because the maps wouldn't fit on the 512MB card. Seems like this unit can read SDHC cards though as it is still finding the HBS.TXT, it's just not opening the exe.

  7. #6
    iGO Moderator Rosen DS-UN0910 GPS software issue
    Rosen DS-UN0910 GPS software issueRosen DS-UN0910 GPS software issueRosen DS-UN0910 GPS software issueRosen DS-UN0910 GPS software issue
    Boki_Srb's Avatar
    Join Date
    Jun 2014
    Location
    Niš
    Age
    47
    Posts
    2,879
    Rep Power
    2023

    Default

    Did you tried with some other iGO version?

    Is it possible that Unit is MIPS based?
    Before asking a question, know it's already discussed here and at 99.9% is not unique. Use search.
    NO ONE IS A SEER, READ (click on): [Only registered and activated users can see links. ] <- Click!
    [Only registered and activated users can see links. ] <- Click!

    Spoiler: obs
    Many questions become very arduous, a lot of time chewed deja vu...Since we have lost all the year of work and effort, many people have no will to answer the same questions again. Me neither. Use a search, please.

  8. #7
    Junior Member
    Join Date
    Aug 2019
    Location
    Ohio
    Posts
    6
    Rep Power
    0

    Default

    I have tried Primo 2.4 9.6.13.405512, NextGen 9.18.40.671989, Primo 9.6.5.299162, and a few others. That's what I'm beginning to think. Not specially MIPS, but I don't know if the ones I'm downloading are for x86 or ARM or what. For what it's worth, I've tried running all these in the Windows CE 5 emulator from Microsoft, but they all say "Not a valid Windows CE application". Then again, I dont know what processor the emulator is using. I would get x86, since the computer is x86-64. Also, I'm not even sure what OS this unit is running. There is a sticker at the top that says OS: 5.0.1. The error dialog looks like Windows CE, so I'm guessing WinCE 5.0.

    Edit: I changed the path in "HBS.TXT" to just "\igo\igo.exe" and put iGo at that path. Now I'm getting a completely new error "Unable Open HBS.TXT!" Think I just forgot to make it Read-Only. Couldn't repeat error.

    Edit2: One of the chips inside is labeled "ARM STR736FV2T6", so it must be an ARM processor.
    Last edited by ImpalaLS; 22nd November 2019 at 01:01 AM.

  9. #8
    iGO Moderator Rosen DS-UN0910 GPS software issue
    Rosen DS-UN0910 GPS software issueRosen DS-UN0910 GPS software issueRosen DS-UN0910 GPS software issueRosen DS-UN0910 GPS software issue
    Boki_Srb's Avatar
    Join Date
    Jun 2014
    Location
    Niš
    Age
    47
    Posts
    2,879
    Rep Power
    2023

    Default

    Quote Originally Posted by ImpalaLS View Post
    I have tried Primo ...I've tried running all these in the Windows CE 5 emulator from Microsoft, but they all say "Not a valid Windows CE application"...
    That is strange. All of this editions are standard WinCE aps...the emulator that is in this Forum is proven ok. There are no X86 or X64 editions of emulator, there is only one, and it works on both architectures of OS.

    Actually, this leads me to a thought: your PC have viruses.
    They change the structure of the exe file, although they have no effect on WinCE.
    Before asking a question, know it's already discussed here and at 99.9% is not unique. Use search.
    NO ONE IS A SEER, READ (click on): [Only registered and activated users can see links. ] <- Click!
    [Only registered and activated users can see links. ] <- Click!

    Spoiler: obs
    Many questions become very arduous, a lot of time chewed deja vu...Since we have lost all the year of work and effort, many people have no will to answer the same questions again. Me neither. Use a search, please.

  10. #9
    Junior Member
    Join Date
    Aug 2019
    Location
    Ohio
    Posts
    6
    Rep Power
    0

    Default

    Well, I don't think so, but I can run a scan, as I don't know the last time I did. I just renewed my Bitdefender Total Security subscription recently, and as much as it was I hope that's not the case. I'm thinking the problem is with the unit itself. I'm wondering if the SD reader is defective. This unit didn't work when I got it. First time I plugged it in, it smoked like a chimney. I disassembled the radio and the only part that burned was the main harness connector. I just cut it out and soldered the wires directly to the board. I'm wondering if when the plug failed it took the card slot out with it. Either that or I damaged it when I had it apart. Everything else is working, but I suppose anything is possible.

    Edit: I was using the wrong emulator I think. I just installed WM6.1 emulator and most of the versions of iGo are working. Something is either wrong with the unit or there is more to the HBS.TXT than what is known about it. It seems that most Rosen's had "maplaunch.ini" files, so that doesn't help. I'm wondering if HBS.TXT is actually supposed to be on internal storage? I don't think there's any hope for this, unless there is some way to get it to boot directly into Windows CE. If that were possible, I might be able to get around the HBS.TXT problem, but it seems to be completely locked.
    Last edited by ImpalaLS; 23rd November 2019 at 04:53 AM.

 

 

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •