Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Results 1 to 2 of 2
  1. #1
    Junior Member
    Join Date
    Jun 2017
    Location
    Seattle
    Posts
    1
    Rep Power
    0

    Default Fixed Garmin Nuvi 44LM after bad update caused restart loop (Logo>"loading maps">Logo)

    I'm posting this to help others with Garmin Nuvi units who have run into the same problem. If it works for you, it's a much easier solution than the "easy" unbricking with GarminCure3 or anything else I found.

    I caused my problem by reflexively putting my computer to sleep while my GPS was in the middle of a maps update, which I had initiated with Garmin Express.

    Symptoms: If I turned my Nuvi on when not connected to the computer, it would show the Garmin logo, then show "loading maps," then re-start, show the logo, then show "loading maps," ad infinitum. If it was plugged into a USB power source, it would always want to be on, going through that loop. When I connected it to my computer by USB, the computer would not "see" the device. Even when I went through pressing the corner of the screen, then turning it on, etc., the best I would get was the white calibration screen.

    Solution: I left the GPS plugged into a USB power source. (I don't know if it helped, but I ended up using a 2.1 Amp USB AC adapter instead of a low-power one.) The unit went through the looping for *hours* and then appeared to boot properly. It showed the screen with "Where To" and "View Map" and stopped looping. But it still didn't work! And restarting it returned it to the frigging loop.

    However, after leaving it plugged in again for another very long time (overnight), it looped for a long time, but by morning it had returned to the proper "Where To" screen. This time I didn't turn it off but instead plugged it into the computer's USB port, and the computer saw it and so did Garmin Express. It showed I was up-to-date and did nothing automatically, but I went to the Map Update lower in the window and ran that. And it worked.

    One other thing I did might have helped, but maybe it was a step that did nothing. At one point, before updating the maps, when I was able to connect via USB, I used Garmin's WebUpdater, then searched the drive where the unit was for GarminDevice.xml. Searching found that file even though it was in the System folder of the GPS, which was hidden (it was the .system folder). I edited GarminDevice.xml to turn the line <SoftwareVersion>400</SoftwareVersion> into <SoftwareVersion>350</SoftwareVersion> [Garmin Express had said I was using System 4.00 when it refused to update the unit. I chose 350 as an arbitrary version number that was lower than 400.]. After doing that, I was able to get Garmin Express (or WebUpdater? I don't recall which) to treat the unit as *not* up-to-date, and it reinstalled software. (I don't know if this was a necessary part of the solution, however, because the unit again went into the looping-restarting problem; but it was after this that, as I explained above, I used the Garmin Express program to update the Maps, which resulted in a fixed GPS.)

    The main point of this post is that before doing something more complicated, try leaving your Garmin Nuvi plugged into a power source for HOURS (even while it won't turn off and goes again and again through the Logo-LoadingMaps loop). You may find, like I did, that this allows you to connect the unit to the computer and be seen and fix the problem with the standard Garmin software on your PC.

  2.    Advertissements


  3. #2
    Navigation software expert Fixed Garmin Nuvi 44LM after bad update caused restart loop (Logo&gt;&quot;loading maps&quot;&gt;Logo)
    Fixed Garmin Nuvi 44LM after bad update caused restart loop (Logo&gt;&quot;loading maps&quot;&gt;Logo)Fixed Garmin Nuvi 44LM after bad update caused restart loop (Logo&gt;&quot;loading maps&quot;&gt;Logo)Fixed Garmin Nuvi 44LM after bad update caused restart loop (Logo&gt;&quot;loading maps&quot;&gt;Logo)Fixed Garmin Nuvi 44LM after bad update caused restart loop (Logo&gt;&quot;loading maps&quot;&gt;Logo)
    lolypop000's Avatar
    Join Date
    May 2010
    Location
    EU
    Posts
    2,738
    Rep Power
    810

    Default

    Your nuvi was in loop becouse of broken map update and all you need to do was to run GE and reinstall map no need of edit xml or update FW.
    If you wish, you can [Only registered and activated users can see links. ]

 

 

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.