Quote Originally Posted by bram1980 View Post
Goldwing 2012 right now with 2.60 firmware and use city navigator 2016.40, and running well. Want to upgrade the firmware . Is it 4.70 the las firmware?
No 2.9 is the latest. Make sure you get 2.9 for the 2012 and up and not 2.9 for the 2009-10. The one for 2012 and up is 25mb in size. the one for the 2009-10
is only 6mb