Hi, new question, either Mapsource or Basecamp detect my SP v2.35 kitkat, why?