Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Likes Likes:  0
Results 1 to 6 of 6
  1. #1
    Member
    Join Date
    Jan 2012
    Location
    Wales
    Posts
    20
    Rep Power
    0

    Default Mapsource what ver. for W2k

    What is the latest version of Mapsource I can run on my old Windows 2000 PC? I know I should get something better but it still works fine & does everything I need to do, it's not possible to upgade it as the processor is too slow.
    I have a couple of netbooks running windows 7 but they are a bit slower than my old PC, I also have a laptop with vista on it but it's pretty useless most of the time, battery has died & was never really up to the spec to run Vista & constantly locks up.

  2.    Advertissements


  3. #2
    ☼ADMIN☼ Mapsource what ver. for W2k
    catymag's Avatar
    Join Date
    Nov 2007
    Location
    light side
    Posts
    19,163
    Rep Power
    4759

    Default

    Try version 6.16.2
    Operating System:Windows 2000,Windows XP
    Code:
    Please Login or Register to see the links



    u1rTN
    l9ebnsm
    You have to navigate to get to the good.

    Galaxy S5 Kitkat 4.4.2 / Nuvi1200->1250 / Nuvi3790T->34xx / Nuvi 2200 / Nuvi 66 / Oregon 600

  4. #3
    Member
    Join Date
    Jan 2012
    Location
    Wales
    Posts
    20
    Rep Power
    0

    Default

    Thanks, I'll give it a try. I did have a copy of ver.4 City Select but can only find disk 1, I was also sent an upgrade to ver.5 & then 6 but you have to have mapsource already loaded to upgrade.
    This was when I had a GPS V & could only load about 16 mb of maps, if you were travelling any distance you had to stop & load maps for the next section & this would take 35 mins no matter how many maps you were loading.



    Ed

  5. #4
    ☼ADMIN☼ Mapsource what ver. for W2k
    catymag's Avatar
    Join Date
    Nov 2007
    Location
    light side
    Posts
    19,163
    Rep Power
    4759

    Default

    May be you need this too
    [Only registered and activated users can see links. ]
    l9ebnsm
    You have to navigate to get to the good.

    Galaxy S5 Kitkat 4.4.2 / Nuvi1200->1250 / Nuvi3790T->34xx / Nuvi 2200 / Nuvi 66 / Oregon 600

  6. #5
    ☼ADMIN☼ Mapsource what ver. for W2k
    catymag's Avatar
    Join Date
    Nov 2007
    Location
    light side
    Posts
    19,163
    Rep Power
    4759

    Default

    I must apologize coz a friend tested 6.16.2 and it doesnt work in 2000
    6.15.7 works instead


    Code:
    Please Login or Register to see the links
    patch
    [Only registered and activated users can see links. ]
    l9ebnsm
    You have to navigate to get to the good.

    Galaxy S5 Kitkat 4.4.2 / Nuvi1200->1250 / Nuvi3790T->34xx / Nuvi 2200 / Nuvi 66 / Oregon 600

  7. #6
    Member
    Join Date
    Jan 2012
    Location
    Wales
    Posts
    20
    Rep Power
    0

    Default

    I did get around to trying version 6.16.2 & found it wouldn't work, hadn't had time to get back on the forum. Will give 6.15.7 a try thanks for the help.

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.