Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1
    Junior Member
    Join Date
    Sep 2015
    Location
    midlands
    Posts
    6
    Rep Power
    0

    Default TomTom Go 910 updating

    I have been searching to update my tomtom go 910, I am sure the last time I did this I Put on x40 and x50 software
    but this has been a long time, can anyone give me any advice on latest software and maps for this model.
    I know its a old tomtom and fat ( a bit like me) but it still works ok, just out of date.

  2.    Advertissements


  3. #2
    TomTom Expert

    biggerdave's Avatar
    Join Date
    Dec 2011
    Location
    Darn sarf
    Posts
    1,773
    Rep Power
    508

    Default

    It's all here for you:- [Only registered and activated users can see links. ] just search around there
    Please do not post "thanks" but use the "reputation" star(*) bottom/left or "like" bottom/left buttons
    S i m p l e s

    PS If you find any dead links on MY posts please pm me & I'll try to fix/reload

  4. #3
    TomTom Expert

    yuriyggg's Avatar
    Join Date
    Dec 2011
    Location
    Russia
    Age
    60
    Posts
    589
    Rep Power
    293

    Default

    I know that works very reliably software 9.026 (And I know that it makes no sense to look for a later version of the software.)
    You only need to have a modern version of the maps Today is the 955 series.
    [Only registered and activated users can see links. ]
    [Only registered and activated users can see links. ]

  5. #4
    Junior Member
    Join Date
    Sep 2015
    Location
    midlands
    Posts
    6
    Rep Power
    0

    Default

    I updated my tomtom go 910 with just the map 955 6747 as when looking at the charts. I thought it showed it would work with my navcore 8.415 and patched it but when I start the tomtom it says can not use this map on this device
    will keep reading and maybe I will have to change the navcore as well, when I swap it over from x40 to x30 on my tomtom its says the map is 47 months old.

  6. #5
    TomTom Expert

    biggerdave's Avatar
    Join Date
    Dec 2011
    Location
    Darn sarf
    Posts
    1,773
    Rep Power
    508

    Default

    These will work with 8.415 (why are yoyu using that navcore?) PROVIDED WE HAVE THE METAS. We only have Europe_955_6747, and the France/Iberia/Italy ones in 6747.

    1. Has FastActivate actually created/added a ...meta.dct inside your new map folder?
    2. Did you run options 1 then 2 then 3 in F/A?
    3. Which actual 955 6747 are you trying to activate? If it's the UK one we don't have a meta for it.

    ps here's the current list of 955's we have metas for [Only registered and activated users can see links. ]
    Last edited by biggerdave; 1st October 2015 at 10:52.
    Please do not post "thanks" but use the "reputation" star(*) bottom/left or "like" bottom/left buttons
    S i m p l e s

    PS If you find any dead links on MY posts please pm me & I'll try to fix/reload

  7. #6
    Junior Member
    Join Date
    Sep 2015
    Location
    midlands
    Posts
    6
    Rep Power
    0

    Default

    I put that navcore on the tomtom years ago and at the time I read this was the one to use
    I found this on the net a day or so ago : United Kingdom and Republic of Ireland 955 6747 OR
    United Kingdom and Republic of Ireland 955 6747 with Automatic Installer & Patcher
    I downloaded Automatic Installer & Patcher file which was came down as a exe and a rar file
    I ran the exe had to choose the drive Name for my TomTom and it installed it but my tomtom said it did not work with mine.
    I am unsure if it patched it but after it installs the map it does open a dos window and says metadata updated

  8. #7
    TomTom Expert

    biggerdave's Avatar
    Join Date
    Dec 2011
    Location
    Darn sarf
    Posts
    1,773
    Rep Power
    508

    Default

    That'll teach you to follow cr4p links from copitotal! They always forget to remind you that it's only good IF there's a meta (which there isn't)

    Why not try yuris suggestion of 9.026 as that 8.415 is pretty old and not ideal for your x10 device then just take any UK map we have a meta from from here?

    PS there's really no one specific navcore for your device so have a read through [Only registered and activated users can see links. ] or [Only registered and activated users can see links. ] or just search for what others use on their 510/710/910
    Last edited by biggerdave; 1st October 2015 at 15:40.
    Please do not post "thanks" but use the "reputation" star(*) bottom/left or "like" bottom/left buttons
    S i m p l e s

    PS If you find any dead links on MY posts please pm me & I'll try to fix/reload

  9. #8
    Junior Member
    Join Date
    Sep 2015
    Location
    midlands
    Posts
    6
    Rep Power
    0

    Default

    I have used the Universal Navcore Installer and thats boots nice I am just trying to find a map with a meta, I downloaded Uk and Ireland 955-6745 but I guess this is again not working as it does not have a meta
    I think I will get there in the end

  10. #9
    TomTom Expert

    biggerdave's Avatar
    Join Date
    Dec 2011
    Location
    Darn sarf
    Posts
    1,773
    Rep Power
    508

    Default

    The UK and Ireland 955-6746 is the one you should be using provided your navcore is now 9.0xx or newer
    Please do not post "thanks" but use the "reputation" star(*) bottom/left or "like" bottom/left buttons
    S i m p l e s

    PS If you find any dead links on MY posts please pm me & I'll try to fix/reload

  11. #10
    Junior Member
    Join Date
    Sep 2015
    Location
    midlands
    Posts
    6
    Rep Power
    0

    Default

    I used the universal navcore installer and the map you suggested UK and Ireland 955-6746 all sorted
    It wont let me install computer voices in tomtom home, well the option there but nothing comes up when you open it
    I have installed some human stye voices instead. sorted

 

 
Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.