Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Results 1 to 5 of 5
  1. #1
    Member victor meldrew's Avatar
    Join Date
    Nov 2012
    Location
    NE Coastal UK
    Age
    46
    Posts
    16
    Rep Power
    0

    help GO520 Screen Issue


    Hi all, I have come across an issue that I have never seen before and I'm hoping that someone out there may have an idea of how to correct it.

    TomTom GO520
    M2xxxxAxxxxx

    Everything works fine, except the screen image is displayed off centre to the right -

    [Only registered and activated users can see links. ]

    I have hard reset the device, cleared flash, tried different navcores, bootloaders and tried a new screen. Is there a fix like the digitizer calibration fix?

    Thanks in advance for any help given.

  2.    Advertissements


  3. #2
    TomTom Expert

    biggerdave's Avatar
    Join Date
    Dec 2011
    Location
    Darn sarf
    Posts
    1,780
    Rep Power
    508

    Default

    Have a read through here [Only registered and activated users can see links. ] but be aware this really is a bit of hit & miss science so good luck

    ...or google "tomtom calibration screen"
    Last edited by biggerdave; 18th December 2013 at 10:23.
    Please do not post "thanks" but use the "reputation" star(*) bottom/left or "like" bottom/left buttons
    S i m p l e s

    PS If you find any dead links on MY posts please pm me & I'll try to fix/reload

  4. #3
    Member victor meldrew's Avatar
    Join Date
    Nov 2012
    Location
    NE Coastal UK
    Age
    46
    Posts
    16
    Rep Power
    0

    Default

    Hi Dave, Thanks for the quick response buddy,
    I have just fiddled about with that for the last hour, but it only seems to change the Digitizer calibration only.
    Where the screen is over to the right, strangely or not the digitizer is perfectly calibrated, for instance if I click the far left/top corner
    which is black area on the screen where the zoom key should be, it zooms as expected.
    I get about 10 or so TT a month broken and have never seen this fault, I can add internal memory, change broken usb sockets E.T.C.
    But changing the VGA or even the screen connector is just a bit too much for me!
    Me thinks maybe file this TT in the BIN!
    Thanks for your reply mate, it is very much appreciated.

  5. #4
    TomTom Expert

    biggerdave's Avatar
    Join Date
    Dec 2011
    Location
    Darn sarf
    Posts
    1,780
    Rep Power
    508

    Default

    ....plan b) [Only registered and activated users can see links. ] before plan c...bin the bugger?
    Please do not post "thanks" but use the "reputation" star(*) bottom/left or "like" bottom/left buttons
    S i m p l e s

    PS If you find any dead links on MY posts please pm me & I'll try to fix/reload

  6. #5
    Master Downunder35m's Avatar
    Join Date
    Aug 2010
    Location
    private
    Posts
    609
    Rep Power
    375

    Default

    If the screen is not centered anymore:
    Do a Hard Reset followed byClear flash 3 times,
    delete all files from the device (make a backup!),
    do a clean install of Navcore and map, use the original N_avcore for the device and patch it if necessary.

    If that does not help you might have to replace the screen or have a faulty hardware.
    Password for all my files: downunder

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.