Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Page 4 of 5 FirstFirst ... 2345 LastLast
Results 31 to 40 of 41

Thread: Sygic 15.4.4

  1. #31
    Master asprin624's Avatar
    Join Date
    Aug 2009
    Location
    Belgium
    Age
    68
    Posts
    526
    Rep Power
    152

    Default

    What I am saying here is until Sygic fixes and makes the app stable it is not the right time to screw around with a new map format.
    Which is not downward compatible with other older versions of Sygic.
    They just made v15.3.10 the latest full version on the Google store.
    Now they come out with maps that will not work on that version or any other version before 15.4.x.
    There will be a lot of users that will not be happy with this.
    There are a lot of older versions that user's a very happy with and not cannot get map updates they have paid for.

    Learn the lesson from MS v8.0 they screwed up big time with those changes.
    Now they give away MS v10 for free to make the user base happy again.

    I am not complaining but pointing out fact.

  2.    Advertissements


  3. #32
    Super Member Nx4's Avatar
    Join Date
    Sep 2014
    Location
    79.933202, -99.228398
    Posts
    164
    Rep Power
    27

    Default

    In this discussion I think chambers has more arguments in his favor. They have one perfect version, yes perfect. 14.3.4. They want to introduce a new interface. They made it. With limitations! No older Android version possible to get it. Users were unhappy. But users still manage to get map updates, which were compatible with older versions. Until now. Sygic decided to cut off that. If you want new maps, you must change your hardware, e.g software. Simple trick, but left many disappointed.
    We'll see if it was the right move for them.

    Sent from my LG E960 Mako using Tapatalk

  4. #33
    Master
    Join Date
    Mar 2015
    Location
    127.0.0.1
    Posts
    159
    Rep Power
    52

    Default

    Quote Originally Posted by Nx4 View Post
    In this discussion I think chambers has more arguments in his favor. They have one perfect version, yes perfect. 14.3.4. They want to introduce a new interface. They made it. With limitations! No older Android version possible to get it. Users were unhappy. But users still manage to get map updates, which were compatible with older versions. Until now. Sygic decided to cut off that. If you want new maps, you must change your hardware, e.g software. Simple trick, but left many disappointed.
    We'll see if it was the right move for them.

    Sent from my LG E960 Mako using Tapatalk
    Both guys have good arguments.
    Progress is good. But Sygic's time to market opportunism sucks.

  5. #34
    Member bat's Avatar
    Join Date
    Dec 2014
    Location
    Croatia-Split
    Age
    26
    Posts
    17
    Rep Power
    0

    Default

    works great on the Samsung s4

  6. #35
    Junior Member
    Join Date
    Aug 2015
    Location
    greece
    Posts
    5
    Rep Power
    0

    Default

    is this version stable?

  7. #36
    Member +
    Join Date
    Aug 2015
    Location
    earth
    Posts
    39
    Rep Power
    2

    Default

    Nope. Stable version is 15.3.10.

  8. #37
    Member
    Join Date
    Aug 2015
    Location
    Greece
    Posts
    17
    Rep Power
    0

    Default

    Hi to all in the forum. I have the 15.4.1 version of sygic with 2015.06 maps which I installed 1 week ago. Now, gps shows to me a message (in sygic store menu) that ending at 31.8.2015 and I must get Premium gps Navigation for 19.99 . Anyone any idea please?Thanks in advance!

  9. #38
    Member + Mauritsz's Avatar
    Join Date
    Aug 2011
    Location
    Texel
    Posts
    84
    Rep Power
    6

    new

    Maybe first post can be changed to mapdownloader version of today.
    Last edited by Mauritsz; 26th August 2015 at 14:59.

  10. #39
    GPSPower Helper

    Brown Dog's Avatar
    Join Date
    Mar 2010
    Location
    Madagascar
    Posts
    1,305
    Rep Power
    1312

    Default

    soon 15.4.6

  11. #40
    Member
    Join Date
    Aug 2015
    Location
    Greece
    Posts
    17
    Rep Power
    0

    Default

    Quote Originally Posted by Tziminhio View Post
    Hi to all in the forum. I have the 15.4.1 version of sygic with 2015.06 maps which I installed 1 week ago. Now, gps shows to me a message (in sygic store menu) that ending at 31.8.2015 and I must get Premium gps Navigation for 19.99 . Anyone any idea please?Thanks in advance!
    Can any answer in this question? Is there any posibility after 31.8.15 sygic stop its function or it writes it to all of you? May I have not install in the right way the crack. Is this happens due to the fact that I use gps while I was opening the 3g connection?
    Last edited by Tziminhio; 27th August 2015 at 11:51.

 

 
Page 4 of 5 FirstFirst ... 2345 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.