Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 50

Thread: Sygic 14.7.7

  1. #21
    Master asprin624's Avatar
    Join Date
    Aug 2009
    Location
    Belgium
    Age
    68
    Posts
    526
    Rep Power
    152

    Default

    "maury22" efforts are very commendable to get sounds to work.
    It is a shame that user's have to find tricks to get things working that were there before the new UI.

    I think Sygic is up to the 24th version of the new UI and still problems after problems.

    Now "educky" points out yet another item that will be put back into Sygic.
    But you will have to pay for it.

    As you can see slowly every item that made Sygic a very good GPS app is being taken apart and being put back as a paid item.

    The problem with this is they are tuning off user's who had paid for a full working version back with v14.3.4

    They are forced to upgrade if they want new maps.
    Why should a paid user have to upgrade to get new maps?
    But we know the new TomTom maps version 2014.09 work great with the v14.3x versions but you can not get them as a paid user.

    Then at the same time lose all the items that they had for a new UI that only has problems and missing some many things that made it a great GPS app.

    What a waste of a great GPS App that once was........

  2.    Advertissements


  3. #22
    Member +
    Join Date
    Aug 2013
    Location
    spain
    Age
    47
    Posts
    90
    Rep Power
    23

    Default

    totally agree with chambers...the moment that 14.3.4 stops supporting new versions of maps, I will no more care for Sygic.
    ....unless problems are solved (in the next 24 "beta" versions perhaps)

  4. #23
    Important User

    maury22's Avatar
    Join Date
    Aug 2013
    Location
    ITALY
    Posts
    791
    Rep Power
    195

    Default

    @chambers


    The update to version 14.7.0 has been free for their paying users....but not the optional features.

    I think what on 14.3.4 (cr@cked) version TA maps will work up to 2014 12 ..... then change maps compression and no longer be able to read the later ones (2015) ...

  5. #24
    Master educky's Avatar
    Join Date
    May 2014
    Location
    germany
    Posts
    78
    Rep Power
    49

    Default

    we will see next month what the v15 brings innovations

  6. #25
    Important User

    maury22's Avatar
    Join Date
    Aug 2013
    Location
    ITALY
    Posts
    791
    Rep Power
    195

    Default

    @ educky



    Yeah !!!

    I hope Sygic not make another 20 Beta for 15.xx version.....

    I don't think there exists another Gps software producer that works hurt as much as Sygic ....

  7. #26
    Pro-Member
    Join Date
    Aug 2014
    Location
    Romania
    Posts
    248
    Rep Power
    28

    Default

    On Lenovo A536, the Sygic 14.7.7 does not working with the NT maps. Only TT maps are working fine.
    I have installed Play Store patched, but I can't use anymore the NT maps.
    First run show 7 days trial. Sometimes ask me to go to the Play Store to purchase the full version.

    On my Galaxy S5 is working fine without a problem.

    The Sygic has problems on other devices too..

  8. #27
    Junior Member
    Join Date
    Jan 2015
    Location
    holland
    Posts
    2
    Rep Power
    0

    Default

    Need to change WCL folder in maps??
    come from 13.4.2!!

  9. #28
    Important User

    maury22's Avatar
    Join Date
    Aug 2013
    Location
    ITALY
    Posts
    791
    Rep Power
    195

    Default

    I still use that one 14.3.2 version .....never changed!

    Now I use T.A. 2014.09 maps....

  10. #29
    Master asprin624's Avatar
    Join Date
    Aug 2009
    Location
    Belgium
    Age
    68
    Posts
    526
    Rep Power
    152

    Default

    Quote Originally Posted by maury22 View Post
    I still use that one 14.3.2 version .....never changed!

    Now I use T.A. 2014.09 maps....
    One of the best versions they ever came up with.

  11. #30
    Super Member Nx4's Avatar
    Join Date
    Sep 2014
    Location
    79.933202, -99.228398
    Posts
    164
    Rep Power
    27

    Default

    Quote Originally Posted by maury22 View Post
    I think what on 14.3.4 (cr@cked) version TA maps will work up to 2014 12 ..... then change maps compression and no longer be able to read the later ones (2015) ...
    That'll be terrible. What to say those users who bought Sygic older versions (like 14.3.4) and can't update it due to Android limitation. For example I have device running Gingerbread.



    Sent from my LG E960 Mako using Tapatalk

 

 
Page 3 of 5 FirstFirst 12345 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.