Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16
  1. #11
    Member +
    Join Date
    Oct 2007
    Location
    KSA
    Age
    36
    Posts
    37
    Rep Power
    10

    Default

    For me I like The older version 13.4.2 .. Foursquare search is very good , better looking than even 15.0.0 , more alternative paths for your trip and more smooth on Samsung note 10.1 2014 and Sony Xperia Z2
    What i the benefit of 14.3.4 over 13.4.2 ?

  2.    Advertissements


  3. #12
    Important User

    osiris4isis's Avatar
    Join Date
    Apr 2012
    Location
    Farside of the Sun
    Posts
    2,645
    Rep Power
    638

    Default

    Quote Originally Posted by dr_neoman View Post
    For me I like The older version 13.4.2 .. Foursquare search is very good , better looking than even 15.0.0 , more alternative paths for your trip and more smooth on Samsung note 10.1 2014 and Sony Xperia Z2
    What i the benefit of 14.3.4 over 13.4.2 ?
    What is latest version of maps can you use in 13.4.2?

  4. #13
    Member
    Join Date
    Oct 2014
    Location
    spain
    Posts
    25
    Rep Power
    3

    Default

    Quote Originally Posted by osiris4isis View Post
    What is latest version of maps can you use in 13.4.2?
    I have 14.3.4 installed with teleatlas 09.2014 working OK, foursquare is in so it makes searching POI really efficient. You could try this version works really well.
    cheers

  5. #14
    Member
    Join Date
    Feb 2015
    Location
    The Netherlands
    Posts
    24
    Rep Power
    2

    Default

    Same here as ZZAS

    As what it looks like, I'll stay by 14.3.4. if the newer versions stay as they are now.
    Good clear GUI for 14.3.4.
    Everything works well
    Still able to update the TA maps, last map is 2014.09...

  6. #15
    Important User

    maury22's Avatar
    Join Date
    Aug 2013
    Location
    ITALY
    Posts
    790
    Rep Power
    195

    Default

    Probably 14.3.4 version ordered to bear T.A. maps up to 2014.12....
    Then Sygic will change the maps compression (as it always has previously done) and will no longer be usable.......

  7. #16
    Member
    Join Date
    Feb 2015
    Location
    The Netherlands
    Posts
    24
    Rep Power
    2

    Angry

    Quote Originally Posted by maury22 View Post
    Probably 14.3.4 version ordered to bear T.A. maps up to 2014.12....
    Then Sygic will change the maps compression (as it always has previously done) and will no longer be usable.......
    Oh my Goodness...
    So they force you to use an other GUI, or rewritten program, even when you totally not agree with the new set-up?
    That's really stupid.
    Version 14.3.4. give me a lot of satisfaction as it is.
    No problem's, no crashed smartphone.

    I am using a very handy free app together with Sygic, this one:
    Click->
    Code:
    Please Login or Register to see the links
    You don't have to type the route you want to go, just say it, and to app will start Sygic with the route already implanted.
    I am not sure this tool will work with the newer version of Sygic.

 

 
Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.