Welcome guest, is this your first visit? Click the "Create Account" button now to join.

View Poll Results: Which Sygic version is best?

Voters
63. You may not vote on this poll
  • I like old GUI (example 14.3.4)

    44 69.84%
  • I like new GUI (example 15.x)

    14 22.22%
  • I don't like Sygic and doesn't use it

    5 7.94%
Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 42
  1. #21
    Member
    Join Date
    Oct 2014
    Location
    spain
    Posts
    25
    Rep Power
    3

    Default

    I ALWAYS...always....go to sygic 14.3.4 using maps 2014.09.

    Never a problem with that, no lag, no fc, re routing fast, never got lost.
    And I promised myself to not test any other sygic, because it has become a waste of time.
    These guys screwed up and they do not know how to find a way out. It is not serious to change versions every week...and full of bugs. Horrible.

  2.    Advertissements


  3. #22
    Pro-Member
    Join Date
    Jan 2015
    Location
    The Netherlands
    Age
    66
    Posts
    229
    Rep Power
    3

    Default

    Quote Originally Posted by keesdewit View Post
    [Only registered and activated users can see links. ]
    Thanx so much Kees.

    14.3.4 will work with 03-2015 maps ?

  4. #23
    Master
    Join Date
    Mar 2015
    Location
    127.0.0.1
    Posts
    159
    Rep Power
    52

    Default

    Quote Originally Posted by chambers View Post
    That is not what I said.

    It is the info added to the bottom of the list that is new since v15.5.1.

    aka whitelist / blacklist
    If you look at older "compatibility_table" you will not see it before v15.5.1
    I absolutely agree with you about Sygic's non-transparancy concerning supported devices, versions and the lot.

    But I don't see what this has to do with the added blacklist items in "compatibility_table".
    For almost a year Nexus 5 has a known GPS problem when upgrading from Android 4.4 to 5.0 and higher, so there is a reason for exclusion.
    Ditto for the Vivante renderer which has a very diffent specification for enabling direct GPU control and multithreading efficiency as well as combining and optimizing graphics and compute.

  5. #24
    Master
    Join Date
    Mar 2015
    Location
    127.0.0.1
    Posts
    159
    Rep Power
    52

    Default

    Quote Originally Posted by rider View Post
    Thanx so much Kees.

    14.3.4 will work with 03-2015 maps ?
    After adjusting the content.info file to the right map versions it 'll work.

  6. #25
    Member
    Join Date
    Aug 2015
    Location
    Germany
    Posts
    24
    Rep Power
    0

    Default

    can you post here please..the content info..or can i use the latest..fromm 15.X.XXX

  7. #26
    Master
    Join Date
    Jan 2013
    Location
    athens greece
    Age
    52
    Posts
    130
    Rep Power
    58

    Default

    Quote Originally Posted by keesdewit View Post
    [Only registered and activated users can see links. ]
    this version of 14.3.4 dint work in samsung tablet3.i remember from the past i take a apk only and the base of14.3.2 and it works.but i cant find the post now.its from our site gpspower

  8. #27
    Member
    Join Date
    Aug 2015
    Location
    Germany
    Posts
    24
    Rep Power
    0

    Default

    Quote Originally Posted by zzas View Post
    I ALWAYS...always....go to sygic 14.3.4 using maps 2014.09.

    Never a problem with that, no lag, no fc, re routing fast, never got lost.
    And I promised myself to not test any other sygic, because it has become a waste of time.
    These guys screwed up and they do not know how to find a way out. It is not serious to change versions every week...and full of bugs. Horrible.


    Yes ...

    i believe they canot understand,,he will destroy her self.

  9. #28
    Junior Member
    Join Date
    Sep 2014
    Location
    Malaysia
    Posts
    9
    Rep Power
    0

    Default

    I think the version 14.3.4 is the most classic until now. They do the wrong change direction on their after version.

  10. #29
    Member
    Join Date
    Aug 2015
    Location
    Germany
    Posts
    24
    Rep Power
    0

    Default

    Yes i did it ,,it works with 2015 03 maps..

    vers 14.3.4,,best.

  11. #30
    Super Member Nx4's Avatar
    Join Date
    Sep 2014
    Location
    79.933202, -99.228398
    Posts
    164
    Rep Power
    27

    Default

    Well, it's probably the best version out there, but it dies slowly. These 03/15 maps are the last which will work. So, no new maps afterwards, no point of using ver. 14.3.4.
    Sygic killed the most stable software they were able to create ever. Sad, but true.


    Sent from my HTC Explorer A310e using Tapatalk 2

 

 
Page 3 of 5 FirstFirst 12345 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.