Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    Oct 2015
    Location
    greece
    Posts
    3
    Rep Power
    0

    Default Sygic Map Compatibility?

    Hello Everybody,

    Nice site. Quick question please.

    If I'm using Sygic 14.7.2 will the newest maps & poi's work with this version or
    do I have to download the latest version of Sygic for the latest maps to work?

    Thank You...

  2.    Advertissements


  3. #2
    Master asprin624's Avatar
    Join Date
    Aug 2009
    Location
    Belgium
    Age
    68
    Posts
    532
    Rep Power
    152

    Default

    Quote Originally Posted by georgie View Post
    Hello Everybody,

    Nice site. Quick question please.

    If I'm using Sygic 14.7.2 will the newest maps & poi's work with this version or
    do I have to download the latest version of Sygic for the latest maps to work?

    Thank You...
    Take the time to read.
    There is enough info posted on this forum.

    New TomTom 2015.06 maps v9.01 work at Sygic 15.4.+

    See link:

    [Only registered and activated users can see links. ]

  4. #3
    Junior Member
    Join Date
    Oct 2015
    Location
    greece
    Posts
    3
    Rep Power
    0

    Default

    Thanks for your response.
    I'm using Sygic 14.7.2 and post says work at Sygic 15.4.+. which confused me...

  5. #4
    Master asprin624's Avatar
    Join Date
    Aug 2009
    Location
    Belgium
    Age
    68
    Posts
    532
    Rep Power
    152

    Default

    Quote Originally Posted by georgie View Post
    Thanks for your response.
    I'm using Sygic 14.7.2 and post says work at Sygic 15.4.+. which confused me...
    If you want to use the new maps I would use this version 15.4.10

    Link:
    [Only registered and activated users can see links. ]

    It is stable.
    Then use the downloader to get the maps you need.
    Make sure you download the WCL folder and copy the content.info along with the map folders you need.
    TomTom maps not Here maps.
    See that you have a very old version I would first copy the Sygic folder to your PC.
    Then delete the folder off your phone or tablet.
    Uninstall v 14.7.2 clear the cache. reboot.
    Then copy the new Sygic folder to your phone or tablet on the External SD card.
    Then copy the Map folder from the downloader over to Sygic folder.
    Then copy the app over to the root of the SD card.
    Install it
    Then start Sygic and set it up the way you want.
    Make sure you skip email and leave the wifi off when you install and run it.

  6. #5
    Junior Member
    Join Date
    Sep 2015
    Location
    south carolina
    Posts
    1
    Rep Power
    0

    Default

    Sorry to jump on the band wagon, but I have sygic fleet 8.30 r-19687MD
    I can activate it but it says maps not found? can some one show me how to install maps (i do have them in the maps dir but in the mlm how do i write it in?)...
    I know using too new maps (nt.2015.06) which do i need?
    and last question i also downloaded Fleet 15i Rbx-00020 MD is there a keygen for this?

 

 

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.