Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Likes Likes:  0
Results 1 to 9 of 9
  1. #1
    Master cnrv77's Avatar
    Join Date
    Jun 2006
    Location
    Dark Side
    Age
    51
    Posts
    193
    Rep Power
    3508

    Default Fix for voices in Nokia Maps 3.0.0302

    From TYX
    [SIZE="3"]I found out that the newest set of voices do not work in my N95 8GB. Even though navigation works fine, the phone remains mute.
    I found the problem, and all my voices work now, and since I see this voice problem all the time, I hope this helps some of you.

    The problem is in the newest release, 0.2.0.20090504, released as the name implies on the 4th of May. The programmer tried to separate some functions from the configuration file, config.lua and put them in common.lua, but it doesn't work... at least not on my phone.

    Putting the functions back to what they were in the previous version, released on the 12th of Feb., sorts all the problems and navigation works like a dream.

    You have to use your pc for this, connect the phone in data transfer mode, and go to cities/diskcache/voices/{voice you want} .
    - Delete the common.lua file.

    - Open the config.lua file with notepad. Only 2 changes are necessary.
    - Delete the line require("common")
    - Three lines down, replace the line get_common_code() with the following chunk: (Copy/paste)

    if trigger == "GPS_SIGNAL_LOST" or trigger == "GPS_SIGNAL_RESTORED" or trigger == "NO_GPS_SIGNAL" or trigger == "ROUTE_RECALCULATION" then
    process_gps_triggers()
    end
    if trigger == "COMMAND" or trigger == "REMINDER1" or trigger == "REMINDER2" or trigger =="ANNOUNCEMENT" then
    process_maneuver_triggers()
    end
    if trigger == "SAFETYSPOT_WARNER" then
    if above_speed_limit == true then
    table.insert(result_list, misc[ "safety_camara_ahead_wav" ] )
    else
    table.insert(result_list, misc[ "beep_sound" ] )
    end
    end
    if trigger == "SPEED_WARNER" then
    table.insert(result_list, misc[ "over_speed_limit_wav" ] )
    end
    if trigger == "TRAFFIC_WARNER" then
    if avoidance_mode == "AUTOMATIC_AVOIDANCE" then
    table.insert(result_list, misc[ "traffic_automatic_detour_wav" ] )
    elseif avoidance_mode == "MANUAL_AVOIDANCE" then
    table.insert(result_list, misc[ "traffic_manual_detour_wav" ] )
    else
    table.insert(result_list, misc[ "beep_sound" ] )
    end
    end
    if trigger == "PEDESTRIAN_COMMAND" then
    if maneuver_1.id == "STOPOVER" then
    table.insert(result_list, misc[ "stopover_wav" ] )
    elseif maneuver_1.id == "END" then
    table.insert(result_list, misc[ "destination_wav" ] )
    else
    table.insert(result_list, misc[ "beep_sound" ] )
    end
    end


    Save, and you are done.

    Now your voices will work.
    LISTEN BELLYUP4BLUES , THE BEST INTERNET RADIO
    dpzl1j
    Read The Rules,Search Before Posting
    To see hidden threads links ,please hit forum "Like" button on the post right bottom corner.
    You dont need to have 10 posts to see the unhidden links. Please dont spam.

    Thanks post Will be trash

  2.    Advertissements


  3. #2
    Junior Member
    Join Date
    Nov 2007
    Age
    34
    Posts
    6
    Rep Power
    0

    Default

    Thanks a lot man .. it solved the problem, i couldnt understand why the voice guidance stopped ...
    i worked great on my N82 ...
    rep add ...

  4. #3
    Junior Member
    Join Date
    Nov 2008
    Location
    Greece
    Posts
    2
    Rep Power
    0

    Default

    Wow, you're fast

    Glad it helps.
    Two notes that might help some people:

    You can check which version of voices you have, by looking in the "skin_(language)_(gender).lua" file, in the 8th line, "audio_files_version". Or more simply, if your voice folder contains the file common.lua, you have the newest voices. The working version is 0.2.0.20090212

    Also remember that the voices only work in DRIVE mode. Walking navigation does not have voices, for reasons of common sense

  5. #4
    Member
    Join Date
    Jan 2008
    Location
    Bedrock
    Posts
    14
    Rep Power
    0

    Default

    Quote Originally Posted by Tyx View Post
    Wow, you're fast

    Glad it helps.
    Two notes that might help some people:

    You can check which version of voices you have, by looking in the "skin_(language)_(gender).lua" file, in the 8th line, "audio_files_version". Or more simply, if your voice folder contains the file common.lua, you have the newest voices. The working version is 0.2.0.20090212

    Also remember that the voices only work in DRIVE mode. Walking navigation does not have voices, for reasons of common sense

    Do you fix for newest voice audio_files_version = "0.2.0.20090504"??

  6. #5
    Junior Member
    Join Date
    Nov 2008
    Location
    Greece
    Posts
    2
    Rep Power
    0

    Default

    Quote Originally Posted by ky1 View Post
    Do you fix for newest voice audio_files_version = "0.2.0.20090504"??
    Yes, that is the newest NON-working version (04/05/2009). The new structure doesn't work in most phones, but it works if you change it back to what it was in the previous February version. Just follow the instructions in the first post.

  7. #6
    ☼ADMIN☼
    catymag's Avatar
    Join Date
    Nov 2007
    Location
    light side
    Posts
    23,553
    Rep Power
    5307

    Default

    Tyx rep added
    cnrv sorry mssr
    [Only registered and activated users can see links. ]
    [Only registered and activated users can see links. ]

    [Only registered and activated users can see links. ]
    You have to navigate to get to the good.
    Nuvi1250/Nuvi 34xx/Nuvi 2200/Nuvi 66/Oregon 600/Galaxy S5 MM 6.0.1/TomTom GO/iGO Nextgen Avic,Basar,Isr.Gift/Navigon
    Please don't flood my pm box with questions you can post on forum!! You won't hear back from me.

  8. #7
    Junior Member
    Join Date
    Aug 2009
    Location
    Nunraton
    Posts
    3
    Rep Power
    0

    Default

    THANKS man i can say now that i have not wasted one week on this. YOU ARE A ROCK STAR. THANKS A TON

  9. #8
    Junior Member
    Join Date
    Oct 2009
    Posts
    4
    Rep Power
    0

    Default

    Thanks for the fix

  10. #9
    Junior Member
    Join Date
    Nov 2009
    Age
    26
    Posts
    2
    Rep Power
    0

    Default

    It works, you are a superstar :D, im so happy that i can navigate with my mobile now :D

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.