Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Page 5 of 7 FirstFirst ... 34567 LastLast
Results 41 to 50 of 64
  1. #41
    Important User

    osiris4isis's Avatar
    Join Date
    Apr 2012
    Location
    Farside of the Sun
    Posts
    2,646
    Rep Power
    639

    Default

    Quote Originally Posted by Neil View Post
    Some bright young chap could maybe make a little app to pull the graphics out of other 'non-gir' bin files? Are you likely to find anything different and useful in them d'ya think?
    Well the scanner was hungry so I feed it zumo590's boot.bin and surprisingly there are PNG files (there might be other graphic files like .bmp but my proggy only works on .png) Different yes, useful? I have no idea.
    Spoiler: .

    [Only registered and activated users can see links. ]
    Attached Files Attached Files
    • This post requires you to click the "LIKE this post" button to see Attachments.
    Last edited by osiris4isis; 9th June 2015 at 03:08.

  2.    Advertissements


  3. #42
    Garmin/GPS Systems GMod.

    Neil's Avatar
    Join Date
    Aug 2011
    Location
    Oz.
    Posts
    7,405
    Rep Power
    1434

    Default

    Quote Originally Posted by osiris4isis View Post
    Good info, mate! But I was thinking that since Cyclop alerts often uses those cool red icons and since I didn't find any, I assumed that it didn't support it. TW firmware does seem to have speedcam alerts, but is it Cyclop capable? Remember Cyclop alerts uses a special record that has 3 points and probably some data indicating which build-in icons to use (there are no icons included in the Cyclop .gpi's) Now that I know fw_resources.bin contained icons (including Cyclop's) the next thing to do is to find a correlation between those icons and the data in .gpi This will definitely help to decode Cyclop records some more. But I might need your help to test the .gpi file to see if icons is shown correctly after mod. How you say "sweet!" in Klingon?
    Yep that's what i meant, all Asian incl TWN probably uses the black icon for redlight as confirmed for SG/MY above. i.e. not just for speedcams, all cyclops alerts. I had no other US gpi files in use only latest safety_camera_us_canada.gpi issued June 8th, so that's a cyclops redlight alert on US41 N for sure. I suppose the same triggering applies with the Asian fw as for US/EU, but if you want more tests just tell me what's required.

    Klingon for 'sweet!' is 'quv!' In plqaD characters that's [Only registered and activated users can see links. ]. Anything else i can do for you? [how ya off fer undies and socks still mate?]. If you plead a bit i'll convert the 765 to TWN and test it, or you could just extract the symbols from SG/MY to check what they are and compare to TWN instead:
    Code:
    Please Login or Register to see the links
    Seriously, happy to do more testing of files for you when you've modded them.

    EDIT: Some interesting looking icons in zumo 590 boot.bin .....
    Btw, Have a look here too for more symbols from fw: [Only registered and activated users can see links. ].
    Last edited by Neil; 9th June 2015 at 10:09. Reason: add btw.
    'Thanking Posts' are banned. To thank someone, and/or to see hidden links and content, use the [Only registered and activated users can see links. ] button below left of the helpful post then refresh your browser [F5 key]. 'Thanking Posts' are banned.
    Please don't spam. Posts serving no purpose other than to thank or to ask about hidden links are trashed or deleted, it's GPSPower's policy. Please don't spam.
    [Only registered and activated users can see links. ] should make their first post as a new Intro Thread in [Only registered and activated users can see links. ].

  4. #43
    Important User

    osiris4isis's Avatar
    Join Date
    Apr 2012
    Location
    Farside of the Sun
    Posts
    2,646
    Rep Power
    639

    Default

    Quote Originally Posted by Neil View Post
    If you plead a bit i'll convert the 765 to TWN and test it, or you could just extract the symbols from SG/MY to check what they are and compare to TWN instead:
    Code:
    Please Login or Register to see the links
    Seriously, happy to do more testing of files for you when you've modded them.
    I've extracted symbols from nuvi765_SG_v250 and few of them are corrupted. I don't think it's my proggy doing since this is the first time I've seen corruptions from all my extract testing. I've crosschecked the start and end pointers of PNG data and they are correct; so it only means the .gcd file has corruptions. Are you running the SG_v250 in your unit?
    Look at BMP_FIND_SHOPPING_HGLT.png for example of a corrupted .png
    Spoiler: .

    [Only registered and activated users can see links. ]


    Edit: Nevermind, I know what's wrong. Those Garmin developers are just pure evil.
    Last edited by osiris4isis; 9th June 2015 at 20:58.

  5. #44
    Garmin/GPS Systems GMod.

    Neil's Avatar
    Join Date
    Aug 2011
    Location
    Oz.
    Posts
    7,405
    Rep Power
    1434

    Default

    Yes, that's the same fw i'm running, apart from the boot.bin which is US [v4.50]. It and and SG [v2.50] fw_all naturally have overwrite of HWID to 0870 & SW Version to 4.51. So my fw_all bin and original fw_all from SG gcd files should match apart from hwid & sw version changes. Anyway, here's my actual fw:
    Spoiler: Click
    [Only registered and activated users can see links. ]


    How are the symbols from fw_all.bin corrupt? I only checked the first 100 or so and they looked ok but there's over 900 of the little blighters.

    EDIT: Sorry, just saw you've edited to explain so disregard above. This is what i was replying to:
    I've extracted symbols from nuvi765_SG_v250 and few of them are corrupted. I don't think it's my proggy doing since this is the first time I've seen corruptions from all my extract testing. I've crosschecked the start and end pointers of PNG data and they are correct; so it only means the .gcd file has corruptions. Are you running the SG_v250 in your unit?
    didn't see this:
    Look at BMP_FIND_SHOPPING_HGLT.png for example of a corrupted .png
    ...............
    Edit: Nevermind, I know what's wrong. Those Garmin developers are just pure evil.
    Gotcha now. In what way exactly are they evil? [i know that are, but how? lol].
    Last edited by Neil; 9th June 2015 at 21:14. Reason: add EDIT:
    'Thanking Posts' are banned. To thank someone, and/or to see hidden links and content, use the [Only registered and activated users can see links. ] button below left of the helpful post then refresh your browser [F5 key]. 'Thanking Posts' are banned.
    Please don't spam. Posts serving no purpose other than to thank or to ask about hidden links are trashed or deleted, it's GPSPower's policy. Please don't spam.
    [Only registered and activated users can see links. ] should make their first post as a new Intro Thread in [Only registered and activated users can see links. ].

  6. #45
    Important User

    osiris4isis's Avatar
    Join Date
    Apr 2012
    Location
    Farside of the Sun
    Posts
    2,646
    Rep Power
    639

    Default

    They randomly drop bd0200ff bombs to corrupt true data.

  7. #46
    Garmin/GPS Systems GMod.

    Neil's Avatar
    Join Date
    Aug 2011
    Location
    Oz.
    Posts
    7,405
    Rep Power
    1434

    Default

    Ahhh! [clear as mud ].
    'Thanking Posts' are banned. To thank someone, and/or to see hidden links and content, use the [Only registered and activated users can see links. ] button below left of the helpful post then refresh your browser [F5 key]. 'Thanking Posts' are banned.
    Please don't spam. Posts serving no purpose other than to thank or to ask about hidden links are trashed or deleted, it's GPSPower's policy. Please don't spam.
    [Only registered and activated users can see links. ] should make their first post as a new Intro Thread in [Only registered and activated users can see links. ].

  8. #47
    Important User

    osiris4isis's Avatar
    Join Date
    Apr 2012
    Location
    Farside of the Sun
    Posts
    2,646
    Rep Power
    639

    Default

    Quote Originally Posted by Neil View Post
    Ahhh! [clear as mud ].
    Sorry, in slow e n g l i s h...

    Lets say your PNG data is:
    Code:
    Please Login or Register to see the links
    Garmin gives you this:
    Code:
    Please Login or Register to see the links
    this is data corruption by insertion of tags. But not to fear, it's just a one liner for me to fixed it.
    Last edited by osiris4isis; 14th October 2015 at 03:35.

  9. #48
    Important User

    osiris4isis's Avatar
    Join Date
    Apr 2012
    Location
    Farside of the Sun
    Posts
    2,646
    Rep Power
    639

    Default

    Ok, looks like turboccc proggy SymbolExtractor133 has problem with few extraction; look at BMP_PAT_CONIFER.bmp and BMP_PAT_CASUARINA.bmp extracted* from nuvi765_SG_v250, they look the same garbled image. They should be like this [Only registered and activated users can see links. ]

    * You have to extracted it to proved that it's not my environment that messing it up.

    Edit: A whole lot more of bad extraction [Only registered and activated users can see links. ]
    Last edited by osiris4isis; 10th June 2015 at 04:45.

  10. #49
    Garmin/GPS Systems GMod.

    Neil's Avatar
    Join Date
    Aug 2011
    Location
    Oz.
    Posts
    7,405
    Rep Power
    1434

    Default

    GIT_Editor too on occasional gets a 'bad-looking' BMP image display from a logo, however regardless it will display ok on the device. Examples: BMW nuvi 37x0 [Only registered and activated users can see links. ] [post #20] and nuvi 3x0 [Only registered and activated users can see links. ] [post #38]. Maybe this is somehow related to what you've found.
    'Thanking Posts' are banned. To thank someone, and/or to see hidden links and content, use the [Only registered and activated users can see links. ] button below left of the helpful post then refresh your browser [F5 key]. 'Thanking Posts' are banned.
    Please don't spam. Posts serving no purpose other than to thank or to ask about hidden links are trashed or deleted, it's GPSPower's policy. Please don't spam.
    [Only registered and activated users can see links. ] should make their first post as a new Intro Thread in [Only registered and activated users can see links. ].

  11. #50
    Important User

    osiris4isis's Avatar
    Join Date
    Apr 2012
    Location
    Farside of the Sun
    Posts
    2,646
    Rep Power
    639

    Default

    Quote Originally Posted by Neil View Post
    GIT_Editor too on occasional gets a 'bad-looking' BMP image display from a logo, however regardless it will display ok on the device. Examples: BMW nuvi 37x0 [Only registered and activated users can see links. ] [post #20] and nuvi 3x0 [Only registered and activated users can see links. ] [post #38]. Maybe this is somehow related to what you've found.
    Yes that is what I found. When the image was garbled, I had no idea what it was. So I examine the data directly and cut/paste to a similar size .bmp template that has same header. Sure enough, it showed correctly. So it's not the data in the file that's bad, it's the extraction. Not a major issue but it's hard to know what you're replacing/modifying if the extraction is bad.

 

 
Page 5 of 7 FirstFirst ... 34567 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.