Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Likes Likes:  0
Results 1 to 4 of 4
  1. #1
    Junior Member
    Join Date
    Aug 2016
    Location
    Nottingham
    Posts
    2
    Rep Power
    0

    Default Faulty rneg2 help

    Hi please help, I forgot to disconnect the battery before refitting the rneg2 stereo and I must have blown it when connecting wires back up.
    The stereo switches on but no longer picks up any stations or plays music when the cd is playing, I can however view the satnav but when I upload a new route the radio resets itself prior to completion of the loading of the map.
    There is also the mute icon on the screen in the top corner which I cannot remove.

    Is there anyway I can fix this as it appears a new stereo is VERY expensive.

    Very daft mistake I admit but any help would massively be appreciated!

  2.    Advertissements


  3. #2
    Moderator

    Bricoman's Avatar
    Join Date
    Dec 2014
    Location
    All over the place
    Posts
    1,119
    Rep Power
    243

    Default

    Hello,

    Always disconnect the car battery before touching the electrical system at the risk of damage to the equipment.
    For work at home, it's the same thing !
    You can say more and do some photo equipment ?
    Being different is neither a good or a bad thing, this means that you are brave enough to be yourself

  4. #3
    Junior Member
    Join Date
    Aug 2016
    Location
    Nottingham
    Posts
    2
    Rep Power
    0

    Default

    I was in a rush and forgot I reconnected the stereo very costly mistake.😞
    I am assuming I have blown the internal amp? If it's past repair where is the best place to pick up a used one? Also the screen itself is temperamental in hot weather it won't pop up fully and on occasions it won't move at all any advice? This fault was there before I blew the stereo btw lol!

    Thanks!

  5. #4
    Moderator

    Bricoman's Avatar
    Join Date
    Dec 2014
    Location
    All over the place
    Posts
    1,119
    Rep Power
    243

    Default

    Hello,

    The small cooling fan on the device is sometimes blocked or down ?
    Which causes malfunction of the display or device ?
    There are very fortunate that the unit is damaged after hot-plugging !
    Done research on the ads of used equipment or broken vehicles.
    Being different is neither a good or a bad thing, this means that you are brave enough to be yourself

 

 

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.