Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Likes Likes:  0
Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19
  1. #11
    Member
    Join Date
    Jun 2016
    Location
    -
    Posts
    10
    Rep Power
    0

    Default

    Bump!

    Can you recommend my on an aftermarket multimedia system that I can install?

    Sent from my A0001 using Tapatalk

  2.    Advertissements


  3. #12
    Moderator

    Bricoman's Avatar
    Join Date
    Dec 2014
    Location
    All over the place
    Posts
    1,119
    Rep Power
    243

    Default

    Quote Originally Posted by mosheva View Post
    Bump!

    Can you recommend my on an aftermarket multimedia system that I can install?

    Sent from my A0001 using Tapatalk
    Hello,

    Go to see your dealer CitroŽn, it know very well your device, ask GPS technician.
    Its best to keep original GPS factory in your car.

  4. #13
    Member
    Join Date
    Jun 2016
    Location
    -
    Posts
    10
    Rep Power
    0

    Default

    I will ask... I think that Citroen brings only to EUR and other parts of the world the original multimedia devices and in my country the dealer puts like original HU.
    I have access from this unit to a lot of features in my car such as lights, sounds (alarms) clock, fuel consumption, diagnostics... So strange that this is not a OEM one.

    Sent from my A0001 using Tapatalk

  5. #14
    Member
    Join Date
    Jun 2016
    Location
    -
    Posts
    10
    Rep Power
    0

    Default

    Hi,

    Here are some pictures of my system... Doesn't look good at all...

    cb3889fc81d84f53301c18be14fc80f9
    bfd00ed75eef0c62791eaf07c3619ef6
    f18e06e67a94a54f7742f257778f0a37
    7e600d85c465d8a90418034506f9c647
    733d69ca262a91ac86b172e0ce690d38

    Do you identity it?

    Sent from my A0001 using Tapatalk

  6. #15
    Master spijun's Avatar
    Join Date
    Oct 2008
    Location
    SA
    Posts
    479
    Rep Power
    330

    Default

    This is aftermarket NAV sistem Qnavi2
    [Only registered and activated users can see links. ]
    Enjoy life

  7. #16
    Moderator

    Bricoman's Avatar
    Join Date
    Dec 2014
    Location
    All over the place
    Posts
    1,119
    Rep Power
    243

    Default

    Quote Originally Posted by spijun View Post
    This is aftermarket NAV sistem Qnavi2
    [Only registered and activated users can see links. ]
    Hello,

    Yes, it isn't an original PSA GPS radio as already mentioned above in the first post.

  8. #17
    Member
    Join Date
    Jun 2016
    Location
    -
    Posts
    10
    Rep Power
    0

    Default

    Thanks guys! So if I want to replace it to an Android based system, any recommendations? Why did they installed the small speaker ? For BT?
    Are you guys know if this system can stream BT?

    Thanks a lot!

    Sent from my A0001 using Tapatalk

  9. #18
    Moderator

    Bricoman's Avatar
    Join Date
    Dec 2014
    Location
    All over the place
    Posts
    1,119
    Rep Power
    243

    Default

    Hello,

    Often there is a special interface adapted to connect the car to the station properly.
    This is the case in Alpine or other well known brands.
    The assembly may be incorrectly wired, which explains your problems ?
    You must check all the entire wiring to be sure of the assembly.
    There is perhaps updates for your device on the manufacturer's website ?

  10. #19
    Member
    Join Date
    Jun 2016
    Location
    -
    Posts
    10
    Rep Power
    0

    Default

    Hi,

    Thank you all for your comments, as you can see in the above picture my wiring harness is a mass because of this aftermarket radio installation, such a shame that the person who bought the car in 2012 got a brand new car with so much wiring cuts...

    I'm trying to fix it before buying an android based multimedia device.

    My head unit model is Continental RD5 L3 CEM 00, I have search everywhere for the head unit wiring diagram and I couldn't find them...
    My car have a USB port and AUX port which are not working... I suspect that the wires are just cut therefor a wiring diagram could really help me..

    I know that this forum is just for GPS based systems but you guys have a lot of knowledge so maybe you could help me out...

    Thanks,
    Moshe

 

 
Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.