Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 50

Thread: Firmwares RT3

  1. #11
    Moderator

    Bricoman's Avatar
    Join Date
    Dec 2014
    Location
    All over the place
    Posts
    1,119
    Rep Power
    243

    Default

    Hello,

    The method to change the language of the RT3 :

    - Start the engine
    - Insert the setup CD (Firmware)
    - Select the language of the country from the MENU, "Configuration, display configuration, choice of language".
    - Wait until the restart of the navigation system and follow the instructions on the screen
    - Remove the setup CD (Firmware)
    - Turn off the engine
    Last edited by Bricoman; 9th March 2016 at 17:13.

  2.    Advertissements


  3. #12
    Member
    Join Date
    Dec 2015
    Location
    Portugal
    Posts
    16
    Rep Power
    0

    Default

    Hello again Bricoman,

    Thanks for help me changing the language !
    Last edited by xBrunex; 16th March 2016 at 16:07.

  4. #13
    Member
    Join Date
    Mar 2016
    Location
    Somewhere
    Posts
    15
    Rep Power
    0

    Default

    Hi, I have version 6.51 in my C5, so I guess I'll have to update my fw to the latest version in order to use the latest maps. Do I need a copy of 6.51 fw also in case something goes wrong? And if so, can anybody please provide me said firmware? Thanks in advance
    Last edited by TotalKore; 25th March 2016 at 10:47.

  5. #14
    Moderator

    Bricoman's Avatar
    Join Date
    Dec 2014
    Location
    All over the place
    Posts
    1,119
    Rep Power
    243

    Default

    Hello,

    Your firmware version is not online, unless you have the original CD, be careful.
    You can always try to burn the CD to the desired map 2014/2015 and see if it works.
    Last cartography 2014/2015 :
    [Only registered and activated users can see links. ]
    Update the firmware has risks if the procedure is not controlled.
    Sometimes in concession, they manage to break the GPS ?

  6. #15
    Member
    Join Date
    Mar 2016
    Location
    Somewhere
    Posts
    15
    Rep Power
    0

    Default

    I allready updated to 6.63b890. All went perfectly, and it loaded the 14-15 maps, which it didn't before on 6.51. I still had the orig 04-05 maps. So, I'm very happy 😃. Do you perhaps have info on the 2015-2016 cd's? Or a download link? They are released according to CitroŽn.

  7. #16
    Moderator

    Bricoman's Avatar
    Join Date
    Dec 2014
    Location
    All over the place
    Posts
    1,119
    Rep Power
    243

    Default

    Hello,

    I'm very happy for you also, It's good to have a unit with latest Firmware/cartography.
    You have to see the difference maps 2004/2005 to 2014/2015 on the screen.
    Yet, no link for version 2015/2016, be patient.

  8. #17
    Member
    Join Date
    Mar 2016
    Location
    Somewhere
    Posts
    15
    Rep Power
    0

    Default

    Yeah, and I think it just even looks a little bit nicer (can be my imagination though). Maybe I'll finally use my onboard navigation now instead of my phone 😃. Maps were just too old...

  9. #18
    Moderator

    Bricoman's Avatar
    Join Date
    Dec 2014
    Location
    All over the place
    Posts
    1,119
    Rep Power
    243

    Default

    Hello,

    It's a shame not to use the embedded GPS in the vehicle.
    With the phone in addition it's better, because you don't have the ZAR (danger zone).
    The RT3 is old, but still useful with the latest mapping 2014/2015.

  10. #19
    Junior Member
    Join Date
    Mar 2016
    Location
    Netherlands
    Posts
    2
    Rep Power
    0

    Default

    It took a long time to find the update. Now i have download it.
    Only thing is that is think i burn the Disc nog right. I get the fault:

    the selected disk image file is invalid. I only want to burg 663b890 file without the .ccd of .cue?
    Does somebody have tips?

  11. #20
    Member
    Join Date
    Mar 2016
    Location
    Somewhere
    Posts
    15
    Rep Power
    0

    Default

    If you use imgburn, put it on a slow speed (4x) and use good media (i used verbatim cd's). Normally all should be fine.

 

 
Page 2 of 5 FirstFirst 1234 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.