Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Page 1 of 2 12 LastLast
Results 1 to 10 of 17
  1. #1
    Junior Member
    Join Date
    Jul 2016
    Location
    New Zealand
    Posts
    8
    Rep Power
    0

    IGO Primo IGO Promo no audio for Alerts including speed camera

    I have just got a TIawiaIT Android 4.4 Igo Primo 9.6.29.331894. It ways Basarsoft Navigation powered by IGO Primo.

    The issue I have is that I cannot get any audio for the alerts. I am particularly wanting the speed camera alerts. It has alerts for cameras, schools, fire stations, etc. I can turn them on and off visually, but never get any audio. I get audio for directions and over the speed limit and I get a clicking on key press.

    One thing I have notices is I can also not use any TTS voices, if I try and select them the IGO progam just freezes and then closes.

    I never realised there were so many GPS programs, I have tried to search the forum, but cant find a solution. Help!

    Update. I have managed to select a TTS voice. I see on one forum they say the TTS language needs to match the Android language. Mine was set the same, but I reset Android again (English UK) and then tried IGO (English UK) and it selected it OK and gave me the options for TTS. I will go for a drive tomorrow and pass a speed camera.
    Last edited by Easy; 1st August 2016 at 14:51.

  2.    Advertissements


  3. #2
    Important User

    osiris4isis's Avatar
    Join Date
    Apr 2012
    Location
    Farside of the Sun
    Posts
    2,645
    Rep Power
    636

    Default

    Clarification
    Spoiler: .

    This post requires you to click the "LIKE this post" button and hit F5 to read this content.
    "You know the very powerful and the very stupid have one thing in common. They don't alter their views to fit the facts. They alter the facts to fit the views." -DrWho

    Do NOT PM me with requests or for fixes to your problem. Post in thread instead. All communications in English only!

  4. #3
    Junior Member
    Join Date
    Jul 2016
    Location
    New Zealand
    Posts
    8
    Rep Power
    0

    Default

    The TTS English language was not the answer, in fact with it activated, there was no voice commands at all. Does anyone know of a site that I can learn about the IGO Primo customization. Like does "=0" mean No and "=1" mean Yes. But what does "=3" mean. Does the sys.txt file overwrite everything. If I look in the sys.txt file it says below, which would indicate is disabled, but if I go into setup its enabled (visual and audio)

    [speedcam_category:0]
    activated_spoken_type=speech
    activated_speech="Caution speed camera ahead"
    approach_beep_spoken_type=0
    approach_beep_speech=0
    approach_beep_sound=0
    overspeed_spoken_type=0
    overspeed_speech=0
    overspeed_sound=0

  5. #4
    Important User

    osiris4isis's Avatar
    Join Date
    Apr 2012
    Location
    Farside of the Sun
    Posts
    2,645
    Rep Power
    636

    Default

    Answer
    Spoiler: .

    This post requires you to click the "LIKE this post" button and hit F5 to read this content.
    "You know the very powerful and the very stupid have one thing in common. They don't alter their views to fit the facts. They alter the facts to fit the views." -DrWho

    Do NOT PM me with requests or for fixes to your problem. Post in thread instead. All communications in English only!

  6. #5
    Junior Member
    Join Date
    Jul 2016
    Location
    New Zealand
    Posts
    8
    Rep Power
    0

    Default

    So I have not managed to fix the issue. I can only find two ways of configuring the thing. Using the on screen setups and the sys.txt file.

    With the onscreen setups I have all the alerts and sounds turned on, that is alerts for Fire stations, schools, accident spots, all 32 of them, and given the map is covered with alerts I should get something. Of interest I have had them all disabled but for the school alert, as there is one close by, to test if it was getting confused. I get the directions announced, over speeding and the ding - But no alert audio!. I get the visual alert on the screen.

    My sys.txt look like this with the exception it has a further 30 [speedcam_category: ]'s at the end. But having played around with the [speedcam Category: ] stuff I think it does nothing and I suspect is because I am not using TTS. But I am happy not to have spoken stuff I just want an audible alert.


    [device]
    type="android"

    [android]
    fullscreen=1
    tablet=0
    has_physical_home_button=0
    show_status_bar=0
    ;getdeviceid_gemini=1
    ;check_for_dead_links=1

    [gps]
    location_net=1
    location_gps=1
    ;this should be in android igo9 config:
    background_navigation=1
    location_log=0
    location_log_filename="gpslog/LocationManager"
    check_gps_timestamp=1
    min_distance_timestamp=5000

    [rawdisplay]
    driver=engine
    ;driver=gles
    screen_xy="auto"
    ;screen_x=800
    ;screen_y=480
    ;screen_x2=480
    ;screen_y2=800
    ;screen_xy="800_480:800x480/480x800:fullscreen"
    ;screen_x=1184
    ;screen_y=768
    ;screen_x2=768
    ;screen_y2=1184
    ;screen_xy="1184_768:1184x768/768x1184:fullscreen"

    [3d]
    usepolyfarroads=0

    [folders]
    linked_root_list="/mnt/sdcard/iGO /mnt/ext_sd/iGO /mnt/sd/iGO /mnt/iGO /mnt/sdcard/external_sd/iGO /sdcard/iGO /sdcard/sd/iGO /sdcard/external_sd/iGO /sdcard2/iGO /storage/iGO extSdCard/igo"

    [network]
    available=1

    [naviextras]
    boot_service_address="http://zippy.naviextras.com/services/index/rest/2/boot"

    [tmc-http]
    enabled=1
    start=1
    servers.size=1
    ;servers[0].url="http://zippy.naviextras.com/services/tmclite/data/nng-igo-tmc-iphone/0/"
    servers[0].url="http://zippy.demo.naviextras.com/services/tmclite/data/nng-igo-tmc-china/0/"


    [google]
    enabled=1
    start=1
    servers.size=1
    ;servers[0].url="http://zippy.naviextras.com/services/tmclite/data/nng-igo-tmc-iphone/0/"

    [services]
    server_addr="https://android.naviextras.com/"
    servers[0].url="http://zippy.demo.naviextras.com/services/tmclite/data/nng-igo-tmc-china/0/"

    [poi]
    ;featured_provider=""
    picturepoi_scan="/mnt/sdcard/iGO/myPictures"
    picturepoi_nonrecursive_scan="/mnt/sdcard/iGO/myPictures"

    [camera.roundabout]
    enabled=0

    [sound]
    csv_voice_enabled="1"
    ding_muted=0
    maneuver_chimes=0
    pause_mp3_sooner=1


    [2d]
    traffic_lights=1

    [interface]
    skin="ui_android"
    capture_to_jpeg=1
    show_tmc_eventlist=1
    extra_settings=1
    show_minimize=0
    save_checksum=0
    show_exit=1
    maxzoom2d=6000000

    [other]
    demo_enabled=0

    [navigation]
    junction_view_blink_time=1000
    junction_view_blink_time_no_lane=1000

    [feature]
    back_exit=1
    back_button=1
    tmc_event_coloring=1
    signpost_coloring=1

    [debug]
    imei="000000000000000"
    skip_eula=0
    screenshotsavecameraini=0
    screenshotfilename="\android_linked_root\captures\image_%02d.jpg"
    experimental_features=1
    show_networkservices=1

    [warning]
    speedcam_enabled=1
    is_spoken=1
    speedcam_warning=1
    speedlimit_warning_visual=1
    speedcam_max_lookahead=2000
    speedcam_maxdistance_from_road=10

    [hnr]
    ignored_missing_country_ids=*

    [volume_channels]
    volumefade=3000

    [vmc_voice]
    enter_script="sc_volmanager_voice"
    vmc_effect=100
    vmc_media=40


    [tts]
    announce_exit_directions=1
    tts_logics=3
    always_say_road_names=3
    announce_street_name=1
    automatic_direction_conversion=1
    skip_exit_numbers=0

    [dynamiccompressor]
    compressor=1
    ratio=9
    gain=9

    [warning]
    speedlimit_warning_visual=1
    speedcam_warning=1
    is_spoken=1
    speedcam_max_lookahead=2000
    speedcam_maxdistance_from_road=10

    [speedcam_category:0]
    activated_spoken_type=speech
    activated_speech="Caution speed camera ahead"
    approach_beep_spoken_type=0
    approach_beep_speech=0
    approach_beep_sound=0
    overspeed_spoken_type=0
    overspeed_speech=0
    overspeed_sound=0
    warn_distances="150:2000,140:1800,130:1500,120:1400,110:1300,100:1200,90:1100,80:1000,60:700,50:600,40:500"



    [speedcam_category:1]
    activated_spoken_type=speech
    activated_speech="Caution mobile speed camera ahead"
    approach_beep_spoken_type=0
    approach_beep_speech=0
    approach_beep_sound=0
    overspeed_spoken_type=0
    overspeed_speech=0
    overspeed_sound=0
    warn_distances="150:2000,140:1800,130:1500,120:1400,110:1300,100:1200,90:1100,80:1000,60:700,50:600,40:500"


    $$$$$$$$ Etc $$$$ down to

    [speedcam_category:31]
    activated_spoken_type=speech
    activated_speech="Caution dangerous point"
    approach_beep_spoken_type=0
    approach_beep_speech=0
    approach_beep_sound=0
    overspeed_spoken_type=0
    overspeed_speech=0
    overspeed_sound=0
    warn_distances="0:500"

  7. #6
    Important User

    osiris4isis's Avatar
    Join Date
    Apr 2012
    Location
    Farside of the Sun
    Posts
    2,645
    Rep Power
    636

    Default

    I find your posts confusing. What exactly are you trying to do? When you say "no audio" in first post, it's too generic. "Audio" can be
    1. A built-in "ding" sound
    2. A customized audio sound
    3. A TTS voice announcement
    From your first post, looks like you're trying to get TTS to work. If you are hearing TTS voice in direction, it means TTS works. And as I explained in post #2, the ability to select voice inside NNG has nothing to do with android language. Alerts function are depended on the skin and the data used. If you're seeing the alerts then it's not a data (speedcam.txt) problem. And I already said in post #4, setting approach* and overspeed* to 0 (meaning none) has nothing to do with enabling of disabling the visual and audio of alerts. What skin are you using?
    "You know the very powerful and the very stupid have one thing in common. They don't alter their views to fit the facts. They alter the facts to fit the views." -DrWho

    Do NOT PM me with requests or for fixes to your problem. Post in thread instead. All communications in English only!

  8. #7
    Junior Member
    Join Date
    Jul 2016
    Location
    New Zealand
    Posts
    8
    Rep Power
    0

    Default

    Brown Dog

    Sorry I am very new at this and very limited computer knowledge. To answer you question I am using the default skin. Day Skin Theme = Default. Night Skin Theme = Skin~default~night.

    What I want is to have some form of audible warning when approaching a speed camera. I thought I could only get it if I used a TTS voice, so my first post was how do I get TTS working because if I selected it as an option the IGO froze and then shut down. I did get TTS going, but all my other spoken audios did not work like "you are over the speed limit" or "turn left". So I have abandoned the idea of using TTS.

    I am using the language = "English (AU)" and I get spoken "over the speed limit", directions like "turn left" , "take the third exit". I also get the ding when there is a direction. So I have some audio. I just do not get any audio when approaching an Alert. I get the visual coming up.

    If I go to the Volume settings there are Voice, Ding, Alerts and Key, which I have all turned on, but if I change the slider for the volume I get a voice with the voice slider, a ding with the ding slider and a click with the key slider, but with the alert slider I get a ding, exactly the same as a ding slider.

    I have found your post on "Speedcam audio warning - non TTS" which would be an answer but I am not confident in doing it and I don't understand about the data.zip. I don't need spoken warning, just an audio warning of some type. And I don't care about 31 of the categories I only care about the Category 0 speed cam.

    Thank you for your interest in my problem

  9. #8
    Important User

    osiris4isis's Avatar
    Join Date
    Apr 2012
    Location
    Farside of the Sun
    Posts
    2,645
    Rep Power
    636

    Default

    Wrong person. Brown Dog, no longer play on this forum. Ok, so you're using the built-in skin. And I assumed under Settings->SoundAndWarnings->AlertPointSettings->AlertTypes->SpeedCamera, you have Warning Type=Audio and Visual? How are you testing the alerts? They are only triggered when driving, not in simulation. Here is a checklist for TTS [Only registered and activated users can see links. ]
    1. Get voice engine working. If you choose VocalizerEx, follow instructions on how to get it working outside proggy (under android)
    2. Then once android is able to use VocalizerEx TTS engine, see if proggy can use the voice*.zip file (only correct ones will show up and allow to be selected)
    3. Once voice file is working, then you can worry about configuring alerts to use it
    Sounded you're using non-TTS voice which will not have anything to do with alerts. So you will have to do custom audio warning (if you're not interested in TTS)
    If you're only interested in category 0 (speedcam), then remove all others categories in sys.txt (keep it simple) You also have duplicate [warning] section in your posted sys.txt
    Last edited by osiris4isis; 3rd August 2016 at 04:30.
    "You know the very powerful and the very stupid have one thing in common. They don't alter their views to fit the facts. They alter the facts to fit the views." -DrWho

    Do NOT PM me with requests or for fixes to your problem. Post in thread instead. All communications in English only!

  10. #9
    Junior Member
    Join Date
    Jul 2016
    Location
    New Zealand
    Posts
    8
    Rep Power
    0

    Default

    Hi osiris4isis

    I am happy not to use TTS as I think that is making it more complex. So if I can get it working on the English (AU) with just some form of sound I will be happy.

    Yes I have all the alerts set as Visual and Audio

    Yes I am testing it by driving in my car, that is why I have kept all the categories for now as there is a school close by, its a 25km round trip to a speed camera.

    I think my preference is to do a custom alert if that is possible. I see looking at data.zip there is an existing sound !alert6.wav that would get my attention

  11. #10
    Important User

    osiris4isis's Avatar
    Join Date
    Apr 2012
    Location
    Farside of the Sun
    Posts
    2,645
    Rep Power
    636

    Default

    Actually TTS would be simpler and it will be much better to hear direction that include street names. My suggestion is for you to install VocalizerEx per instructions.
    "You know the very powerful and the very stupid have one thing in common. They don't alter their views to fit the facts. They alter the facts to fit the views." -DrWho

    Do NOT PM me with requests or for fixes to your problem. Post in thread instead. All communications in English only!

 

 
Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.