Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 27
  1. #11
    Important User

    osiris4isis's Avatar
    Join Date
    Apr 2012
    Location
    Farside of the Sun
    Posts
    2,646
    Rep Power
    639

    Default

    Ok, do this:
    1. Renamed* speedcam.spud and speedcam.scdb to speedcam.spud_ and speedcam.scdb_
    2. Make sure file speedcam.txt exists under content/speedcam
    3. Start iGO and let it run for 30 secs, then exit
    4. Check to see if speedcam.scdb is created with filesize not 0
    5. Start iGO and look for speedcam icons on map; if you see any, then speedcam data is read correctly
    6. Getting sound to work and checking it working via driving is another issue

    * You can also renamed or temp moved it out of content/speedcam
    Last edited by osiris4isis; 25th February 2016 at 00:21.

  2.    Advertissements


  3. #12
    Member
    Join Date
    Dec 2011
    Location
    UK
    Age
    60
    Posts
    13
    Rep Power
    0

    Default

    Quote Originally Posted by osiris4isis View Post
    Ok, do this:
    1. Renamed* speedcam.spud and speedcam.scdb to speedcam.spud_ and speedcam.scdb_
    2. Make sure file speedcam.txt exists under content/speedcam
    3. Start iGO and let it run for 30 secs, then exit
    4. Check to see if speedcam.scdb is created with filesize not 0
    5. Start iGO and look for speedcam icons on map; if you see any, then speedcam data is read correctly
    6. Getting sound to work and checking it working via driving is another issue

    * You can also renamed or temp moved it out of content/speedcam
    Thanks for your reply.
    As I mentioned previously, I don't have a file named speedcam.scdb to rename only speedcam.spdb. Furthermore, I don't have a file called speedcam.spud only SpeedcamUpdates.spud. I also have speedcam.txt (8kb), speedcams.txt(63kb) and SpeedCamTxt.txt(658kb).

    I changed the names of speedcam.spud to *.spud_ and renamane the speedcamupdates.spud. I reran igo for 30 seconds and now I have a new speedcam.spdb file at 1264kb and a speedcamupdates.spud at 0kb nothing else has changed. I have now restarted igo but there's no difference. Still no speedcam or events showing.

    I did just have a reminiscence and that's static traffic camera's sometime show (the ones that are mounted on very high poles above roads) but nothing else.

  4. #13
    Pro-Member
    Join Date
    Mar 2013
    Location
    Blath
    Posts
    386
    Rep Power
    20

    Default

    Quote Originally Posted by rebgershon View Post
    Thanks again for your reply.

    I am doubtful that doing as you suggest will solve the problem.

    Looking at the contents of the ext4 partition, there seems to be only a skeleton of android. There are only 2 directories:
    Lost & Found which is empty and NexusHD2-KitKat. These is then subdivided into data & system folders. Within the data folder there's another folder called data. Thsi has similar content to the storage/emulated/0/Android(1)/data folder on my Galaxy S3. There are subfolders which begin com.*. There is one called com.navngo.igo.javaclient. In this folder there is a subfolder called Cache which is empty
    android_linked_root
    branding.gro
    branding.zip
    content
    data.gro
    data.zip
    debug
    gfx
    kuka_logger.txt
    lib
    license
    monkey.txt
    save
    sentinel.txt
    sys.txt
    ui_android
    ui_igo9
    ux

    Above are just files with exception of the zips and the cache directory.

    Also in the parent data folder is app folder containing this igo file: com.navngo.igo.javaclient-1.apk.
    app-lib folder, sub folder com.navngo.igo.javaclient-1 containing 2 files: libigo_jni.so & libtmceapi.so.
    Doesn't seem to be any other folders related directly to igo.

    No igo specific files in the system folder.

    So where to put the folders you suggest?

    It could just be that it ain't gonna work!
    Within then first data folder create another folder called iGO this where you put the internal SD content I outlined. Try this and advise of the result.

  5. #14
    Pro-Member
    Join Date
    Mar 2013
    Location
    Blath
    Posts
    386
    Rep Power
    20

    Default

    Quote Originally Posted by rebgershon View Post
    Thanks for your reply.
    As I mentioned previously, I don't have a file named speedcam.scdb to rename only speedcam.spdb. Furthermore, I don't have a file called speedcam.spud only SpeedcamUpdates.spud. I also have speedcam.txt (8kb), speedcams.txt(63kb) and SpeedCamTxt.txt(658kb).

    I changed the names of speedcam.spud to *.spud_ and renamane the speedcamupdates.spud. I reran igo for 30 seconds and now I have a new speedcam.spdb file at 1264kb and a speedcamupdates.spud at 0kb nothing else has changed. I have now restarted igo but there's no difference. Still no speedcam or events showing.

    I did just have a reminiscence and that's static traffic camera's sometime show (the ones that are mounted on very high poles above roads) but nothing else.
    You have verified what I wrote in post #7. As it stands on kikat the speedcams won't work with the way you have the speedcams loacted on the external SD card. I have given you a solution that works, as I have this implemented on my kikat tablet and samsung s5 mini.

  6. #15
    Member
    Join Date
    Dec 2011
    Location
    UK
    Age
    60
    Posts
    13
    Rep Power
    0

    Default

    Quote Originally Posted by De5i View Post
    You have verified what I wrote in post #7. As it stands on kikat the speedcams won't work with the way you have the speedcams loacted on the external SD card. I have given you a solution that works, as I have this implemented on my kikat tablet and samsung s5 mini.
    Thanks again for your reply.

    I am now in the process of carrying out your instructions. I have a couple of further questions/observations though:
    1. where I'm making the folders in the iGO folder within the data folder, do I copy the whole content of each folder with the exception of the content folder, of the matching folder on the external sd card?
    2. are those now duplicated folders to be removed from the external sd card and if so what of the remaining content within the 'content' folder?
    3. I don't have dictionaries in my content file.
    4. Do data.zip & sys.txt remain on the external sd as well?

    Thanks again.

    **Update**.

    I have done the above but not deleted the copied folders as yet.

    On starting igo I get an error message: "Missing or incomplete folder: Not a zip archive" - no indication what's missing or incomplete.

    **Further Update"

    After the above, I thought I'd check the ext4 partition contents. I was amazed to find the carefully crafted iGO folder has been reduced to a 1kb file!! Looks like Kit Kat must have had a break and eaten all the folder!!

    What to do now?
    Last edited by rebgershon; 25th February 2016 at 23:38. Reason: Update

  7. #16
    Pro-Member
    Join Date
    Mar 2013
    Location
    Blath
    Posts
    386
    Rep Power
    20

    Default

    Quote Originally Posted by rebgershon View Post
    Thanks again for your reply.

    What to do now?
    As i understand from your previous post you have NexusHD2-KitKat folder which is subdivided into data & system folders. Within the data folder you create a folder called iGO and in this you copy the content including the data.zip and sys.txt as listed in my post i.e.
    The content folder on the internal (ext4) only contains what I have listed below and all the rest of the content information stays on the external SD. (dictionaries is not important)

    iGO
    -content in this folder the following information - global_cfg, lang, speedcams, tmc, userdata
    -debug
    -font
    -gfx
    -license
    -save
    -ui_android
    -ux
    data.zip
    sys.txt

    On the external SD card you can either rename iGO to iGo_backup and create new folder called "Addons" or rename the iGO folder to "Addons" and have the following information in this folder;

    Addons/Content
    building
    dem
    map
    phoneme
    poi
    scheme
    skin
    voice

    Hope this is now clear instructions to carry out.

  8. #17
    Member
    Join Date
    Dec 2011
    Location
    UK
    Age
    60
    Posts
    13
    Rep Power
    0

    Default

    Quote Originally Posted by De5i View Post
    As i understand from your previous post you have NexusHD2-KitKat folder which is subdivided into data & system folders. Within the data folder you create a folder called iGO and in this you copy the content including the data.zip and sys.txt as listed in my post i.e.
    The content folder on the internal (ext4) only contains what I have listed below and all the rest of the content information stays on the external SD. (dictionaries is not important)

    iGO
    -content in this folder the following information - global_cfg, lang, speedcams, tmc, userdata
    -debug
    -font
    -gfx
    -license
    -save
    -ui_android
    -ux
    data.zip
    sys.txt

    On the external SD card you can either rename iGO to iGo_backup and create new folder called "Addons" or rename the iGO folder to "Addons" and have the following information in this folder;

    Addons/Content
    building
    dem
    map
    phoneme
    poi
    scheme
    skin
    voice

    Hope this is now clear instructions to carry out.
    Thanks again for clarifying the instructions.

    I did as you have said again but sadly Kit Kat doesn't like the creation of the iGO folder and once again has converted it to a 1kb file. There must be something in the software that deletes non standard programmes/data.

    I could get iGO to run but I had to change the folder name on the 'external' SD back to iGO. However, it went through the whole set up process like a new installation and each time I restart I have to do this probably due to the modifications of the sys.txt. It doesn't retain any history either. Also it is still running without the speedcams & events as before. I have also noticed that although screen rotation works for Kit Kat, iGO doesn't go into a landscape view on screen rotation-it just remains on its side. This didn't happen when I used Jellybean.

    Perhaps if we could find out why the iGO folder on the internal SD is being deleted fix it this would then allow iGO to run as you expected.

    Regards.

    **Update**

    Having recopied to the ext4 partition, I removed the SD card for my PC, reinserted and checked the DATA subdirectory. All that I'd copied was still present.

    However, on putting back in the phone, restarting Android and then removing the SD card, on reinserting and checking on the PC, the iGO data had again been converted to a 1kb file. I'm now going to try and write protect the iGO directory and will report back.

    **Further Update**

    Making the iGO file has kept it. However, on trying to load igo I got the same result as before it not being found. I then re examined the iGO folder on the ext4 partition. It was still there but all its contents had disappeared and in their place are 2 new files, com.android.dialer.xml & com.android.dialer_preferences.xml.
    Last edited by rebgershon; 26th February 2016 at 16:04.

  9. #18
    Important User

    osiris4isis's Avatar
    Join Date
    Apr 2012
    Location
    Farside of the Sun
    Posts
    2,646
    Rep Power
    639

    Default

    Files "mysteriously" get deleted; hmmm, could be a virus or antivirus at works.

  10. #19
    Important User

    wojpen's Avatar
    Join Date
    Nov 2013
    Location
    EU
    Posts
    1,231
    Rep Power
    817

    Default

    Colleague rebgershon - give exact info:
    * / Nexus model and year of manufacture
    * Apk - number
    * Where installed
    * Show your sys.txt
    * root or noroot?
    Password for My Files: wojpen
    User (when necessary): wojpen
    Closed Link - Please PM
    regards

  11. #20
    Member
    Join Date
    Dec 2011
    Location
    UK
    Age
    60
    Posts
    13
    Rep Power
    0

    Default

    Quote Originally Posted by wojpen View Post
    Colleague rebgershon - give exact info:
    * / Nexus model and year of manufacture
    * Apk - number
    * Where installed
    * Show your sys.txt
    * root or noroot?
    In reply to your questions:

    1.To go back to my original posting: "Hi there,

    I have been using Igo Primo 2 on a HTC HD2 running Android Jellybean 4.1.2 and now Kit Kat 4.4.4. I used to use Igo 8 pre android with the Windows mobile 6.5 that came with the phone. This worked flawlessly.

    However, since using Android and Primo, and now Android and Igo My Way 9.6 I don't have speed cam warnings graphically or audibly."
    The phone is HTC HD2-essentially a Windows mobile v6.5 phone. The windows software on the internal rom hasn't been overwritten. I use a micro sd card (16gb) which has 2 partitions a. ext4 system partition of 4gb and a fat32 partition for the remaining memory.

    From the About Phone section of settings:
    Model Number: Nexus HD2
    CyanogenMod Version: 11.0-M9-leo
    Android Version:4.4.4
    Baseband Version: 15.42.50.11U_2.15.50.14
    Kernel Version: 2.6.32_tytung_jellybean_r2
    CPU: ARMv7 rev 2
    Memory: 410MB
    Build date: 7/09/2014
    Build no. KTU84Q (NexusHD2-Kit Kat V4.7) [NaiveSD]
    SELinux status: Disabled

    2. I am using iGO Primo v2.0, iGOprimo_v9.6.7.235654_thin-v1.3.apk dated 30/11/2012.N.B the same version of iGO works on HTC DesireS (same screen settings as HD2) & Samsung Galaxy s3 9300 & 9305 (different screen settings). Originally downloaded from Android Zone.
    3. Before making the modifications suggested by De5i the iGO folder was on the FAT32 partition, apk installed from there.
    4. Modified sys.txt as per De5i's suggestions:
    Code:
    Please Login or Register to see the links
    4. AFAIK this software is rooted.

    Hope this helps us!

    Awaiting replies.

    N.B the same version of iGO works on HTC DesireS (same screen settings as HD2) & Samsung Galaxy s3 9300 & 9305 (different screen settings). Originally downloaded from Android Zone.

    please use code tags for sys.txt
    Last edited by catymag; 27th February 2016 at 19:35. Reason: code tags

 

 
Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.