Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Likes Likes:  0
Results 1 to 6 of 6
  1. #1
    Member +
    Join Date
    Nov 2012
    Location
    United States
    Posts
    44
    Rep Power
    5

    Default Pause/Resume Of Music Playback And TTS

    Hello again all,....

    I'm in need of help on this problem I'm experiencing with the TTS and I think the system audio,....maybe?

    This is using Igo Primo Android ver. (9.6.29.483387) Jan 31 2015
    And Android Lollipop 5.0

    "I'm using the output of the 1/8 jack plugged into my radio head unit, not the built-in speakers of the tablet".

    OK, I'll try to explain the best I can,...

    this is what's going on with my audio output after iGO Primos TTS pauses the music playback and announces the directions then resuming the music back again.

    A very flat music playback of audio/music now? It's like the EQ and Preamp settings of any audio player app, (doesn't matter which I'm using ie: PowerAmp, Rocket Player etc.) gets bypassed?

    Music now sounds like there is no Bass and over all lower in volume too.

    I have in the sys.txt settings listed for navigation audio stream (which is suggested), set to "4" Alarm volume.

    I thought that when using this setting 4 for nav audio stream isn't supposed to alter/change the music playback in anyway.

    The music sound stays like this until I have to close out the music player app and restart it, then it's back to normal. Bass and volume level sound again.

    And When I get more directions announced, my music playback goes flat again in sound??

    I'm trying to rap my head on this one but, no joy.
    If anyone has any suggestions to fix this big annoyance, would be fantastic.

    Here is what I have listed below related to audio in my sys.txt file if it helps.

    Thanks.


    [android]
    ;fullscreen=1
    ;tablet=0
    ;has_physical_home_button=1
    ;select audio stream
    ; 0-STREAM_VOICE_CALL, 1-STREAM_SYSTEM, 2-STREAM_RING, 3-STREAM_MUSIC, 4-STREAM_ALARM, 5-STREAM_NOTIFICATION
    navigation_audio_stream=4
    create_sdcard_dir=0

    [sound]
    csv_voice_enabled="1"

    [tts]
    automatic_direction_conversion=1
    announce_exit_directions=1
    always_say_road_names=3
    announce_street_name=1
    skip_exit_numbers=1
    tts_buffer=131072
    tts_logics=3
    priority="HIGH"
    Last edited by ijustpickedmynose; 16th June 2015 at 14:43.

  2.    Advertissements


  3. #2
    Member +
    Join Date
    Nov 2012
    Location
    United States
    Posts
    44
    Rep Power
    5

    Default

    Anybody?

    This is driving me bonkers.

  4. #3
    Junior Member
    Join Date
    Apr 2015
    Location
    italy
    Age
    38
    Posts
    9
    Rep Power
    0

    Default

    Try to use



    Viper4android

    [Only registered and activated users can see links. ]

    You must install
    This zip from twrp recovery..
    But , YOU NEED A NANDROID BUCK UP FIRST



    You must
    Have
    1)a device with root permission

    2)selinux with permissive feature
    This apk converts enforcing to permissive

    [Only registered and activated users can see links. ]

    3)busybox apk installed
    From play store.

    AFTER THAT 3 you can install Viper4android

    Fantastic sound with no problems,
    If we use igo from mini jack output or from bluetooth
    Or from our device speaker.
    Last edited by petsinis; 23rd June 2015 at 07:38.

  5. #4
    Member +
    Join Date
    Nov 2012
    Location
    United States
    Posts
    44
    Rep Power
    5

    Default

    petsinis,..

    Thank you so much, and I really do appreciate your help, but,.....
    I was hoping for something like changing/adding code to the sys.txt etc.
    I really don't want to root my android tab.

    Also I do have Sygic with lifetime maps installed on this same tablet. The sound settings EQ/Preamp of the audio/playback of any music player app never changes after the paused of music when voice directions are spoken. The audio always stays the same. Which I want, but iGO Primo uses the alarm setting for this?
    (which is suggested) and why?

    Thx.

  6. #5
    Junior Member
    Join Date
    Apr 2015
    Location
    italy
    Age
    38
    Posts
    9
    Rep Power
    0

    Default

    sygic is different from primo in audio sources
    viper4android use drivers which cures these sound problems.

    try to change the sound source from sys.txt
    navigation_audio_stream=4

    change the number from 0 1 2 3 5
    and try it,

    i dont think there is another way

    except , if inside your apk , to the path , res , raw , sys.txt
    is active
    the same command
    navigation_audio_stream=4
    Last edited by petsinis; 24th June 2015 at 18:41.

  7. #6
    Member +
    Join Date
    Nov 2012
    Location
    United States
    Posts
    44
    Rep Power
    5

    Default

    Quote Originally Posted by petsinis View Post
    try to change the sound source from sys.txt
    navigation_audio_stream=4

    change the number from 0 1 2 3 5
    and try it
    Will do,...I'll try but,
    I don't think either that it will fix it.

    Quote Originally Posted by petsinis View Post
    i dont think there is another way

    except , if inside your apk , to the path , res , raw , sys.txt
    is active
    the same command
    navigation_audio_stream=4
    Sorry for my ignorance but,
    I don't understand,....a bit over my head.

    Thx.

 

 

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.