Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Page 1 of 2 12 LastLast
Results 1 to 10 of 17
  1. #1
    Important User

    wojpen's Avatar
    Join Date
    Nov 2013
    Location
    EU
    Posts
    1,225
    Rep Power
    814

    UX Hot: Modification for UX-utility Attractions

    Welcome Navigators,
    In the post - [Only registered and activated users can see links. ]
    introduced a new tool UX- Files "Attractions" - to vicewandel.
    Today is time to show the modification of the tool;

    [Only registered and activated users can see links. ]


    Summary: (from the author of the tool):
    "Now you can see a photo of a place Announced That is ... if you want it)
    Returned to the choice of name or description.
    Discovered and DECIDED dependence filename encoding from the OS. Now works CORRECTLY even on machines with Cyrillic in the name SD-card.
    Now displays the voice and distance changes in splitscreen too.
    Kml cleaned and posted a photo to Kiev
    Removed from the list splitscreen what has already sounded.

    [Only registered and activated users can see links. ]
    [Only registered and activated users can see links. ]

    What and how ...

    As attractions can act any POI, Including (and perhaps Especially) Those That are placed in the folder / content / userdata / poi / as .kml files.
    Perhaps tie POI names to the names of pictures (jpg) in a folder with pictures of the place.
    It is now possible to see the image of space if you have it tied.
    Read below how to do it. For WEUC the application has finished (replenished).

    To view information and pictures of the place is enough to click on the icon on the left in the box splitscreen or select a POI in the standard way.
    Of course this should be done only in the parking lot or in pedestrian mode.

    In the folder iGO / Please insert (create) a new called "userpicture".
    It can be placed anywhere, pointing the way to it through sys.txt:

    Android - file sys.txt please add:

    [attractions]
    user_picture_path = "% root% \ Storage \ extSdCard \ iGO \ userpicture"
    Note: - Path for Android Prescribed absolute, not relative.

    WinCE - file sys.txt please add:
    [attractions]
    user_picture_path = "% app% \ userpicture"

    Note: - Path for WinCE can be relative.

    This new folder is associated to the KML POI photos. They are connected to the name of the POI in KML. Complete copy of the name should be the name of the file in the folder jpg (userpicture) with photos.
    Cyrillic can be a file name. Now it is seen as normal text, not as kryakozyabriki))


    Spoiler: links
    1) - for Android:
    This post requires you to click the "LIKE this post" button and hit F5 to read this content.

    2) - for WinCE:
    This post requires you to click the "LIKE this post" button and hit F5 to read this content.

    3) - Example folder userpicture - for Kiyev:
    This post requires you to click the "LIKE this post" button and hit F5 to read this content.




    THX: vicewandel + GupailoV & 4pda,

    Regards wojpen
    Last edited by D.I.I.; 22nd January 2015 at 10:08.

  2.    Advertissements


  3. #2
    Master
    Join Date
    May 2011
    Location
    UK
    Age
    30
    Posts
    230
    Rep Power
    120

    Default

    i have tried to get this to work on 480x272 but nothing happens. has anyone been able to get it to work on their device?
    [Only registered and activated users can see links. ]

  4. #3
    iGO&Becker Moderator

    Korabi's Avatar
    Join Date
    Jan 2013
    Location
    Eastern Europe
    Posts
    602
    Rep Power
    752

    Default

    @urbexuk
    you put it in sys ?

    [attractions]
    user_picture_path = "% app% \ userpicture"

  5. #4
    Master
    Join Date
    May 2011
    Location
    UK
    Age
    30
    Posts
    230
    Rep Power
    120

    Default

    I have added that but nothing is showing that the ux works.
    no options in the menu and nothing else showing.

  6. #5
    Important User

    wojpen's Avatar
    Join Date
    Nov 2013
    Location
    EU
    Posts
    1,225
    Rep Power
    814

    Default

    Hello,
    Give what you have equipment, system and software version and Skin

    Example, my:
    Samsung NOTE 2 not root, android 442, iGO-403969 + skin Dimka 133 def.

    and everything works beautifully

    greet wojpen
    Last edited by wojpen; 15th September 2014 at 11:14.

  7. #6
    Important User

    wojpen's Avatar
    Join Date
    Nov 2013
    Location
    EU
    Posts
    1,225
    Rep Power
    814

    Default

    Welcome once again;
    From your earlier post I concluded that you have WinCE - so do this:
    1 Uninstall and clean the residue!
    2 Download the file again Attractions (in which your - no one file * .lua)

    Link: .... Attractions (13).zip
    [Only registered and activated users can see links. ]

    3 In the main directory where you have iGO folder, create a folder "userpicture"
    4 Install iGO and copy the right place add-on "Attractions".
    5 Go to the program may be the demo mode and create a POI at any distance of no more than 10km. from where you are - but one that can be taken.
    6 Select and activate the split-interest (POI).
    7 The next option - Settings SpiltSreen POI in the first set - Cat.POI List - select category (example - "London Places") in which you saved your POI - write down the exact name of the point on a piece of !!!
    8. userpicture directory, copy the photo of your point - the name of the saved as above - example - "Trafalgar Square" jpg
    9 Insert the sys.txt the path in the ATTRACTIONS.
    In the settings menu, go to options - the "additional options".
    10 In the penultimate position you ATTRACTIONS button - go.
    11.Select your choices order to vote and go to the option settings splitscreen POI - point within 10km example.

    Exit the program, start again and ........... works!
    You can click on the map shown in the photo - will show you the route to the selected point.

    regards wojpen

  8. #7
    Master
    Join Date
    May 2011
    Location
    UK
    Age
    30
    Posts
    230
    Rep Power
    120

    Default

    Ok,
    I copied the ux into the ux folder
    I created the userpicture folder in the main igo directory, (the one with the primo.exe)
    I started igo and went to the poi and created the poi via the attractions option
    I then added jpg image to userpicture folder with same name i called the poi
    I went to the settings and activated the attractions option
    I created a route that goes to poi destination
    The destination shows the attraction default icon - archaeology (the man with spade)
    but it does not show the image i saved in userpicture folder.

    i did add to sys the following:
    [attractions]
    user_picture_path = "% app% \ userpicture"

    but still the image does not show
    I made sure its a capital letter as i saved poi but still will not show that image

  9. #8
    Important User

    wojpen's Avatar
    Join Date
    Nov 2013
    Location
    EU
    Posts
    1,225
    Rep Power
    814

    Default

    Buddy - how can I help you, if you have not given the information I asked for?
    Insert here your sys.txt and a screenshot of the contents of the folder iGO
    regards wojpen

    PS What system and skin?

  10. #9
    Master
    Join Date
    May 2011
    Location
    UK
    Age
    30
    Posts
    230
    Rep Power
    120

    Default

    WINCE
    Skin: Dimka 171

    [Only registered and activated users can see links. ]
    [Only registered and activated users can see links. ]

  11. #10
    Important User

    wojpen's Avatar
    Join Date
    Nov 2013
    Location
    EU
    Posts
    1,225
    Rep Power
    814

    Default

    Hello,
    Looking at your sys.txt and the directory structure of the application is the only one!
    Cameras do not see, because evil is the location of the folder userpicture.
    solution:

    1 Move the folder userpicture outside Primo2.4 folder, and install again, leaving the existing allowance Attractions.zip and improving path in sys.txt to:
    user_picture_path ="% app%\ userpicture"


    NOTE !!! - Remember of course, that the uninstall treba clear pozostałoiści - including the save folder?

    2.If this does not work - change the path and enter exactly as it is - that is:
    user_picture_path = "path indicated in the file manager on the device (file userpicture outside iGO folder)".
    regards wojpen

    PS - One more thing - U you in sys.txt there is no declaration of the folder for the application:

    code:

    [folders]
    App =% SDCARD% / Primo2.4 (so I can see the small image)

    [Attractions]
    user_picture_path = "% app% \ userpicture"

    And now it should be ok.
    Last edited by wojpen; 16th September 2014 at 09:58.

 

 
Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.