Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Results 1 to 2 of 2
  1. #1
    Junior Member
    Join Date
    Feb 2016
    Rep Power

    help iGO pimo for Iveconnect

    Can someone help me, I have a new Iveco Daily with Iveconnect but I have no a genuine SD card. In manual is written, The system Iveconnect can be equipped with satellite navigation applications iGO Primo NavNGo specifically designed for commercial vehicles. I downloaded various versions iGO primo but can not seem to run them. Always Reports - Insert the SD card with navigation data.
    I do not know what I write to sys file. It is necessary to unlock the device?
    Thanks for help

    [Only registered and activated users can see links. ]

  2.    Advertissements

  3. #2
    GPSPower Helper

    titisoim's Avatar
    Join Date
    Apr 2007
    Rep Power


    these devices do not work procesor ARM ..work with procesor MIPS ..
    and for the proc. MIPS there is only one version of IGO 8.3.2 CRACK ..



Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.