Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Results 1 to 9 of 9

Thread: Help needed!

  1. #1
    Junior Member
    Join Date
    Aug 2015
    Location
    Europe
    Posts
    5
    Rep Power
    0

    Default Help needed!

    Hello, I'm new to the forum and have to ask a (may be) silly question...
    I own a arival nav-pnx 35 m and like to update the software and maps to igo primo (V 2.4 or 3.01). But - what do I have to do precisely to get there?

    Help is very much appreciated since I don't have any idea...!!

    Ah, the current sdmmc directory looks as follows:

    Data (Dir)
    Maptrip (Dir)
    System Volume Information (dir)
    skinlog.txt
    shell.ini
    sd.ini

    Thanks!!

    cappelfreak

  2.    Advertissements


  3. #2
    Member
    Join Date
    Nov 2012
    Location
    Romania
    Posts
    18
    Rep Power
    0

    Default

    It should be simple. Copy the kit(Primo) in root of SD Card and edit file shell.ini
    eg: \SDMMC\Primo\Primo.exe
    If you have problems upload content of SD Card without map or open shell.ini with notepad and put a printscreen here.

  4. #3
    Junior Member
    Join Date
    Aug 2015
    Location
    Europe
    Posts
    5
    Rep Power
    0

    Default

    Hi victorpetroi, now I get two files named mobilenavigator....exe: one ends in "cn", the other in "wd" - both have the same size. Which one is the correct one?

    Thanks again,

    cappelfreak

  5. #4
    Important User

    Midnight Blues's Avatar
    Join Date
    Aug 2009
    Location
    Croatia/Slovenia
    Posts
    912
    Rep Power
    724

    Default

    Use WD version
    CN version is for China with China maps only
    NO THANKS POSTS ALLOWED, NO LIKES NEEDED, ALL MIRRORS APPRECIATED
    1qhhsh
    Password for all my uploads: gpspower.net

  6. #5
    Junior Member
    Join Date
    Aug 2015
    Location
    Europe
    Posts
    5
    Rep Power
    0

    Default

    Hi Midnight Blues, (still got the blues? RIP Gary...)

    I put the content of the igo primo package in the root directory of a new 8 GB sd-card and edited the shell.ini as victorpetroi suggested. But.. nothing happens when starting the arival thing. The directory of my sd.card looks like this:
    content (dir)
    license (dir)
    lux (dir)
    data.zip
    MobileNavigator_9.6.13.405512WD.exe
    shell.ini
    sys.txt

    What went wrong?

    Thanks in advance,

    cappelfreak

  7. #6
    iGO Moderator

    Boki_Srb's Avatar
    Join Date
    Jun 2014
    Location
    Niš
    Age
    44
    Posts
    671
    Rep Power
    207

    Default

    Usually, you have to rename exe file (MobileNavigator_9.6.13.405512WD.exe) to name it was used (Primo, Navigator...etc).
    Then, you need to preserve the file structure as it was! What was in "data" dir? What was written in the "shell.ini"? What in "sd.ini"?
    And, few more things:
    - it is 3.5", low res, you can not use Primo 405512. Find proper version (320x240 I guess, but...).
    - Most important: what was original version of software on it? Maptrip 2.6?
    The big problem with dedicated devices, usually are locked to a particular type of firmware, and software. It often fails simple software replacement, you need to unlock the device first. But, you can try.
    Last edited by Boki_Srb; 17th August 2015 at 22:32.

  8. #7
    Junior Member
    Join Date
    Aug 2015
    Location
    Europe
    Posts
    5
    Rep Power
    0

    Default

    Hi Boki_Srb,

    the original sw was in fact maptrip 2.6.1 - is there a newer maptrip version around? If not, I guess, I cancel the whole thing, it seems the problems are getting unsolvable...

    Anyway,

    Thanks.

  9. #8
    iGO Moderator

    Boki_Srb's Avatar
    Join Date
    Jun 2014
    Location
    Niš
    Age
    44
    Posts
    671
    Rep Power
    207

    Default

    It is latest MapTrip.
    Well, basicly, you can put Igo on it, it is a little bit complicated, but possible. First, backup all data from your device.
    Then, you have to find from existing ini files, proper structure and naming, use it to adapt Igo structure and naming.
    I'll suggest Igo Primo 1.1 (or 2.0, maximum, you can try...) with data.zip for 320x240 res, and you have to put in sys:

    [gps]
    port="7"
    baud="38400"

    [tmc]
    port="7"
    baud="4800"

    Bluetooth works without any additional setting.
    Last edited by Boki_Srb; 18th August 2015 at 10:43.

  10. #9
    Junior Member
    Join Date
    Aug 2015
    Location
    Europe
    Posts
    5
    Rep Power
    0

    Default

    Hi everybody,

    finally I made it. The problem was the resolution as Boki_Srb mentioned. I found a primo version that supports 320X240. Unfortunately I can't rotate the screen any longer, so using it on my bike doesn't make sense; furthermore there is no explicit "bike-mode". Too bad, but anyhow: I learned a lot!

    So, thanks to everybody,

    cappelfreak

 

 

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.