Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. #1
    Member +
    Join Date
    Jul 2009
    Location
    Cyprus
    Posts
    30
    Rep Power
    0

    Default Issue on Galaxy S4

    Hello all,

    I have 2 GPS applications on my phone Sygic and IGO Primo.

    The issue is that whenever I restart my phone and I first run IGO it doenst find my location it just searches for GPS. But when I run Sygic (Sygic finds my location immediately) and then run IGO then IGO finds my position. I hope you understand what I mean.

    Any suggestion will be appreciated.
    Last edited by Black Wolf; 17th October 2013 at 21:54.

  2.    Advertissements


  3. #2
    Junior Member
    Join Date
    Jan 2010
    Location
    BiH
    Age
    50
    Posts
    5
    Rep Power
    0

    Default

    1st install and run GPS Status & Toolbox, then run iGO.
    ----------------
    [Only registered and activated users can see links. ]

  4. #3
    Member +
    Join Date
    Jul 2009
    Location
    Cyprus
    Posts
    30
    Rep Power
    0

    Default

    Quote Originally Posted by XisiX View Post
    1st install and run GPS Status & Toolbox, then run iGO.
    ----------------
    [Only registered and activated users can see links. ]
    Thanks for this but is there a permanent solution?

  5. #4
    IGo Moderator Black Wolf's Avatar
    Join Date
    Jan 2010
    Location
    Near
    Posts
    436
    Rep Power
    353

    Default

    How do you expect some solution, if you didn't post at least some basic infos, like Primo version, which rom your device use, official or some custom, etc.!?

    Dont expect help, if you don't post detailed info, when you go to doctor to help you, probably you explain him all details about your problem, same is for your problem with gps fix!
    ﻻاله اﻻ الله محمد رسول الله

  6. #5
    Member +
    Join Date
    Jul 2009
    Location
    Cyprus
    Posts
    30
    Rep Power
    0

    Default

    Quote Originally Posted by Black Wolf View Post
    How do you expect some solution, if you didn't post at least some basic infos, like Primo version, which rom your device use, official or some custom, etc.!?

    Dont expect help, if you don't post detailed info, when you go to doctor to help you, probably you explain him all details about your problem, same is for your problem with gps fix!
    You have a point and you are correct.

    I am using official rom and kernel. Latest on my device MH6 4.2.2. I am rooted using CF-auto-ROOT.

    It happens on all IGO Primo (now using latest Barasoft iGO Primo (2.4) 9.6.29.33189) I have used so far. No problem with Sygic or Navigator.

  7. #6
    IGo Moderator Black Wolf's Avatar
    Join Date
    Jan 2010
    Location
    Near
    Posts
    436
    Rep Power
    353

    Default

    Didn't have problem with fixing gps signal on newer SGS like S2, S3, S4, all of them fix gps signal fast, specially S3 and S4, which has now more better gps recievers. When you try to get gps signal, try to be at place where not some buildings front of you, or some other objects, which can block gps signal. In meantime, delete save folder, add these command lines in sys.txt


    [gps.igo_connector]
    position_validity=-1
    restart_listening_interval=0
    listen_for_gps_while_log_is_playing=1

    [modules]
    IGPS_DRIVER="ANDROID_NGPS_DRIVER"

    then start Primo and see will it fix GPS signal faster, didn't test latest version, but with 11 september works ok, with 27 sept would be same...

    At all like i told with all newer android phones - SG, HTC, Sony, etc. no problems with fixing gps signal, cause most of them have very good gps recievers, with S4 on my testing wasn't problem with fixing gps signal.
    ﻻاله اﻻ الله محمد رسول الله

  8. #7
    Member +
    Join Date
    Jul 2009
    Location
    Cyprus
    Posts
    30
    Rep Power
    0

    Default

    Quote Originally Posted by Black Wolf View Post
    Didn't have problem with fixing gps signal on newer SGS like S2, S3, S4, all of them fix gps signal fast, specially S3 and S4, which has now more better gps recievers. When you try to get gps signal, try to be at place where not some buildings front of you, or some other objects, which can block gps signal. In meantime, delete save folder, add these command lines in sys.txt

    ***Hidden content cannot be quoted.***

    then start Primo and see will it fix GPS signal faster, didn't test latest version, but with 11 september works ok, with 27 sept would be same...

    At all like i told with all newer android phones - SG, HTC, Sony, etc. no problems with fixing gps signal, cause most of them have very good gps recievers, with S4 on my testing wasn't problem with fixing gps signal.
    Thanks a lot I will test and let you know.

  9. #8
    Member +
    Join Date
    Jul 2009
    Location
    Cyprus
    Posts
    30
    Rep Power
    0

    Default

    Hello again guys! sorry for the delayed answer..I have tested it and I think its somehow better now.. I am getting GPS signal fast but not fast enough like Sygic....When i open Sygic I wait 5-10 secs and I get a signal (in an open area) with IGO it takes 30+ secs and when it gets the signal I may lose it and then it comes back...

    Thanks

  10. #9
    IGo Moderator Black Wolf's Avatar
    Join Date
    Jan 2010
    Location
    Near
    Posts
    436
    Rep Power
    353

    Default

    Didn't experience that on S4 with Primo 11.sept , fixing gps signal in 5-10 seconds with Primo and 11 sept., so unistall that release, which at all i don't like too much, cause think not modified good,

    [Only registered and activated users can see links. ]

    with this version works great, even without adittional command lines in sys.txt
    ﻻاله اﻻ الله محمد رسول الله

  11. #10
    Member +
    Join Date
    Jul 2009
    Location
    Cyprus
    Posts
    30
    Rep Power
    0

    Default

    Quote Originally Posted by Black Wolf View Post
    Didn't experience that on S4 with Primo 11.sept , fixing gps signal in 5-10 seconds with Primo and 11 sept., so unistall that release, which at all i don't like too much, cause think not modified good,

    [Only registered and activated users can see links. ]

    with this version works great, even without adittional command lines in sys.txt
    Thanks! Which one should I download for GS4? the one posted by ozut (data.zip) ?

 

 
Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.