Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Junior Member
    Join Date
    Jul 2013
    Location
    Fredericton
    Posts
    6
    Rep Power
    0

    Default Zumo 220 - Bricked / MIssing System Software

    Last ditch at trying to revive my bricked Zumo 220....

    It is in a state where it will not boot and it isn't recognised as a mass media device under Windows. It will go into pre-boot mode and I can attempt to update the firmware via the update.exe, but it returns an error code and the device is stuck at "Loader Loading" message.

    Just to see if it will do anything, I followed the steps to do a backup of region 41. The message from updater.exe indicated that it was successful, but the device doesn't reboot and there is no backup file on the SD card.

    Any suggestions for next steps?

    Thanks.

  2.    Advertissements


  3. #2
    ☼ADMIN☼
    catymag's Avatar
    Join Date
    Nov 2007
    Location
    light side
    Posts
    23,595
    Rep Power
    5317

    Default

    Hi
    please read this sticky threads:
    [Only registered and activated users can see links. ]
    [Only registered and activated users can see links. ]
    [Only registered and activated users can see links. ]
    [Only registered and activated users can see links. ]

    [Only registered and activated users can see links. ]
    You have to navigate to get to the good.
    Nuvi1250/Nuvi 34xx/Nuvi 2200/Nuvi 66/Oregon 600/Galaxy S5 MM 6.0.1/TomTom GO/iGO Nextgen Avic,Basar,Isr.Gift/Navigon
    Please don't flood my pm box with questions you can post on forum!! You won't hear back from me.

  4. #3
    Junior Member
    Join Date
    Jul 2013
    Location
    Fredericton
    Posts
    6
    Rep Power
    0

    Default

    Here is all the requested information:

    - Device Zuma 220, HWID - 1138
    - I don't know how it got bricked - I plugged it in to PC to do map updates but it crashed and got into a reboot loop before I could start updating.
    - The device currently starts up and displays "System Software Missing" .
    - PC does not show GPS as a media device or anything else
    - I've followed the steps for unbricking in the previous link, but I get an error message on the PC:
    App: Updater
    At: 8/5/2016 11:56:36 PM (UTC)
    OS: WIN32 Windows Platform, Major Version: 6, Minor Version: 1 Service Pack 1
    Processor: Pentium Pro or Pentium II, RAM: 4194303 KB
    IOU_UTILITIES.CPP-203-2.8

    - Garmin USB drivers are installed
    - It does reach pre-boot mode

  5. #4
    Garmin/GPS Systems GMod.

    Neil's Avatar
    Join Date
    Aug 2011
    Location
    Oz.
    Posts
    7,392
    Rep Power
    1434

    Default

    Receiving 'IOU_UTILITIES' error from Updater.exe can mean several things, the most innocuous is that the flash didn't complete because the connection failed due to a USB problem. Try many different cables and use another USB port [use a REAR port of PC, no hub]. Exhaustively try different cables and PC ports, switch to another PC or laptop also and if after trying all the simple stuff with great perseverance of numerous attempts you still can't get a successful flash of Cure3 look for further reasons as below:

    'System Software Missing' message on device means that the main firmware is [i] no longer in region 14, or [ii] it's corrupt, or [iii] it can't be started by the bootloader which is in region 5 and it in turn has been initiated by region 43, the 'starting blocks'. Using the wrong boot.bin [ramloader, flashed to region 12] results in the third reason for not starting and that's a big problem as the main firmware can then never start. This can be very serious. Are you sure you used the correct boot.bin/Ldr.bin for the device at all times? Also a corrupt region 41 can cause the main fw loading to fail. Physical damage to the flash chip is also a possibility.
    'Thanking Posts' are banned. To thank someone, and/or to see hidden links and content, use the [Only registered and activated users can see links. ] button below left of the helpful post then refresh your browser [F5 key]. 'Thanking Posts' are banned.
    Please don't spam. Posts serving no purpose other than to thank or to ask about hidden links are trashed or deleted, it's GPSPower's policy. Please don't spam.
    [Only registered and activated users can see links. ] should make their first post as a new Intro Thread in [Only registered and activated users can see links. ].

  6. #5
    Junior Member
    Join Date
    Jul 2013
    Location
    Fredericton
    Posts
    6
    Rep Power
    0

    Default

    I think I was able to get a successful flash of Cure3...I tried a few times unseccessfully (IOU errors) and then when I was waiting for the error message to pop up, I switched the USB to a different port (one that I had already tried many times) and I got a success message. However, now the device is in a reboot loop. Garmin screen appears, then goes black over and over. Computer does NOT recognize the unit.

  7. #6
    ☼ADMIN☼
    catymag's Avatar
    Join Date
    Nov 2007
    Location
    light side
    Posts
    23,595
    Rep Power
    5317

    Default

    Cure firmware should allow pc to see the unit, it's made to delete offending files from the gps.
    Cure firmware cannot boot, after cure and deleting files or formatting, must flash original firmware.
    But if after cure pc cannot see the device I think it's hardly bricked.
    But...if it's hardly bricked usually Updater.exe gives error like:

    [Only registered and activated users can see links. ]

    I'd try again with another cable and may be with another pc, may be there is a problem with your USB ports
    [Only registered and activated users can see links. ]
    [Only registered and activated users can see links. ]

    [Only registered and activated users can see links. ]
    You have to navigate to get to the good.
    Nuvi1250/Nuvi 34xx/Nuvi 2200/Nuvi 66/Oregon 600/Galaxy S5 MM 6.0.1/TomTom GO/iGO Nextgen Avic,Basar,Isr.Gift/Navigon
    Please don't flood my pm box with questions you can post on forum!! You won't hear back from me.

  8. #7
    Garmin/GPS Systems GMod.

    Neil's Avatar
    Join Date
    Aug 2011
    Location
    Oz.
    Posts
    7,392
    Rep Power
    1434

    Default

    Quote Originally Posted by mfaulkner View Post
    .... when I was waiting for the error message to pop up, I switched the USB to a different port (one that I had already tried many times) and I got a success message. .....
    Do you mean you unplugged from a port and re-plugged to another while Updater.exe was accessing the device? If so, despite the 'success message' i doubt it did properly complete loading the cure firmware.

    Maybe best to re-make the Cure3 firmware from scratch too then follow Caty's advice re different cable and PC. Even an old low-spec XP machine is fine to use.
    'Thanking Posts' are banned. To thank someone, and/or to see hidden links and content, use the [Only registered and activated users can see links. ] button below left of the helpful post then refresh your browser [F5 key]. 'Thanking Posts' are banned.
    Please don't spam. Posts serving no purpose other than to thank or to ask about hidden links are trashed or deleted, it's GPSPower's policy. Please don't spam.
    [Only registered and activated users can see links. ] should make their first post as a new Intro Thread in [Only registered and activated users can see links. ].

  9. #8
    Junior Member
    Join Date
    Jul 2013
    Location
    Fredericton
    Posts
    6
    Rep Power
    0

    Default

    On all previous attempts there was a period of about 15 seconds after the initial status bar, and the IOU error message. So this time, after the first status bar reached 100%, I changed USB ports. Then another status bar appears "Erasing" or something and then another a status bar which took about 30 seconds to complete. After clicking the popup, the device still says "Loading Loader". I kinda expected it to reboot itself, so after a few minutes I unplugged the USB cable and restarted it. That is when it got into the reboot loop.

    I'll see if I can find another computer to try.

    Thanks!

  10. #9
    Junior Member
    Join Date
    Jul 2013
    Location
    Fredericton
    Posts
    6
    Rep Power
    0

    Default

    Tried on another computer - same results. I was able to use the same trick to load the cure3. Then when I power off the gps, it gets into a reboot loop. The computer doesn't recognize the gps unless I hold top left screen while it reboots.

  11. #10
    ☼ADMIN☼
    catymag's Avatar
    Join Date
    Nov 2007
    Location
    light side
    Posts
    23,595
    Rep Power
    5317

    Default

    My guess is Updater was able to erase faulty firmware, after that you disconnected USB, so no new firmware loading and the result is System software missing.
    You must keep and holding on screen until Upater finishes.
    If you get IOU_Utilities error it's because USB connection is not good anymore and preboot fails.
    As said reasons can be: bad cable, bad USB port connection, USB hub use, not supported USB v3, wrongly followed preboot and flashing procedure.
    Pc doesn't see gps because cure didn't load.
    [Only registered and activated users can see links. ]
    [Only registered and activated users can see links. ]

    [Only registered and activated users can see links. ]
    You have to navigate to get to the good.
    Nuvi1250/Nuvi 34xx/Nuvi 2200/Nuvi 66/Oregon 600/Galaxy S5 MM 6.0.1/TomTom GO/iGO Nextgen Avic,Basar,Isr.Gift/Navigon
    Please don't flood my pm box with questions you can post on forum!! You won't hear back from me.

 

 
Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.