Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Results 1 to 2 of 2
  1. #1
    Junior Member
    Join Date
    Jun 2016
    Rep Power

    help Garmin Alpha 100 firmware for use in EU

    I have two Alpha 100 both of the bought from US by a friend.
    One was already ''patched'' by someone here in Italy that ask a lot of money for this kind of job around 150-200
    Strange is that is working fine with EU radio freq and has 3.41 firmware installed that you can't see it from device menu only from the .xml file when you attached to the computer.And has the option to change the language.

    The other one i can make it work only with the 3.1 firmare and I can't make appear the change language option and I receive a lots of lost connection messages with the collars TT15 because this collars are supported with a higher FW version than 3.1

    There is anyone in this forum who know how to extract the firmware from the working one and install to the other one or someone who know how to get the job done?

    Thank you.
    Last edited by catymag; 5th July 2016 at 10:17 AM. Reason: part of the post removed

  2.    Advertissements

  3. #2
    Join Date
    Feb 2011
    Rep Power


    Take a look here [Only registered and activated users can see links. ]



Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.