Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 25
  1. #11
    Junior Member
    Join Date
    Mar 2016
    Location
    UAE
    Posts
    9
    Rep Power
    0

    Default

    It is showing loader for almost an hour now . However will wait and tell you the results

  2.    Advertissements


  3. #12
    Garmin/GPS Systems GMod.

    Neil's Avatar
    Join Date
    Aug 2011
    Location
    Oz.
    Posts
    7,387
    Rep Power
    1434

    Default

    If it's stuck on Loader for more than several minutes it means one of these things in order of what's best: (i) It's not parsing the command 'reboot' but has flashed regions 14, 127 and 158 successfully; (ii) The Ldr.bin has overwritten the unit's [wrong] X-Loader and Bootloader and the unit now at least has the correct boot info on board for a HWID 2077 device; (iii) The Ldr.bin is unable to initiate the flash at all and it's done absolutely nothing.

    Let's hope it's the first but there's only one way the find out. Disconnect the nuvi from any power source, force it off and leave it OFF then remove the card. Check in '1947' folder for a new file update.log, if it's present open it in NotePad and report it's content. Don't turn on the nuvi until we find out what's happened if anything.

    Posts above moved from [Only registered and activated users can see links. ].
    'Thanking Posts' are banned. To thank someone, and/or to see hidden links and content, use the [Only registered and activated users can see links. ] button below left of the helpful post then refresh your browser [F5 key]. 'Thanking Posts' are banned.
    Please don't spam. Posts serving no purpose other than to thank or to ask about hidden links are trashed or deleted, it's GPSPower's policy. Please don't spam.
    [Only registered and activated users can see links. ] should make their first post as a new Intro Thread in [Only registered and activated users can see links. ].

  4. #13
    Junior Member
    Join Date
    Mar 2016
    Location
    UAE
    Posts
    9
    Rep Power
    0

    Default

    Thanks for the reply
    The file update.log is not present in 1947 folder
    Any further steps?

    Regards

  5. #14
    Garmin/GPS Systems GMod.

    Neil's Avatar
    Join Date
    Aug 2011
    Location
    Oz.
    Posts
    7,387
    Rep Power
    1434

    Default

    Unfortunately absence of update.log means the Ldr.bin has tried to initiate the write process without successfully even starting it although 'Loader' showed on the screen, but 'Loader' presence indicates at least something happened. It may be that Ldr.bin has written the correct 2077 boot info to regions 5 and 43 now, so best you try it again just in case because if it's now got correct bootloader and x-loader on board it should write the firmware bin files to their correct regions next attempt. First check that there isn't a file named 'last_id.bin' created in the 1947 folder from the failed write, if it's there remove it before trying again. I'm unsure at what point 'last-id.bin' is created, but if it's at the the very start when 'Loader' appears then it should be there.

    If it sticks on Loader again kill the process as before but let it go for an hour or so to be absolutely sure it's not doing anything. I should tell you that i'm not a programmer so i cannot help with complex firmware/bin file manipulation, therefore anything we can try from here will only involve more of the same guesswork and basic potential solutions from me.

    Let's have the results please before we go further with this 'blind man's bluff'. If the miracle happens and it boots with touch this time, immediately [Only registered and activated users can see links. ] several times. I've uncertain from your earlier posts exactly how far it's been booting, but because you reported that you were able to look at the GarminDevice.xml therefore it has Mass Storage Mode or Media Transfer Protocol available and that indicates to me it's been booting to the main screen. So please check the xml file again if nothing happens when you re-insert the microSD and if it now shows '2077' instead of '1947' in the xml then change the name of the 1947 folder to 2077 in the card and try that.
    'Thanking Posts' are banned. To thank someone, and/or to see hidden links and content, use the [Only registered and activated users can see links. ] button below left of the helpful post then refresh your browser [F5 key]. 'Thanking Posts' are banned.
    Please don't spam. Posts serving no purpose other than to thank or to ask about hidden links are trashed or deleted, it's GPSPower's policy. Please don't spam.
    [Only registered and activated users can see links. ] should make their first post as a new Intro Thread in [Only registered and activated users can see links. ].

  6. #15
    Navigation software expert

    lolypop000's Avatar
    Join Date
    May 2010
    Location
    EU
    Posts
    2,925
    Rep Power
    848

    Default

    Upload please your FW that you use when touch stop responding, so we can see what was wrong and how to help you.
    If you wish, you can [Only registered and activated users can see links. ]

  7. #16
    Garmin/GPS Systems GMod.

    Neil's Avatar
    Join Date
    Aug 2011
    Location
    Oz.
    Posts
    7,387
    Rep Power
    1434

    Default

    Loly, it seems he flashed his 2597 C4 [HWID 2077] with 25x9 C4 firmware as below. It's then showed in GarminDevice.xml as "<PartNumber>006-B17491947-00</PartNumber>" so it's accepted the flash and changed the unit's HWID to 1947.
    Code:
    Please Login or Register to see the links
    Last edited by Neil; 3rd April 2016 at 20:53. Reason: correct typo.
    'Thanking Posts' are banned. To thank someone, and/or to see hidden links and content, use the [Only registered and activated users can see links. ] button below left of the helpful post then refresh your browser [F5 key]. 'Thanking Posts' are banned.
    Please don't spam. Posts serving no purpose other than to thank or to ask about hidden links are trashed or deleted, it's GPSPower's policy. Please don't spam.
    [Only registered and activated users can see links. ] should make their first post as a new Intro Thread in [Only registered and activated users can see links. ].

  8. #17
    Navigation software expert

    lolypop000's Avatar
    Join Date
    May 2010
    Location
    EU
    Posts
    2,925
    Rep Power
    848

    Default

    Why you have in red 1749 but then you wrote 1947?

    Can you please share link for both FW so i can be sure that i have correct fw for investigation?

    Thank you Neil
    If you wish, you can [Only registered and activated users can see links. ]

  9. #18
    Garmin/GPS Systems GMod.

    Neil's Avatar
    Join Date
    Aug 2011
    Location
    Oz.
    Posts
    7,387
    Rep Power
    1434

    Default

    Sorry, one of my many typos Loly. I've corrected it.

    Just as 25x9 C4 HWID 1947 have only one series of firmware versions, so does 2xx7/2xx8 C4 HWID 2077:
    Code:
    Please Login or Register to see the links
    The information/change log pages for both firmwares are quite close in their URLs:
    Code:
    Please Login or Register to see the links
    To recap the situation:
    • He was trying to patch V8.30 for C4 2077 but mistakenly used V8.30 C4 1947 instead [i don't know what version of 2077 was onboard previously but it's moot now i guess]
    • It was flashed by RGN file but it seems not with safe convention naming XXXX10000.xxx.rgn so the flash was forced and accepted
    • Apparently the unit boots but has no touch function.
    • It is seen by PC so isn't 'bricked' in that sense.
    • It cannot reach preboot because of the unresponsive screen


    What's been tried so far:
    An attempt to flash rgns 14, 127 and 158 from 2077 fw via SD also using Ldr.bin from 2077 fw but in a folder '1947' to match the unit's wrongly written HWID. That's resulted in 'Loader' displaying endlessly on the screen. No 'update.log' in the 1947 folder. I've now asked him to try two things: [i] remove last_id.bin if present and retry the flash in case regions 5 and 43 have been overwritten in the first attempt [ii] If that doesn't work but if the HWID in the XML is now showing as 2077 to change the 1947 folder name to 2077 and repeat the attempt.

    New intended action if needed:
    • If XML still shows 1947, then use the Ldr.bin from HWID1947 to try flashing the 2077 regions 14, 127 & 158 with override in RGN_Tool to 1947 of fw_all.bin for region 14 [127 and 158 have no HWID specified, they're XXXX in RGN_Tool].
    • If that works and touch is back then force a flash of full 2077 fw as OUT.RGN in preboot to write correct HWID 2007.


    I haven't thought any further ahead at this stage. What's your thoughts? Can the firmware be more deeply modded to force the correct flash if necessary?

    PS: I've posted this summary because it's a bit hard to 'see the woods for the trees' in the numerous posts. It may help you or any other NSE with coding experience to see a clear way ahead if my basic attrempts don't work.
    'Thanking Posts' are banned. To thank someone, and/or to see hidden links and content, use the [Only registered and activated users can see links. ] button below left of the helpful post then refresh your browser [F5 key]. 'Thanking Posts' are banned.
    Please don't spam. Posts serving no purpose other than to thank or to ask about hidden links are trashed or deleted, it's GPSPower's policy. Please don't spam.
    [Only registered and activated users can see links. ] should make their first post as a new Intro Thread in [Only registered and activated users can see links. ].

  10. #19
    Navigation software expert

    lolypop000's Avatar
    Join Date
    May 2010
    Location
    EU
    Posts
    2,925
    Rep Power
    848

    Default

    I have idea how we can maybe repair this unit but i whait for @dfdfaisal to see if he brave enough to try.
    If you wish, you can [Only registered and activated users can see links. ]

  11. #20
    Junior Member
    Join Date
    Mar 2016
    Location
    UAE
    Posts
    9
    Rep Power
    0

    Default

    Guys thank you very much for your interest in helping me and appreciate it

    Neil : I tried the same process again but it stuck at loader for 2 hours the same like before.

    No changes at all in the files in SD and no new files

 

 
Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.