Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Page 5 of 6 FirstFirst ... 3456 LastLast
Results 41 to 50 of 59
  1. #41
    Garmin/GPS Systems GMod.

    Neil's Avatar
    Join Date
    Aug 2011
    Location
    Oz.
    Posts
    7,400
    Rep Power
    1434

    Default

    Ok, good result. Remember that this device has hybrid firmware so WebUpdater and GarminExpress will treat it as an Explore because it still has HWID 2204 despite running the firmware of Edge 1000 HWID 1836. If you try to update firmware by WU or GE it will be recognised as HWID 2204 and that firmware will be loaded so it'll be returned to an Explore on reboot. If you want, you can now flash it to full Edge 1000 with HWID 1836 using full firmware and then it can be updated normally thereafter. If not, you can only update it with hybrid fw in future. Thread marked 'Solved'.
    'Thanking Posts' are banned. To thank someone, and/or to see hidden links and content, use the [Only registered and activated users can see links. ] button below left of the helpful post then refresh your browser [F5 key]. 'Thanking Posts' are banned.
    Please don't spam. Posts serving no purpose other than to thank or to ask about hidden links are trashed or deleted, it's GPSPower's policy. Please don't spam.
    [Only registered and activated users can see links. ] should make their first post as a new Intro Thread in [Only registered and activated users can see links. ].

  2.    Advertissements


  3. #42
    Member +
    Join Date
    Dec 2015
    Location
    Israel
    Posts
    34
    Rep Power
    0

    Default

    Neil - I don't think I have the balls to change its ID - I think what we have done is exactly what I wanted and its the safest route. In general I never was the guy who would upgrade every small change in the firmware. Only if its a major one that actually solve something that is relevant for me. I hope that if an important update will be release and I will ask politely for you help I will be able to flash it again as we just did...

    When I launch Garmin express it tells me that I have the Garmin Explore 1000 as the model, but software version 7.00....
    Last edited by irousso; 1st April 2016 at 11:59.

  4. #43
    Garmin/GPS Systems GMod.

    Neil's Avatar
    Join Date
    Aug 2011
    Location
    Oz.
    Posts
    7,400
    Rep Power
    1434

    Default

    I had changed the software [firmware] version to 7.00 in the hybrid fw. Explore is presently at version 3.00, Edge 1000 is at version 7.00. However those update programs [WU & GE] will read the HWID and allocate firmware according to that so be very careful using them or you'll end up with it back as an Explore again. I know you seem concerned to use RGN_Tool but it's really not as scary as you might think. Perhaps you're not the only one so i'll make a tut when i have a little more time on how to check compatibility of related devices and then make hybrid firmware to safely cross-flash using tools already available here.
    'Thanking Posts' are banned. To thank someone, and/or to see hidden links and content, use the [Only registered and activated users can see links. ] button below left of the helpful post then refresh your browser [F5 key]. 'Thanking Posts' are banned.
    Please don't spam. Posts serving no purpose other than to thank or to ask about hidden links are trashed or deleted, it's GPSPower's policy. Please don't spam.
    [Only registered and activated users can see links. ] should make their first post as a new Intro Thread in [Only registered and activated users can see links. ].

  5. #44
    Member +
    Join Date
    Dec 2015
    Location
    Israel
    Posts
    34
    Rep Power
    0

    Default

    I defined in Garmin Express not to download firmware updates - so that I won't have it updated and revert back to Explore. I don't know how Garmin deals with ID change, I know for example that there are devices that can become unusable if you mess with it.
    Again Neil - many thanks for your help, I truly appreciate all that you have done!
    Itay

  6. #45
    Garmin/GPS Systems GMod.

    Neil's Avatar
    Join Date
    Aug 2011
    Location
    Oz.
    Posts
    7,400
    Rep Power
    1434

    Default

    The biggest problem messing with HWID change is the risk of some incompatibility of firmware and hardware generally. Retaining HWID when cross-flashing is preferable because it [usually] easily gives you a safe recourse back to original firmware.

    Sometimes a boot.bin [Ldr.bin] from the original firmware won't work with the desired main software [fw_all.bin; fw1_resources.bin etc.] to flash the relevant regions so we can't use it without further manipulation of the main software, either that or we take the chance and just use the native boot.bin. An example of that is [Only registered and activated users can see links. ], they have different HWIDs but same [Only registered and activated users can see links. ] and despite their hardware being identical the 37x0 boot.bin is incapable of dealing with the 34x0 firmware, although it can do so if the firmware is [Only registered and activated users can see links. ] first thanks to kunix [that's what i mean by further manipulation and it's another story and not a given for other units either]. So we just use the full 34x0 fw for the conversion.

    However, if the original boot.bin does work and the device successfully runs the intended fw then we can be totally confident that so will that fw's native boot.bin work with it's own fw. Therefore we can do a full flash during which the HWID is also changed and the device is effectively fully converted. There are numerous other examples of that: nuvi 2460 to dezl 560; nuvi 27x7 to dezl/RV/Camper 760; nuvi 5x0 to zumo 2x0; nuvi 2x5W to nuvi 465; etc., where hybrid flash works and therefore so will full flash. If hybrid doesn't work only because of an ineffective boot.bin then it doesn't mean that full flash won't work but it's inherently riskier to attempt it without a successful flash of hybrid fw initially.

    Now we can assume Edge 1000 Explore to Edge 1000 is fully compatible simply because it's running properly as a hybrid, although regardless it would be prudent to test out it's real world use for a reasonable period before being the first to make the full conversion.

    I hope that puts things in perspective for you. The explanation is perhaps over-simplistic and will make our Navigation Software Experts' teeth grind but in layman's terms it makes reasonable sense.
    'Thanking Posts' are banned. To thank someone, and/or to see hidden links and content, use the [Only registered and activated users can see links. ] button below left of the helpful post then refresh your browser [F5 key]. 'Thanking Posts' are banned.
    Please don't spam. Posts serving no purpose other than to thank or to ask about hidden links are trashed or deleted, it's GPSPower's policy. Please don't spam.
    [Only registered and activated users can see links. ] should make their first post as a new Intro Thread in [Only registered and activated users can see links. ].

  7. #46
    Member +
    Join Date
    Dec 2015
    Location
    Israel
    Posts
    34
    Rep Power
    0

    Default

    Neil - that was a very good explanation for someone like me. Let me run the device for a week or two. I ride quite a lot so that will give a good testing time. So far I saw that it easily pairs with my Ant+ sensors, my maps works. Basically I saw yet nothing that does not work. After a week or two, I will be willing to try and flash it with a firmware that will change its HWID. Again, I know its a risk, but its a one I am willing to take because despite lack of guaranties you seems to know what you are doing.

    Itay

  8. #47
    Member +
    Join Date
    Dec 2015
    Location
    Israel
    Posts
    34
    Rep Power
    0

    Default

    ok - so I think there is a small problem... :-)
    The device is being recognized by GE, however if I do stuff on GC (for example create a workout or a segment) I can't sync it with the device. Its basically tells me that there is no connected device - this is while it is connected and recognized by GE.
    I've noticed that in GC when activities are uploaded the device is being recognized as Edge 1000 whereas in Express it is identified as Explore 1000 - could that be the source for the above problem?
    Itay
    Last edited by irousso; 6th April 2016 at 09:08.

  9. #48
    Garmin/GPS Systems GMod.

    Neil's Avatar
    Join Date
    Aug 2011
    Location
    Oz.
    Posts
    7,400
    Rep Power
    1434

    Default

    I'm not particularly familiar with how GarminConnect 'reads' the identity of the unit connected to it. It may be that it only looks at the unit's HWID and because yours is still 2204 it's being identified as an Explore and the assumption is made that those features aren't available. Read the comparison of full 1000 to Explore here:
    Code:
    Please Login or Register to see the links
    If you want it to function fully as an Edge 1000 then do a complete conversion, it'll then have HWID of 1836 and the extra features should be available in GC.
    'Thanking Posts' are banned. To thank someone, and/or to see hidden links and content, use the [Only registered and activated users can see links. ] button below left of the helpful post then refresh your browser [F5 key]. 'Thanking Posts' are banned.
    Please don't spam. Posts serving no purpose other than to thank or to ask about hidden links are trashed or deleted, it's GPSPower's policy. Please don't spam.
    [Only registered and activated users can see links. ] should make their first post as a new Intro Thread in [Only registered and activated users can see links. ].

  10. #49
    Member +
    Join Date
    Dec 2015
    Location
    Israel
    Posts
    34
    Rep Power
    0

    Default

    Neil,
    I've been working with the hybrid edge for several rides now and it all works perfectly. I think I am ready to take the risk and do the full conversion with the HWID change. Again, I fully understand that there is no guarantee, but I do trust your knowledge. Could you please upload the appropriate firmware so that I can flash my device?
    Just a quick info - when I flashed my device with the hybrid firmware, after I was informed that the upload was completed the device was "stuck" at the downloading stage and I had to soft-restart it in order for it to restart. Is this "normal"? should I be worried about it - or I can go ahead and do the full conversion?
    Cheers,
    Itay

  11. #50
    Garmin/GPS Systems GMod.

    Neil's Avatar
    Join Date
    Aug 2011
    Location
    Oz.
    Posts
    7,400
    Rep Power
    1434

    Default

    I have a theory about it being stuck on Loader/Software Loader. Garmin 1000 Explore has region 136 populated and it's firmware has a bin file to flash to it whereas it's not present in Edge 100 firmware, see Post #10. Perhaps because we retained the HWID and used the boot.bin from Explore it was waiting for a further flash for region 136 which of course would never come. So although Updater.exe had completed the flash the device was waiting for more, therefore it had to be forced off to reboot it.

    If you wish to flash the full Edge 1000 firmware, hard reset it first. Extract the rar file, then flash Out.rgn in preboot via Updater.exe: [Only registered and activated users can see links. ]

    Hard reset it again immediately after the flash.
    'Thanking Posts' are banned. To thank someone, and/or to see hidden links and content, use the [Only registered and activated users can see links. ] button below left of the helpful post then refresh your browser [F5 key]. 'Thanking Posts' are banned.
    Please don't spam. Posts serving no purpose other than to thank or to ask about hidden links are trashed or deleted, it's GPSPower's policy. Please don't spam.
    [Only registered and activated users can see links. ] should make their first post as a new Intro Thread in [Only registered and activated users can see links. ].

 

 
Page 5 of 6 FirstFirst ... 3456 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.