Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1
    Junior Member
    Join Date
    Sep 2014
    Location
    Prague
    Age
    38
    Posts
    6
    Rep Power
    0

    Default Garmin Nuvi 660 EU stuck on Garmin logo

    Hello all,

    I have several problem with my Nuvi 660 Euro. Nuvi was bricked before with my friend, and I do not know what he did. Last thing what happened me, was flashing Cure firmware maked from latest Nuvi 660 - 4.90 firmware - result OK. Next step was formating internal flash in Win7. But formating was interrupted and Nuvi totally not working.

    I have tried a lot of things, but no one helped. Nuvi stuck on Garmin logo screen. Only preboot mode working. Only possible is flash boot.bin. Fw_all.bin is impossible to flash. I have tested update.txt with modified boot.bin and it is working.

    Unit ID get from updater.exe is different to UID and HWID get from update.txt script.

    Information from update.txt script:
    nüvi 660 Software Version 4.90, UID: hidden , HWID: hidden
    ------------------------------------------------------------------------------
    Parsing "ergn,14"
    Error
    Parsing "reboot"
    Success

    nüvi 660 Software Version 4.90, UID: 4294967295, HWID: 1746147337
    ------------------------------------------------------------------------------
    Parsing "ergn,"
    Error
    Parsing "reboot"
    Success


    I have tried command above, but get error and different UID / HWID.

    Can you help me?

  2.    Advertissements


  3. #2
    ☼ADMIN☼
    catymag's Avatar
    Join Date
    Nov 2007
    Location
    light side
    Posts
    23,608
    Rep Power
    5320

    Default

    try cure by kunix then format with RMPrepUSB
    follow this
    [Only registered and activated users can see links. ]
    [Only registered and activated users can see links. ]
    [Only registered and activated users can see links. ]

    [Only registered and activated users can see links. ]
    You have to navigate to get to the good.
    Nuvi1250/Nuvi 34xx/Nuvi 2200/Nuvi 66/Oregon 600/Galaxy S5 MM 6.0.1/TomTom GO/iGO Nextgen Avic,Basar,Isr.Gift/Navigon
    Please don't flood my pm box with questions you can post on forum!! You won't hear back from me.

  4. #3
    Garmin/GPS Systems GMod.

    Neil's Avatar
    Join Date
    Aug 2011
    Location
    Oz.
    Posts
    7,399
    Rep Power
    1434

    Default

    You'll get the different UID & HWID numbers with all nuvi 3x0/6x0, it a series quirk. Best you edit those numbers out if they're genuine [but i think you've disguised them ].

    Do you still have cure fw onboard? If not can you flash cure still? How did you attempt to reformat? If you can load cure fw still and you formatted with the Windows built-in tool or something other than RMprepUSB then you should try with that. [Only registered and activated users can see links. ]

    EDIT: Oopps, Caty beat me ..... [so what's new :sigh:].
    Last edited by Neil; 11th September 2014 at 23:22. Reason: too slow.
    'Thanking Posts' are banned. To thank someone, and/or to see hidden links and content, use the [Only registered and activated users can see links. ] button below left of the helpful post then refresh your browser [F5 key]. 'Thanking Posts' are banned.
    Please don't spam. Posts serving no purpose other than to thank or to ask about hidden links are trashed or deleted, it's GPSPower's policy. Please don't spam.
    [Only registered and activated users can see links. ] should make their first post as a new Intro Thread in [Only registered and activated users can see links. ].

  5. #4
    Junior Member
    Join Date
    Sep 2014
    Location
    Prague
    Age
    38
    Posts
    6
    Rep Power
    0

    Default

    I tried both steps before, but Nuvi cannot be seen as attached device (only in pre-boot mode as Garmin device). If I try to flash Cure firmware, first I get correct Unit ID, start flashing and when loader information displays on the screen of Nuvi, I get (Unit id 0) in updater.exe window and aftre while I get error: CPP-203-2.8 from updater.exe app. I thing, that I need to reformat flash internally, because it is impossible to connect Nuvi as mass storage device. It can be done by update.txt file or by another trick?

  6. #5
    ☼ADMIN☼
    catymag's Avatar
    Join Date
    Nov 2007
    Location
    light side
    Posts
    23,608
    Rep Power
    5320

    Default

    Do you have Garmin drivers installed properly?
    Which OS are you using?
    [Only registered and activated users can see links. ]
    [Only registered and activated users can see links. ]

    [Only registered and activated users can see links. ]
    You have to navigate to get to the good.
    Nuvi1250/Nuvi 34xx/Nuvi 2200/Nuvi 66/Oregon 600/Galaxy S5 MM 6.0.1/TomTom GO/iGO Nextgen Avic,Basar,Isr.Gift/Navigon
    Please don't flood my pm box with questions you can post on forum!! You won't hear back from me.

  7. #6
    Junior Member
    Join Date
    Sep 2014
    Location
    Prague
    Age
    38
    Posts
    6
    Rep Power
    0

    Default

    I tried three computers, two with Win7 x64 and one with XP SP3. Garmin drivers (latest) installed correctly on all computers. When I insert usb cable to Nuvi, nothing happen on USB, onlu Nuvi turns on. Stuck on Garmin logo screen. Touching corners with finger does nothing, only long press of power button.

  8. #7
    Navigation software expert

    lolypop000's Avatar
    Join Date
    May 2010
    Location
    EU
    Posts
    2,925
    Rep Power
    849

    Default

    Do you download garmin drivers from garmin site?
    If you wish, you can [Only registered and activated users can see links. ]

  9. #8
    ☼ADMIN☼
    catymag's Avatar
    Join Date
    Nov 2007
    Location
    light side
    Posts
    23,608
    Rep Power
    5320

    Default

    Check also if it's a Garmin cable, some cables are not suitable, some allow charging but not USB communication with nuvi.
    [Only registered and activated users can see links. ]
    [Only registered and activated users can see links. ]

    [Only registered and activated users can see links. ]
    You have to navigate to get to the good.
    Nuvi1250/Nuvi 34xx/Nuvi 2200/Nuvi 66/Oregon 600/Galaxy S5 MM 6.0.1/TomTom GO/iGO Nextgen Avic,Basar,Isr.Gift/Navigon
    Please don't flood my pm box with questions you can post on forum!! You won't hear back from me.

  10. #9
    Junior Member
    Join Date
    Sep 2014
    Location
    Prague
    Age
    38
    Posts
    6
    Rep Power
    0

    Default

    I have three usb data cables, two are high quality and one is cheap. I tried all cables but result still same. Only pre-boot mode connect to PC.

  11. #10
    Garmin/GPS Systems GMod.

    Neil's Avatar
    Join Date
    Aug 2011
    Location
    Oz.
    Posts
    7,399
    Rep Power
    1434

    Default

    Quote Originally Posted by halen1 View Post
    I tried both steps before, but Nuvi cannot be seen as attached device (only in pre-boot mode as Garmin device). If I try to flash Cure firmware, first I get correct Unit ID, start flashing and when loader information displays on the screen of Nuvi, I get (Unit id 0) in updater.exe window and aftre while I get error: CPP-203-2.8 from updater.exe app. I thing, that I need to reformat flash internally, because it is impossible to connect Nuvi as mass storage device. It can be done by update.txt file or by another trick?
    Seeing different PCs & OSs have been tried and it connects initially but exactly the same interrupt error is returned while using Updater.exe in preboot, i doubt the problem's with usb drivers. I think there a few other possible problems: [1] usb cable is intermittently faulty [unlikely, seeing you've tried 3 of them]. [2] The usb socket/mo connection is faulty/loose/making & breaking [not a common problem with nuvi 6x0 series]. [3] Damaged or corrupt internal flash [this seems most likely because your attempt shown in the initial post running the legitimate command 'ergn,14' to erase region 14 failed with error in update.txt].

    You could try to erase rgn41 but it's not possible to successfully backup 41 on 6x0 and the bin file will be empty, so there's also no way to restore it. Some other regions can be backed up but in 3x0/6x0 the path to SD is 2 as it is for 2013 models with RWFS, not 1 as for most. With no way to restore 41 all registration and unlock codes for the unit will be lost even if you successfully erase it. If the flash chip is actually damaged the unit cannot economically be recovered anyway. It's just not feasible to replace the chip on such an old unit imo. If the unit was mine i'd try erasing 41, but maybe someone has another suggestion.
    'Thanking Posts' are banned. To thank someone, and/or to see hidden links and content, use the [Only registered and activated users can see links. ] button below left of the helpful post then refresh your browser [F5 key]. 'Thanking Posts' are banned.
    Please don't spam. Posts serving no purpose other than to thank or to ask about hidden links are trashed or deleted, it's GPSPower's policy. Please don't spam.
    [Only registered and activated users can see links. ] should make their first post as a new Intro Thread in [Only registered and activated users can see links. ].

 

 
Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.