Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Results 1 to 8 of 8
  1. #1
    Garmin/GPS Systems GMod.

    Neil's Avatar
    Join Date
    Aug 2011
    Location
    Oz.
    Posts
    7,403
    Rep Power
    1435

    help NA nuvi 680 GPS & BT software missing

    Some advice please for this unit. It was given to me bricked, stuck on a loop of loading the GPS software. It will get to ~70% loading GPS sw then revert to 0% and start loading again. BT sw loading aborts immediately but doesn't restart and in the absence of the GPS bin file the unit will boot but of course can't get a satellite lock.

    680 SW

    This is what I've done:

    • Cured it.
    • Deleted BT sw update file 006B055301.GCD and GPS sw update file 006B047800.BIN from RemoteSW and Garmin folders respectively.
    • Loaded original system sw.
    • Replaced BT & GPS sw using WebUpdater.
    • Downgraded system sw.
    • Loaded older versions of GPS and BT sw.

    Nothing changed. I've thought about forcing loading of the BT sw as an RGN file but even if that worked the unit's useless without a working GPS receiver. The unit is in almost pristine condition and is worth something for parts anyway.

    Suggestions?
    'Thanking Posts' are banned. To thank someone, and/or to see hidden links and content, use the [Only registered and activated users can see links. ] button below left of the helpful post then refresh your browser [F5 key]. 'Thanking Posts' are banned.
    Please don't spam. Posts serving no purpose other than to thank or to ask about hidden links are trashed or deleted, it's GPSPower's policy. Please don't spam.
    [Only registered and activated users can see links. ] should make their first post as a new Intro Thread in [Only registered and activated users can see links. ].

  2.    Advertissements


  3. #2
    Navigation software expert

    lolypop000's Avatar
    Join Date
    May 2010
    Location
    EU
    Posts
    2,925
    Rep Power
    849

    Default

    Do you have empty circle in GPS page or you have satellite inside?

    If you have empty, then your flat cable have damage.
    If you wish, you can [Only registered and activated users can see links. ]

  4. #3
    Garmin/GPS Systems GMod.

    Neil's Avatar
    Join Date
    Aug 2011
    Location
    Oz.
    Posts
    7,403
    Rep Power
    1435

    Default

    Empty. I'll try to locate another antenna module to swap out, thanks.
    'Thanking Posts' are banned. To thank someone, and/or to see hidden links and content, use the [Only registered and activated users can see links. ] button below left of the helpful post then refresh your browser [F5 key]. 'Thanking Posts' are banned.
    Please don't spam. Posts serving no purpose other than to thank or to ask about hidden links are trashed or deleted, it's GPSPower's policy. Please don't spam.
    [Only registered and activated users can see links. ] should make their first post as a new Intro Thread in [Only registered and activated users can see links. ].

  5. #4
    Garmin/GPS Systems GMod.

    Neil's Avatar
    Join Date
    Aug 2011
    Location
    Oz.
    Posts
    7,403
    Rep Power
    1435

    Default

    Update: Found an antenna module from a 300 which works fine in the 680 and sat fix works, but BT still won't update so maybe it's integrated in the antenna module for BT models and is not present in the antenna for the non-BT 300? I'll try swapping the flat cable only and using the original module in case it's only the cable faulty.
    'Thanking Posts' are banned. To thank someone, and/or to see hidden links and content, use the [Only registered and activated users can see links. ] button below left of the helpful post then refresh your browser [F5 key]. 'Thanking Posts' are banned.
    Please don't spam. Posts serving no purpose other than to thank or to ask about hidden links are trashed or deleted, it's GPSPower's policy. Please don't spam.
    [Only registered and activated users can see links. ] should make their first post as a new Intro Thread in [Only registered and activated users can see links. ].

  6. #5
    Navigation software expert

    lolypop000's Avatar
    Join Date
    May 2010
    Location
    EU
    Posts
    2,925
    Rep Power
    849

    Default

    If you have empty circle then is faulty flat cable
    If you wish, you can [Only registered and activated users can see links. ]

  7. #6
    Garmin/GPS Systems GMod.

    Neil's Avatar
    Join Date
    Aug 2011
    Location
    Oz.
    Posts
    7,403
    Rep Power
    1435

    Default

    Yep, you're right as always Loly. Faulty cable it was. I suppose all that coiling/uncoiling inside the antenna casing doesn't help. Problem fixed so thread marked solved, Thx again Loly.
    'Thanking Posts' are banned. To thank someone, and/or to see hidden links and content, use the [Only registered and activated users can see links. ] button below left of the helpful post then refresh your browser [F5 key]. 'Thanking Posts' are banned.
    Please don't spam. Posts serving no purpose other than to thank or to ask about hidden links are trashed or deleted, it's GPSPower's policy. Please don't spam.
    [Only registered and activated users can see links. ] should make their first post as a new Intro Thread in [Only registered and activated users can see links. ].

  8. #7
    Navigation software expert

    lolypop000's Avatar
    Join Date
    May 2010
    Location
    EU
    Posts
    2,925
    Rep Power
    849

    Default

    You have now also working BT?
    If you wish, you can [Only registered and activated users can see links. ]

  9. #8
    Garmin/GPS Systems GMod.

    Neil's Avatar
    Join Date
    Aug 2011
    Location
    Oz.
    Posts
    7,403
    Rep Power
    1435

    Default

    Yes all working with another cable, original antenna module.
    'Thanking Posts' are banned. To thank someone, and/or to see hidden links and content, use the [Only registered and activated users can see links. ] button below left of the helpful post then refresh your browser [F5 key]. 'Thanking Posts' are banned.
    Please don't spam. Posts serving no purpose other than to thank or to ask about hidden links are trashed or deleted, it's GPSPower's policy. Please don't spam.
    [Only registered and activated users can see links. ] should make their first post as a new Intro Thread in [Only registered and activated users can see links. ].

 

 

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.