Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Results 1 to 8 of 8
  1. #1
    Member +
    Join Date
    Jul 2012
    Location
    Republic of Srpska, Bosnia
    Age
    38
    Posts
    37
    Rep Power
    5

    help Nuvi 1390 won't connect to computer

    Hi!

    I have unusual problem with my Garmin GPS.

    I have got a Nuvi 1390 which won't connect to computer. I have seen a screen which show a progress bar and after that shows computer. Picture with computer without progress bar has seen a screen about 10-15 seconds. During that period computer don’t detect nuvi like drive.

    After that, nuvi reboots itself and nuvi works normally, like on car charger. When I disconnect nuvi from my computer I have seen massage: “External power has been lost. Turning off in 30, 29,28…”

    Of course, I have changed USB port, computer, cable…

    Can I do software update, maps update, POI….?

    Help, please.

  2.    Advertissements


  3. #2
    ☼ADMIN☼
    catymag's Avatar
    Join Date
    Nov 2007
    Location
    light side
    Posts
    23,612
    Rep Power
    5321

    Default

    It can be a socket pins problem.
    Read this thread [Only registered and activated users can see links. ]
    post 15/16
    [Only registered and activated users can see links. ]
    [Only registered and activated users can see links. ]

    [Only registered and activated users can see links. ]
    You have to navigate to get to the good.
    Nuvi1250/Nuvi 34xx/Nuvi 2200/Nuvi 66/Oregon 600/Galaxy S5 MM 6.0.1/TomTom GO/iGO Nextgen Avic,Basar,Isr.Gift/Navigon
    Please don't flood my pm box with questions you can post on forum!! You won't hear back from me.

  4. #3
    Junior Member
    Join Date
    May 2014
    Location
    foca
    Age
    35
    Posts
    6
    Rep Power
    0

    Default

    Check the following link:
    Code:
    Please Login or Register to see the links
    I think we have the same [Only registered and activated users can see links. ] , but I don't think it's this user's problem.

  5. #4
    Member +
    Join Date
    Jul 2012
    Location
    Republic of Srpska, Bosnia
    Age
    38
    Posts
    37
    Rep Power
    5

    Default

    I will try to resolve problem with catymag solution. If I don’t have success, I will copy files from SD card.

  6. #5
    Member +
    Join Date
    Jul 2012
    Location
    Republic of Srpska, Bosnia
    Age
    38
    Posts
    37
    Rep Power
    5

    Default

    Unfortunately, this is not a problem with the socket pins.

    I noticed another detail: navigation is not charging its battery while working on the car Carger.

    Of course, I've tried multiple batteries.

  7. #6
    Garmin/GPS Systems GMod.

    Neil's Avatar
    Join Date
    Aug 2011
    Location
    Oz.
    Posts
    7,400
    Rep Power
    1434

    Default

    @ miroslavbl
    I guess you are wanting to try a firmware downgrade. I have renewed the link for v5.40 in the firmwares thread as you requested there. To downgrade from microSD you'll need to give v5.40 a higher number than the fw version already running on your unit, e.g. if it's running 6.20 rename 5.40 to 6.21 with RGN_Tool. You will also need to delete the existing GUPDATE.GCD from the unit's .System folder if present or you'll get a continuous loading loop while the sd is inserted.

    My advice would be to make a complete copy of the unit's internal memory if you don't have a recent one. I suggest run this command script from a min. size 4GiB sd:

    copydir,0:/,1:/BackUp/
    reboot

    It'll take a while so keep the unit on charge. If you find that GUPDATE.GCD is present on the backup, run this before downgrading the firmware:

    del,0:/.System/gupdate.gcd
    reboot
    'Thanking Posts' are banned. To thank someone, and/or to see hidden links and content, use the [Only registered and activated users can see links. ] button below left of the helpful post then refresh your browser [F5 key]. 'Thanking Posts' are banned.
    Please don't spam. Posts serving no purpose other than to thank or to ask about hidden links are trashed or deleted, it's GPSPower's policy. Please don't spam.
    [Only registered and activated users can see links. ] should make their first post as a new Intro Thread in [Only registered and activated users can see links. ].

  8. #7
    Member +
    Join Date
    Jul 2012
    Location
    Republic of Srpska, Bosnia
    Age
    38
    Posts
    37
    Rep Power
    5

    Default

    @neil

    I need firmware version 5.40, because I need ldr.bin file for complete navigation backup.

    Version 5.40 is currently working on my nuvi 1390.

    Do you think that the problem with the hardware or software? Maybe there is a break somewhere on the motherboard, maybe a socket pins is not a problem?

  9. #8
    Garmin/GPS Systems GMod.

    Neil's Avatar
    Join Date
    Aug 2011
    Location
    Oz.
    Posts
    7,400
    Rep Power
    1434

    Default

    In my experience this problem is with hardware, not software. The first thing is to rule out a bent or damaged usb pin as catymag suggested. The 1xxx series also has an inherent problem with the usb socket, especially happens with 14xx, but not unknown on 13xx. Often the soldered connections to the PCB fail and need to be reflowed, a delicate task but not hard if you have the right equipment. Sometimes the problem is due to a component failure on the board, which is harder/impossible to fix. Generally, if both data and charging are compromised it can be fixed with reflowing the connections. If it's only one of those that's a problem and provided the usb socket itself is ok then it's possibly a PCB problem and reflowing may or may not help. As your unit will charge but cannot be seen by PC in either MSM or preboot mode the problem is probably hardware problem of some kind. However, if you haven't already done so you should clear NV. On map page, press speed field>press and hold centre of speedo for ~5-6 seconds to reach Diagnostics Page>Developer Info>Nonvol Available>Clear nonvol>Yes. You will lose favourites, but if that's a big problem for you you can restore from the backup. It's worth a try. After that, do a firmware upgrade to V6.20 from microSD:/Garmin/gupdate.gcd even if the usb still won't work. Then clear nonvol again.
    'Thanking Posts' are banned. To thank someone, and/or to see hidden links and content, use the [Only registered and activated users can see links. ] button below left of the helpful post then refresh your browser [F5 key]. 'Thanking Posts' are banned.
    Please don't spam. Posts serving no purpose other than to thank or to ask about hidden links are trashed or deleted, it's GPSPower's policy. Please don't spam.
    [Only registered and activated users can see links. ] should make their first post as a new Intro Thread in [Only registered and activated users can see links. ].

 

 

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.