Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Page 1 of 3 123 LastLast
Results 1 to 10 of 24
  1. #1
    Member
    Join Date
    May 2013
    Location
    The Netherlands
    Age
    33
    Posts
    14
    Rep Power
    0

    help Nuvi 1695 won't get into computer mode anymore

    I have a Nuvi (Nulink) 1695. Somehow the map update went wrong and I decided to format the Nuvi's internal memory, while it was hooked up to the computer. I now know that you should never do that..

    From that point on, the Nuvi won't get into computer (or 'mass storage') mode anymore when I connect it to the computer. Instead it will only turn on or turn to a brighter screen and start charging, just like when you plug it into the car power outlet. I already tried a hard reset, that didn't work. Instead it now shows 'select locale' with nothing to chose from, every time the unit starts up. It still starts up all the way to the main screen though, and I can navigate all the settings and even go to map view, which is blank of course since there's no map installed anymore.

    I assume there's nothing wrong with the firmware, since it will still start up all the way. I just need it to get into computer/mass storage mode, so I can reinstall the maps! (and hopefully I can find a way to regenerate the file structure on the internal memory)

    Anyone any ideas? Thank you so much already!

  2.    Advertissements


  3. #2
    ☼ADMIN☼
    catymag's Avatar
    Join Date
    Nov 2007
    Location
    light side
    Posts
    23,636
    Rep Power
    5325

    Default

    Follow
    [Only registered and activated users can see links. ]
    No other way to restore it fine.
    Firmwares here
    [Only registered and activated users can see links. ]
    Updater (with instructions)
    [Only registered and activated users can see links. ]
    [Only registered and activated users can see links. ]
    [Only registered and activated users can see links. ]
    [Only registered and activated users can see links. ]

    [Only registered and activated users can see links. ]
    You have to navigate to get to the good.
    Nuvi1250/Nuvi 34xx/Nuvi 2200/Nuvi 66/Oregon 600/Galaxy S5 MM 6.0.1/TomTom GO/iGO Nextgen Avic,Basar,Isr.Gift/Navigon
    Please don't flood my pm box with questions you can post on forum!! You won't hear back from me.

  4. #3
    Member
    Join Date
    May 2013
    Location
    The Netherlands
    Age
    33
    Posts
    14
    Rep Power
    0

    Default

    Thank you for your reply!
    I've been reading on this forum a lot already and came across that post as well.

    I've been unable though to enter the preboot mode on my device. When I hold my finger in the left upper corner during start up, it will enter screen calibration mode.

    Also I've been unable so far to download firmware for the 1695 (or is that not required with this method?), apparently it's not a very popular model, although I liked it a lot until three days ago.

  5. #4
    ☼ADMIN☼
    catymag's Avatar
    Join Date
    Nov 2007
    Location
    light side
    Posts
    23,636
    Rep Power
    5325

    Default

    Entering preboot mode is mandatory to flash cure, if you get at least logo screen you can do it so try and retry till you succeed , read with care instructions in Updater.exe thread.
    To download firmware is easy:
    Code:
    Please Login or Register to see the links
    Nuvi waits for about 30 seconds in pre-boot mode, if you don't start flashing in this time, it goes to calibration procedure.
    [Only registered and activated users can see links. ]
    [Only registered and activated users can see links. ]

    [Only registered and activated users can see links. ]
    You have to navigate to get to the good.
    Nuvi1250/Nuvi 34xx/Nuvi 2200/Nuvi 66/Oregon 600/Galaxy S5 MM 6.0.1/TomTom GO/iGO Nextgen Avic,Basar,Isr.Gift/Navigon
    Please don't flood my pm box with questions you can post on forum!! You won't hear back from me.

  6. #5
    Navigation software expert

    lolypop000's Avatar
    Join Date
    May 2010
    Location
    EU
    Posts
    2,925
    Rep Power
    849

    Default

    Don't forget to install usb drivers:

    Code:
    Please Login or Register to see the links
    If you wish, you can [Only registered and activated users can see links. ]

  7. #6
    Member
    Join Date
    May 2013
    Location
    The Netherlands
    Age
    33
    Posts
    14
    Rep Power
    0

    Default

    Thank you so much! I will try this (now that I know that my device indeed goes into preboot mode) and let y'all know the results.

    It might take a couple days cause I'm on a Mac and all this software is for a PC, so I need to work around that.

  8. #7
    Member
    Join Date
    May 2013
    Location
    The Netherlands
    Age
    33
    Posts
    14
    Rep Power
    0

    Default

    So days turned into weeks and weeks turned into (two) months, but finally I tried to repair my device. It cost me the whole day (working on an aged and ultra slow laptop had a big part in that), but it WORKED!! Thank you guys so much! I haven't installed the map yet, it's downloading right now, but I'm confident that will work too. The device powers up like it used to though and everything looks fine. Thank you again!

  9. #8
    Garmin/GPS Systems GMod.

    Neil's Avatar
    Join Date
    Aug 2011
    Location
    Oz.
    Posts
    7,405
    Rep Power
    1434

    Default

    @volkerts
    Always good to hear back that a process has worked or otherwise. This kind of feedback is helpful regardless of timing. Pre-boot mode sometimes seems more difficult to attain with a bricked device but perseverance pays off as usual.
    As you've found it's best to use a PC as well and NEVER do a FAT32 reformat with a Mac.
    Last edited by Neil; 18th July 2013 at 23:13.
    'Thanking Posts' are banned. To thank someone, and/or to see hidden links and content, use the [Only registered and activated users can see links. ] button below left of the helpful post then refresh your browser [F5 key]. 'Thanking Posts' are banned.
    Please don't spam. Posts serving no purpose other than to thank or to ask about hidden links are trashed or deleted, it's GPSPower's policy. Please don't spam.
    [Only registered and activated users can see links. ] should make their first post as a new Intro Thread in [Only registered and activated users can see links. ].

  10. #9
    Member
    Join Date
    Mar 2015
    Location
    home
    Posts
    11
    Rep Power
    0

    Default

    hi,
    I have more or less the same problem,
    when I do this tutorial I can connect my garmin 1695 I see that navigator is empty, it is lick if it was formatted
    what can I do to continuing??

  11. #10
    ☼ADMIN☼
    catymag's Avatar
    Join Date
    Nov 2007
    Location
    light side
    Posts
    23,636
    Rep Power
    5325

    Default

    Create a Garmin folder in your nuvi, restart it and see if you have a garmindevice.xml file in this folder.
    If you have a backup copy original files, then run Garmin Express.
    [Only registered and activated users can see links. ]
    [Only registered and activated users can see links. ]

    [Only registered and activated users can see links. ]
    You have to navigate to get to the good.
    Nuvi1250/Nuvi 34xx/Nuvi 2200/Nuvi 66/Oregon 600/Galaxy S5 MM 6.0.1/TomTom GO/iGO Nextgen Avic,Basar,Isr.Gift/Navigon
    Please don't flood my pm box with questions you can post on forum!! You won't hear back from me.

 

 
Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.