Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Results 1 to 2 of 2
  1. #1
    Junior Member
    Join Date
    Mar 2013
    Rep Power

    Default Cure not working for Nuvi 2497 (2013 model)

    I was able to make the cure work a few times and the Nuvi would mount as a USB disk. However, after updater.exe to put back the original firmware, I can no longer get the cure to work again. I have gone back and forth a few times.

    With original firmware, my Nuvi reboots after loading maps with a white flash on the screen. Now, with the cure applied, I only see the Garmin logo and the Nuvi powers off immediately. I cannot mount as USB to further troubleshoot / remove bad files preventing a normal boot.

    Does the cure only work a few times? Is it possible I have something broken that prevents the cure from working?


  2.    Advertissements

  3. #2
    Navigation software expert

    lolypop000's Avatar
    Join Date
    May 2010
    Rep Power


    Try with this:

    [Only registered and activated users can see links. ]




Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.